<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<!-- WP_HEAD() START -->
<link rel="dns-prefetch" href="https://media.techpp.com">
<link rel="dns-prefetch" href="https://adservice.google.com/">

<!-- Search Engine Optimization by Rank Math PRO - https://s.rankmath.com/home -->
<title>How to Downgrade OxygenOS 12 to OxygenOS 11 on OnePlus 9/9 Pro - TechPP</title><link rel="preconnect" href="https://media.techpp.com" crossorigin=""><link rel="preload" href="https://media.techpp.com/wp-content/uploads/2020/08/techpp-favir.svg" as="image" imagesrcset="" imagesizes=""><link rel="preload" href="https://media.techpp.com/wp-content/uploads/2020/08/TechPP-2020.svg" as="image" imagesrcset="" imagesizes="">
<meta name="description" content="OnePlus finally started rolling out OxygenOS 12 for OnePlus 9 and 9 Pro. Unfortunately, the release is plagued by bugs, and if you want to downgrade to OxygenOS 11, here is a guide on how to downgrade OxygenOS 12.">
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large">
<link rel="canonical" href="https://techpp.com/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/">
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="How to Downgrade OxygenOS 12 to OxygenOS 11 on OnePlus 9/9 Pro - TechPP">
<meta property="og:description" content="OnePlus finally started rolling out OxygenOS 12 for OnePlus 9 and 9 Pro. Unfortunately, the release is plagued by bugs, and if you want to downgrade to OxygenOS 11, here is a guide on how to downgrade OxygenOS 12.">
<meta property="og:url" content="https://techpp.com/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/">
<meta property="og:site_name" content="TechPP">
<meta property="article:publisher" content="https://www.facebook.com/TechPP">
<meta property="article:tag" content="android 12">
<meta property="article:tag" content="how to guide">
<meta property="article:tag" content="oneplus">
<meta property="article:tag" content="oneplus 9">
<meta property="article:tag" content="oneplus 9 pro">
<meta property="article:tag" content="Oxygen OS">
<meta property="article:tag" content="OxygenOS">
<meta property="article:section" content="News">
<meta property="og:updated_time" content="2021-12-13T16:53:34+05:30">
<meta property="fb:app_id" content="245332046561855">
<meta property="og:image" content="https://media.techpp.com/wp-content/uploads/2021/12/Downgrade-OxygenOS-12-scaled-e1639393892838.jpg">
<meta property="og:image:secure_url" content="https://media.techpp.com/wp-content/uploads/2021/12/Downgrade-OxygenOS-12-scaled-e1639393892838.jpg">
<meta property="og:image:width" content="800">
<meta property="og:image:height" content="450">
<meta property="og:image:alt" content="Downgrade OxygenOS 12">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="How to Downgrade OxygenOS 12 to OxygenOS 11 on OnePlus 9/9 Pro - TechPP">
<meta name="twitter:description" content="OnePlus finally started rolling out OxygenOS 12 for OnePlus 9 and 9 Pro. Unfortunately, the release is plagued by bugs, and if you want to downgrade to OxygenOS 11, here is a guide on how to downgrade OxygenOS 12.">
<meta name="twitter:site" content="@techpp">
<meta name="twitter:creator" content="@shreyasochani">
<meta name="twitter:image" content="https://media.techpp.com/wp-content/uploads/2021/12/Downgrade-OxygenOS-12-scaled-e1639393892838.jpg">
<!-- /Rank Math WordPress SEO plugin -->

<link rel="alternate" type="application/rss+xml" title="TechPP » How to Downgrade OxygenOS 12 to OxygenOS 11 on OnePlus 9/9 Pro Comments Feed" href="https://techpp.com/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/feed/">
<link rel="stylesheet" id="ikva-icrp-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/74d95435075b.style.css" type="text/css" media="all">
<link rel="stylesheet" id="sp-ea-font-awesome-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/269550530cc1.font-awesome.min.css" type="text/css" media="all">
<link rel="stylesheet" id="sp-ea-style-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/c4efdde4de93.ea-style.css" type="text/css" media="all">
<style id="sp-ea-style-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="oxygen-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/af4ecbbd9d3a.oxygen.css" type="text/css" media="all">
<link rel="stylesheet" id="qc-choice-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/7b6e330b6126.style.min.css" type="text/css" media="all">
<link rel="stylesheet" id="ez-toc-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/364e9c4b3d60.screen.min.css" type="text/css" media="all">
<style id="ez-toc-inline-css" type="text/css">
div#ez-toc-container p.ez-toc-title {font-size: 20px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/a-funtion-for-techpp/assets/js/3.4.1/jquery.min.js?ver=220afd743d9e" id="jquery-js" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/a-funtion-for-techpp/assets/js/jquery.sticky.min.js?ver=8e8f0a52999a" id="stickyjoy-js-js" defer></script>
<script type="text/javascript" id="qc-choice-js-extra" src="data:text/javascript,%0A%2F%2A%20%3C%21%5BCDATA%5B%20%2A%2F%0Avar%20choice_cmp_config%20%3D%20%7B%22utid%22%3A%2206xgkTEwQx5jM%22%2C%22enabled%22%3A%22all%22%2C%22ccpa%22%3A%22%22%2C%22datalayer%22%3A%22true%22%7D%3B%0A%2F%2A%20%5D%5D%3E%20%2A%2F%0A" defer></script>
<script type="text/javascript" async="async" id="qc-choice-js" data-lazy-src="https://media.techpp.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=47af5ec57680" data-lazy-method="interaction" data-lazy-attributes="src"></script>
<link rel="https://api.w.org/" href="https://techpp.com/wp-json/"><link rel="alternate" type="application/json" href="https://techpp.com/wp-json/wp/v2/posts/182787"><link rel="alternate" type="application/json+oembed" href="https://techpp.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechpp.com%2F2021%2F12%2F13%2Fdowngrade-oxygenos-12-to-oxygenos-11-oneplus-9%2F">
<link rel="alternate" type="text/xml+oembed" href="https://techpp.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftechpp.com%2F2021%2F12%2F13%2Fdowngrade-oxygenos-12-to-oxygenos-11-oneplus-9%2F&amp;format=xml">
<script async crossorigin="anonymous" data-lazy-src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-7017902435008658" data-lazy-method="interaction" data-lazy-attributes="src"></script>
<style>img{height:auto}</style><!-- Google Tag Manager -->
<script src="data:text/javascript,%28function%28w%2Cd%2Cs%2Cl%2Ci%29%7Bw%5Bl%5D%3Dw%5Bl%5D%7C%7C%5B%5D%3Bw%5Bl%5D.push%28%7B%27gtm.start%27%3A%0Anew%20Date%28%29.getTime%28%29%2Cevent%3A%27gtm.js%27%7D%29%3Bvar%20f%3Dd.getElementsByTagName%28s%29%5B0%5D%2C%0Aj%3Dd.createElement%28s%29%2Cdl%3Dl%21%3D%27dataLayer%27%3F%27%26l%3D%27%2Bl%3A%27%27%3Bj.async%3Dtrue%3Bj.src%3D%0A%27https%3A%2F%2Fwww.googletagmanager.com%2Fgtm.js%3Fid%3D%27%2Bi%2Bdl%3Bf.parentNode.insertBefore%28j%2Cf%29%3B%0A%7D%29%28window%2Cdocument%2C%27script%27%2C%27dataLayer%27%2C%27GTM-PPZ9ZDL%27%29%3B" type="text/javascript" defer></script>
<!-- End Google Tag Manager -->
		<link rel="preconnect" href="https://pagead2.googlesyndication.com">
<link rel="preconnect" href="https://www.googletagmanager.com">
<link rel="preconnect" href="https://cdnjs.cloudflare.com">
<link rel="preconnect" href="https://adservice.google.com">
<link rel="preconnect" href="https://partner.googleadservices.com">
<link rel="preconnect" href="https://googleads.g.doubleclick.net">
<link rel="preconnect" href="https://www.google-analytics.com">

<script async onload="HockeyStack.init('acea7eb27d6e75cbf58213e449f83c')" data-lazy-src="https://cdn.jsdelivr.net/npm/hockeystack@latest/hockeystack.min.js" data-lazy-method="interaction" data-lazy-attributes="src"></script>
<!-- Schema & Structured Data For WP v1.9.91 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>

<link rel="icon" href="https://media.techpp.com/wp-content/uploads/2020/08/cropped-techpp-favir-150x150.png" sizes="32x32">
<link rel="icon" href="https://media.techpp.com/wp-content/uploads/2020/08/cropped-techpp-favir.png" sizes="192x192">
<link rel="apple-touch-icon" href="https://media.techpp.com/wp-content/uploads/2020/08/cropped-techpp-favir.png">
<meta name="msapplication-TileImage" content="https://media.techpp.com/wp-content/uploads/2020/08/cropped-techpp-favir.png">
		<style type="text/css" id="wp-custom-css">
			#customad, .techpp-content-add {

height: 250px;
width: 100%;
max-height: 280px;

}

 /* Force wp caption box to be 100% */
.wp-caption {
    width: 100% !important;
	  height: auto!important;
  }
  #content .wp-caption a img {
    max-width: 99.03225806%; 
    height: auto;
  }



img#site-logo

{
	width: 140px;
	height: 39px !important;
}

#post-date {
	font-size: 17px;
	height: 40px;
}

#highlights-container
{
	height: auto !important;
}

#article-highlights
{
    line-height: 30px;
    font-size: 17px;
    font-weight: 400;
	  height: auto !important;
	  width: 100%;
	  background-color: #f4f7fa;
    padding: 16px;
    border: 1px solid #a4afb7;
    border-radius: 4px;

	
}


.ez-toc-title {
    border-bottom-style: dashed;
    border-bottom-width: 2px;
	  border-bottom-color: grey;
	  min-height: 24px;
	  margin-bottom: 20px;
	padding-bottom: 10px;
    
}

div#ez-toc-container {
	
	width: 100%!important;

}

#ez-toc-container a  {

	color: #1a98ee;
}

div#ez-toc-container p.ez-toc-title  {
	padding-bottom: 10px;
}

.ez-toc-title-container {
	padding-bottom: 16px;
}



li::marker {
  color: #004e92;
   font-size: 20px;
	
}

..ct-image
{
	height: auto!important;
}

@media only screen and (max-width: 768px) {
	#matchedad {
		
		height: 1600px;
		width: 100%;
	}
}
		</style>
		<link rel="stylesheet" id="oxygen-cache-173033-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/ef7ec17fd32e.desktop-sidebar-subscription-173033.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-cache-164650-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/a47eebfd84c3.sidebar-related-0509-164650.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-cache-173032-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/140dc95c1f6f.mobile-below-article-subscription-173032.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-cache-173035-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/f94d57e42716.article-main-section-173035.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-cache-163931-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/90d5befdfb16.main-header-footer-163931.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-cache-164562-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/290323f80f1d.no-label-ad-below-post-164562.css" type="text/css" media="all">
<link rel="stylesheet" id="oxygen-universal-styles-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/1395f1b619b3.universal.css" type="text/css" media="all">
<!-- END OF WP_HEAD() -->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js'></script></head>
<body class="post-template-default single single-post postid-182787 single-format-standard  wp-embed-responsive oxygen-body">



						<header id="header-section" class="oxy-header-wrapper oxy-overlay-header oxy-header"><div id="site-header" class="oxy-header-row"><div class="oxy-header-container"><div id="_header_left-3-163931" class="oxy-header-left"><div id="mobile-hamburger" class="ct-code-block "><svg fill="#004e92" height="34px" width="34px" viewbox="0 0 32 32">
  <path d="M4,10h24c1.104,0,2-0.896,2-2s-0.896-2-2-2H4C2.896,6,2,6.896,2,8S2.896,10,4,10z M28,14H4c-1.104,0-2,0.896-2,2  s0.896,2,2,2h24c1.104,0,2-0.896,2-2S29.104,14,28,14z M28,22H4c-1.104,0-2,0.896-2,2s0.896,2,2,2h24c1.104,0,2-0.896,2-2  S29.104,22,28,22z">
  </path>
</svg></div><a id="link-36-163931" class="ct-link" href="https://techpp.com/" target="_self"><img id="site-logo" alt="TechPP" src="https://media.techpp.com/wp-content/uploads/2020/08/TechPP-2020.svg" class="ct-image" width="485" height="133" loading="eager"></a><div id="mobile-search-icon" class="ct-code-block "><svg xmlns="http://www.w3.org/2000/svg" fill="#004e92" width="24" height="24" viewbox="0 0 24 24"><path d="M23.809 21.646l-6.205-6.205c1.167-1.605 1.857-3.579 1.857-5.711 0-5.365-4.365-9.73-9.731-9.73-5.365 0-9.73 4.365-9.73 9.73 0 5.366 4.365 9.73 9.73 9.73 2.034 0 3.923-.627 5.487-1.698l6.238 6.238 2.354-2.354zm-20.955-11.916c0-3.792 3.085-6.877 6.877-6.877s6.877 3.085 6.877 6.877-3.085 6.877-6.877 6.877c-3.793 0-6.877-3.085-6.877-6.877z">
  </path>
</svg></div></div><div id="_header_center-4-163931" class="oxy-header-center"></div><div id="_header_right-5-163931" class="oxy-header-right"><nav id="nav-menu" class="ct-code-block"><div class="main-menu">
  <nav>
    <a href="https://techpp.com/category/news/">News</a>
    <a href="https://techpp.com/category/review-2/">Reviews</a>
    <a href="https://techpp.com/category/featured/">Featured</a>
    <a href="https://techpp.com/category/featured-downloads/">Downloads</a>
    <a href="https://techpp.com/category/tiny-tip/" style="">Guides</a>
    <a href="https://techpp.com/category/gadgets/android-gadgets/">Android</a>
    <a href="https://techpp.com/category/gadgets/iphone-gadgets/">iOS</a>
  </nav>
</div>

<div class="search-cse">
  <form class="example" action="https://techpp.com/search-results/"><input name="cx" type="hidden" value="partner-pub-7017902435008658:7cx88pseu0c">
    <input name="cof" type="hidden" value="FORID:11">
    <input name="ie" type="hidden" value="ISO-8859-1">
    <input name="q" type="text" placeholder="Search..">
    <button type="submit"><svg class="svgsearch" fill="#ffffff" width="24" height="24" viewbox="0 0 24 24"><path d="M23.809 21.646l-6.205-6.205c1.167-1.605 1.857-3.579 1.857-5.711 0-5.365-4.365-9.73-9.731-9.73-5.365 0-9.73 4.365-9.73 9.73 0 5.366 4.365 9.73 9.73 9.73 2.034 0 3.923-.627 5.487-1.698l6.238 6.238 2.354-2.354zm-20.955-11.916c0-3.792 3.085-6.877 6.877-6.877s6.877 3.085 6.877 6.877-3.085 6.877-6.877 6.877c-3.793 0-6.877-3.085-6.877-6.877z"></path></svg></button></form>
</div></nav></div></div></div></header>
		<section id="second-header" class=" ct-section "><div class="ct-section-inner-wrap"><div id="site-links" class="ct-code-block"><div class="desktop-mega-div">
  <div class="site-links-list">
    <a href="https://techpp.com/about/">About</a>
    <a href="https://techpp.com/contact/">Contact</a>
  </div>

  <div class="desktop-social-icon-list">
    <a class="social-icon facebook-icon" rel="nofollow" href="https://www.facebook.com/techpp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M22.675 0h-21.35c-.732 0-1.325.593-1.325 1.325v21.351c0 .731.593 1.324 1.325 1.324h11.495v-9.294h-3.128v-3.622h3.128v-2.671c0-3.1 1.893-4.788 4.659-4.788 1.325 0 2.463.099 2.795.143v3.24l-1.918.001c-1.504 0-1.795.715-1.795 1.763v2.313h3.587l-.467 3.622h-3.12v9.293h6.116c.73 0 1.323-.593 1.323-1.325v-21.35c0-.732-.593-1.325-1.325-1.325z">
        </path>
      </svg>
    </a>

    <a class="social-icon twitter-icon" rel="nofollow" href="https://twitter.com/techpp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z">
        </path>
      </svg>
    </a>

    <a class="social-icon youtube-icon" rel="nofollow" href="https://www.youtube.com/user/techppcom" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M19.615 3.184c-3.604-.246-11.631-.245-15.23 0-3.897.266-4.356 2.62-4.385 8.816.029 6.185.484 8.549 4.385 8.816 3.6.245 11.626.246 15.23 0 3.897-.266 4.356-2.62 4.385-8.816-.029-6.185-.484-8.549-4.385-8.816zm-10.615 12.816v-8l8 3.993-8 4.007z">
        </path>
      </svg>
    </a>

    <a class="social-icon instagram-icon" rel="nofollow" href="https://instagram.com/tech.pp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M12 2.163c3.204 0 3.584.012 4.85.07 3.252.148 4.771 1.691 4.919 4.919.058 1.265.069 1.645.069 4.849 0 3.205-.012 3.584-.069 4.849-.149 3.225-1.664 4.771-4.919 4.919-1.266.058-1.644.07-4.85.07-3.204 0-3.584-.012-4.849-.07-3.26-.149-4.771-1.699-4.919-4.92-.058-1.265-.07-1.644-.07-4.849 0-3.204.013-3.583.07-4.849.149-3.227 1.664-4.771 4.919-4.919 1.266-.057 1.645-.069 4.849-.069zm0-2.163c-3.259 0-3.667.014-4.947.072-4.358.2-6.78 2.618-6.98 6.98-.059 1.281-.073 1.689-.073 4.948 0 3.259.014 3.668.072 4.948.2 4.358 2.618 6.78 6.98 6.98 1.281.058 1.689.072 4.948.072 3.259 0 3.668-.014 4.948-.072 4.354-.2 6.782-2.618 6.979-6.98.059-1.28.073-1.689.073-4.948 0-3.259-.014-3.667-.072-4.947-.196-4.354-2.617-6.78-6.979-6.98-1.281-.059-1.69-.073-4.949-.073zm0 5.838c-3.403 0-6.162 2.759-6.162 6.162s2.759 6.163 6.162 6.163 6.162-2.759 6.162-6.163c0-3.403-2.759-6.162-6.162-6.162zm0 10.162c-2.209 0-4-1.79-4-4 0-2.209 1.791-4 4-4s4 1.791 4 4c0 2.21-1.791 4-4 4zm6.406-11.845c-.796 0-1.441.645-1.441 1.44s.645 1.44 1.441 1.44c.795 0 1.439-.645 1.439-1.44s-.644-1.44-1.439-1.44z">
        </path>
      </svg>
    </a>
  </div>

</div></div></div></section>            <div class="oxy-modal-backdrop top " style="background-color: rgba(0,0,0,0);" data-trigger="user_clicks_element" data-trigger-selector="#mobile-hamburger" data-trigger-time="5" data-trigger-time-unit="seconds" data-close-automatically="no" data-close-after-time="10" data-close-after-time-unit="seconds" data-trigger_scroll_amount="50" data-trigger_scroll_direction="down" data-scroll_to_selector="" data-time_inactive="60" data-time-inactive-unit="seconds" data-number_of_clicks="3" data-close_on_esc="on" data-number_of_page_views="3" data-close-after-form-submit="no" data-open-again="always_show" data-open-again-after-days="3">

                <div id="modal-90-163931" class="ct-modal"><div id="mobile-menu" class="ct-div-block"><nav id="mobile-menu-nav" class="ct-code-block"><div class="main-menu">
  <a href="https://techpp.com/category/news/">News</a>
  <a href="https://techpp.com/category/review-2/">Reviews</a>
  <a href="https://techpp.com/category/featured/">Featured</a>
  <a href="https://techpp.com/category/featured-downloads/">Downloads</a>
  <a href="https://techpp.com/category/tiny-tip/" style="">Guides</a>
  <a href="https://techpp.com/category/gadgets/android-gadgets/">Android</a>
  <a href="https://techpp.com/category/gadgets/iphone-gadgets/">iOS</a>
</div>

<div class="mobile-mega-div">
  <div class="site-links-list">
    <a href="https://techpp.com/about/">About</a>
    <a href="https://techpp.com/contact/">Contact</a>
  </div>

  <div class="social-icon-list">
    <a class="social-icon facebook-icon" href="https://www.facebook.com/techpp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M22.675 0h-21.35c-.732 0-1.325.593-1.325 1.325v21.351c0 .731.593 1.324 1.325 1.324h11.495v-9.294h-3.128v-3.622h3.128v-2.671c0-3.1 1.893-4.788 4.659-4.788 1.325 0 2.463.099 2.795.143v3.24l-1.918.001c-1.504 0-1.795.715-1.795 1.763v2.313h3.587l-.467 3.622h-3.12v9.293h6.116c.73 0 1.323-.593 1.323-1.325v-21.35c0-.732-.593-1.325-1.325-1.325z">
        </path>
      </svg>
    </a>

    <a class="social-icon twitter-icon" href="https://twitter.com/techpp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z">
        </path>
      </svg>
    </a>

    <a class="social-icon youtube-icon" href="https://www.youtube.com/user/techppcom" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M19.615 3.184c-3.604-.246-11.631-.245-15.23 0-3.897.266-4.356 2.62-4.385 8.816.029 6.185.484 8.549 4.385 8.816 3.6.245 11.626.246 15.23 0 3.897-.266 4.356-2.62 4.385-8.816-.029-6.185-.484-8.549-4.385-8.816zm-10.615 12.816v-8l8 3.993-8 4.007z">
        </path>
      </svg>
    </a>

    <a class="social-icon instagram-icon" href="https://instagram.com/tech.pp/" target="_blank">
      <svg width="24" height="24" viewbox="0 0 24 24">
        <path d="M12 2.163c3.204 0 3.584.012 4.85.07 3.252.148 4.771 1.691 4.919 4.919.058 1.265.069 1.645.069 4.849 0 3.205-.012 3.584-.069 4.849-.149 3.225-1.664 4.771-4.919 4.919-1.266.058-1.644.07-4.85.07-3.204 0-3.584-.012-4.849-.07-3.26-.149-4.771-1.699-4.919-4.92-.058-1.265-.07-1.644-.07-4.849 0-3.204.013-3.583.07-4.849.149-3.227 1.664-4.771 4.919-4.919 1.266-.057 1.645-.069 4.849-.069zm0-2.163c-3.259 0-3.667.014-4.947.072-4.358.2-6.78 2.618-6.98 6.98-.059 1.281-.073 1.689-.073 4.948 0 3.259.014 3.668.072 4.948.2 4.358 2.618 6.78 6.98 6.98 1.281.058 1.689.072 4.948.072 3.259 0 3.668-.014 4.948-.072 4.354-.2 6.782-2.618 6.979-6.98.059-1.28.073-1.689.073-4.948 0-3.259-.014-3.667-.072-4.947-.196-4.354-2.617-6.78-6.979-6.98-1.281-.059-1.69-.073-4.949-.073zm0 5.838c-3.403 0-6.162 2.759-6.162 6.162s2.759 6.163 6.162 6.163 6.162-2.759 6.162-6.163c0-3.403-2.759-6.162-6.162-6.162zm0 10.162c-2.209 0-4-1.79-4-4 0-2.209 1.791-4 4-4s4 1.791 4 4c0 2.21-1.791 4-4 4zm6.406-11.845c-.796 0-1.441.645-1.441 1.44s.645 1.44 1.441 1.44c.795 0 1.439-.645 1.439-1.44s-.644-1.44-1.439-1.44z">
        </path>
      </svg>
    </a>
  </div>

</div></nav></div></div>
            </div>
                    <div class="oxy-modal-backdrop top " style="background-color: rgba(0,0,0,0);" data-trigger="user_clicks_element" data-trigger-selector="#mobile-search-icon" data-trigger-time="5" data-trigger-time-unit="seconds" data-close-automatically="no" data-close-after-time="10" data-close-after-time-unit="seconds" data-trigger_scroll_amount="50" data-trigger_scroll_direction="down" data-scroll_to_selector="" data-time_inactive="60" data-time-inactive-unit="seconds" data-number_of_clicks="3" data-close_on_esc="on" data-number_of_page_views="3" data-close-after-form-submit="no" data-open-again="always_show" data-open-again-after-days="3">

                <div id="modal-91-163931" class="ct-modal"><div id="div_block-92-163931" class="ct-div-block"><nav id="mobile-search" class="ct-code-block"><div class="mobile-icon-logo">
  <img width="75" src="https://media.techpp.com/wp-content/uploads/2020/08/techpp-favir.svg" height="75" loading="eager">
</div>
<div class="mobile-search-cse">
  <form class="example" action="https://techpp.com/search-results/"><input name="cx" type="hidden" value="partner-pub-7017902435008658:7cx88pseu0c">
    <input name="cof" type="hidden" value="FORID:11">
    <input name="ie" type="hidden" value="ISO-8859-1">
    <input name="q" type="text" placeholder="Search..">
    <button type="submit"><svg class="svgsearch" fill="#ffffff" width="24" height="24" viewbox="0 0 24 24"><path d="M23.809 21.646l-6.205-6.205c1.167-1.605 1.857-3.579 1.857-5.711 0-5.365-4.365-9.73-9.731-9.73-5.365 0-9.73 4.365-9.73 9.73 0 5.366 4.365 9.73 9.73 9.73 2.034 0 3.923-.627 5.487-1.698l6.238 6.238 2.354-2.354zm-20.955-11.916c0-3.792 3.085-6.877 6.877-6.877s6.877 3.085 6.877 6.877-3.085 6.877-6.877 6.877c-3.793 0-6.877-3.085-6.877-6.877z"></path></svg></button></form>
</div></nav></div></div>
            </div>
        <article id="article-div" class="ct-div-block"><section id="article-information" class=" ct-section "><div class="ct-section-inner-wrap"><div id="div_block-202-164562" class="ct-div-block"><h1 id="article-title" class="ct-code-block">How to Downgrade OxygenOS 12 to OxygenOS 11 on OnePlus 9/9 Pro</h1><h2 id="article-subheading" class="ct-code-block">But you will lose all your data</h2><div id="post-date" class="ct-code-block">by: <a href="https://techpp.com/author/shreyas/" title="Posts by Shreyas Ochani" rel="author">Shreyas Ochani</a> - Last updated on: December 13th, 2021</div></div></div></section><section id="article-main" class=" ct-section"><div class="ct-section-inner-wrap"><div id="div-box" class="ct-div-block"><div id="highlights-container" class="ct-code-block"><div id="article-highlights">
  <span class="highlights-heading" style="margin-bottom: 8px; font-size: 20px; color: #677075;">Key Takeaways</span>
  <ul>
<li>OnePlus finally released the stable Oxygen OS 12 update for the OnePlus 9/9 Pro.</li>
<li>However, the update was filled with bugs and inconsistencies resulting in an underwhelming experience.</li>
<li>We will have a detailed look at how you can downgrade Oxygen OS 12 to Oxygen OS 11.</li>
</ul>
</div>
</div><div id="below-highlight" class="ct-code-block"></div><div id="article-container" class="ct-div-block"><aside id="aside-one" class="ct-div-block "><div id="desktop-share" class="ct-code-block "><script type="text/javascript" src="data:text/javascript,%0A%09document.title%20%3D%20document.getElementsByTagName%28%22H1%22%29%5B0%5D.innerHTML%3B%0A" defer></script>
<style>.social-share-btn{background-color:#004e92;border-radius:50%;padding:12px;width:48px;height:48px;margin-bottom:20px;display:grid;place-items:center}.social-share-btn:hover{background-color:#000428;border-color:transparent}.social-share-btn svg{fill:#fff}@media (max-width:767px){.social-share-btn{display:inline-block;margin-bottom:0px}}</style>
<div class="social-share-article">
	<a class="social-share-btn facebook" href="" rel="noopener noreferrer" target="_blank" title="Share on Facebook" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=' + encodeURIComponent(document.URL) + '&amp;t=' + encodeURIComponent(document.URL),'popup','width=600,height=600'); return false;"><svg viewbox="0 0 18 18"><path class="facebookTPP" d="M11.344,5.71c0-0.73,0.074-1.122,1.199-1.122h1.502V1.871h-2.404c-2.886,0-3.903,1.36-3.903,3.646v1.765h-1.8V10h1.8v8.128h3.601V10h2.403l0.32-2.718h-2.724L11.344,5.71z"></path></svg></a>
	<a class="social-share-btn twitter" href="" rel="noopener noreferrer" target="popup" title="Share on Twitter" onclick="window.open('https://twitter.com/intent/tweet?text=' + encodeURIComponent(document.title) + ':%20 ' + encodeURIComponent(document.URL)+' &amp;via=techpp','popup','width=600,height=600'); return false;"><svg viewbox="0 0 18 18"><path class="twitterTPP" d="M18.258,3.266c-0.693,0.405-1.46,0.698-2.277,0.857c-0.653-0.686-1.586-1.115-2.618-1.115c-1.98,0-3.586,1.581-3.586,3.53c0,0.276,0.031,0.545,0.092,0.805C6.888,7.195,4.245,5.79,2.476,3.654C2.167,4.176,1.99,4.781,1.99,5.429c0,1.224,0.633,2.305,1.596,2.938C2.999,8.349,2.445,8.19,1.961,7.925C1.96,7.94,1.96,7.954,1.96,7.97c0,1.71,1.237,3.138,2.877,3.462c-0.301,0.08-0.617,0.123-0.945,0.123c-0.23,0-0.456-0.021-0.674-0.062c0.456,1.402,1.781,2.422,3.35,2.451c-1.228,0.947-2.773,1.512-4.454,1.512c-0.291,0-0.575-0.016-0.855-0.049c1.588,1,3.473,1.586,5.498,1.586c6.598,0,10.205-5.379,10.205-10.045c0-0.153-0.003-0.305-0.01-0.456c0.7-0.499,1.308-1.12,1.789-1.827c-0.644,0.28-1.334,0.469-2.06,0.555C17.422,4.782,17.99,4.091,18.258,3.266"></path></svg></a>	
	<a class="social-share-btn whatsapp" href="" rel="noopener noreferrer" target="popup" title="Share on Whatsapp" onclick="window.open('whatsapp://send?text='+encodeURIComponent(document.title)+'%20 '+encodeURIComponent(document.URL),'popup','width=600,height=600');return false;"><svg viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path class="whatsappTPP" d="M17.472 14.382c-.297-.149-1.758-.867-2.03-.967-.273-.099-.471-.148-.67.15-.197.297-.767.966-.94 1.164-.173.199-.347.223-.644.075-.297-.15-1.255-.463-2.39-1.475-.883-.788-1.48-1.761-1.653-2.059-.173-.297-.018-.458.13-.606.134-.133.298-.347.446-.52.149-.174.198-.298.298-.497.099-.198.05-.371-.025-.52-.075-.149-.669-1.612-.916-2.207-.242-.579-.487-.5-.669-.51-.173-.008-.371-.01-.57-.01-.198 0-.52.074-.792.372-.272.297-1.04 1.016-1.04 2.479 0 1.462 1.065 2.875 1.213 3.074.149.198 2.096 3.2 5.077 4.487.709.306 1.262.489 1.694.625.712.227 1.36.195 1.871.118.571-.085 1.758-.719 2.006-1.413.248-.694.248-1.289.173-1.413-.074-.124-.272-.198-.57-.347m-5.421 7.403h-.004a9.87 9.87 0 01-5.031-1.378l-.361-.214-3.741.982.998-3.648-.235-.374a9.86 9.86 0 01-1.51-5.26c.001-5.45 4.436-9.884 9.888-9.884 2.64 0 5.122 1.03 6.988 2.898a9.825 9.825 0 012.893 6.994c-.003 5.45-4.437 9.884-9.885 9.884m8.413-18.297A11.815 11.815 0 0012.05 0C5.495 0 .16 5.335.157 11.892c0 2.096.547 4.142 1.588 5.945L.057 24l6.305-1.654a11.882 11.882 0 005.683 1.448h.005c6.554 0 11.89-5.335 11.893-11.893a11.821 11.821 0 00-3.48-8.413Z"></path></svg></a>
	<a class="social-share-btn telegram" href="" rel="noopener noreferrer" target="popup" title="Share on Telegram" onclick="window.open('https://t.me/share/url?url='+encodeURIComponent(document.URL)+'&amp;text='+encodeURIComponent(document.title),'popup','width=600,height=600');return false;"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path class="telegramTPP" d="M23.91 3.79L20.3 20.84c-.25 1.21-.98 1.5-2 .94l-5.5-4.07-2.66 2.57c-.3.3-.55.56-1.1.56-.72 0-.6-.27-.84-.95L6.3 13.7l-5.45-1.7c-1.18-.35-1.19-1.16.26-1.75l21.26-8.2c.97-.43 1.9.24 1.53 1.73z"></path></svg></a>
	<a class="social-share-btn email" href="" rel="noopener noreferrer" target="popup" title="Share on Email" onclick="window.open('mailto:?subject=' + encodeURIComponent(document.title) + '&amp;body=' + encodeURIComponent(document.URL),'popup','width=600,height=600'); return false;"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path class="emailTPP" d="M12 12.713l-11.985-9.713h23.97l-11.985 9.713zm0 2.574l-12-9.725v15.438h24v-15.438l-12 9.725z"></path></svg></a>
</div>
</div></aside><section id="article-section" class="ct-div-block"><div id="inner_content-80-164022" class="ct-inner-content"><div class="code-block code-block-3" style="margin: 8px 0; clear: both; width: 100%; height: 250px;">
<div class="no-visibility-check ai-check-3-75688688" data-insertion="after" data-selector=".ai-check-3-75688688" data-code="PGRpdiBjbGFzcz0iYWktYXR0cmlidXRlcyI+CjxzcGFuIGNsYXNzPSdhaS1jaGVjay1ibG9jayBhaS1jZnAnIGRhdGEtYWktYmxvY2s9JzMnIGRhdGEtYWktbGltaXQtY2xpY2tzLXBlci10aW1lPScyJyBkYXRhLWFpLWxpbWl0LWNsaWNrcy10aW1lPScxJyBkYXRhLWFpLWNmcC10aW1lPScxJz48L3NwYW4+CjwvZGl2Pgo8IS0tIFJPU19BVEZfcmVzcG9uc2l2ZSAtLT4KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6YmxvY2siCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi03MDE3OTAyNDM1MDA4NjU4IgogICAgIGRhdGEtYWQtc2xvdD0iNjY3OTcwOTg4OCIKICAgICBkYXRhLWFkLWZvcm1hdD0iYXV0byIKICAgICBkYXRhLWZ1bGwtd2lkdGgtcmVzcG9uc2l2ZT0idHJ1ZSI+PC9pbnM+CjxzY3JpcHQ+CiAgICAgKGFkc2J5Z29vZ2xlID0gd2luZG93LmFkc2J5Z29vZ2xlIHx8IFtdKS5wdXNoKHt9KTsKPC9zY3JpcHQ+" data-block="3"><span class="ai-check-block ai-cfp" data-ai-block="3" data-ai-limit-clicks-per-time="2" data-ai-limit-clicks-time="1" data-ai-cfp-time="1"></span></div>

</div>
<p>After weeks and months of testing, Oneplus has finally launched the stable update for the OnePlus 9 Pro. However, many users want to downgrade from OxygenOS 12 to OxygenOS 11 for various reasons.</p>
<p>First, the integration of ColorOS into OxygenOS has become a hindrance for some. The general inconsistencies at UI make for an unsatisfying experience for some. Second, specific bugs and slowdowns bother many users since this is a major software update.</p>
<p><a href="https://media.techpp.com/wp-content/uploads/2021/12/Downgrade-OxygenOS-12-scaled-e1639393892838.jpg"><img src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20800%20450'%2F%3E" alt="Downgrade OxygenOS 12" width="800" height="450" class="aligncenter size-full wp-image-182805" title="Downgrade OxygenOS 12 scaled e1639393892838" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/Downgrade-OxygenOS-12-scaled-e1639393892838.jpg"></a></p>
<p>But do not worry because we will take a detailed look at how you can downgrade your OnePlus 9 Pro from OxygenOS 12 to OxygenOS 11 with ease.</p>
<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-white">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Pre-Requisites" title="Pre-Requisites">Pre-Requisites</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Steps_to_downgrade_OxygenOS_12_to_OxygenOS_11" title="Steps to downgrade OxygenOS 12 to OxygenOS 11">Steps to downgrade OxygenOS 12 to OxygenOS 11</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Downgrade_OxygenOS_12_to_OxygenOS_11_with_ease" title="Downgrade OxygenOS 12 to OxygenOS 11 with ease">Downgrade OxygenOS 12 to OxygenOS 11 with ease</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Frequently_Asked_Questions" title="Frequently Asked Questions">Frequently Asked Questions</a><ul class="ez-toc-list-level-3"><li class="ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-5" href="#1_Is_there_any_way_to_downgrade_OxygenOS_12_without_wiping_data" title="1. Is there any way to downgrade OxygenOS 12 without wiping data?">1. Is there any way to downgrade OxygenOS 12 without wiping data?</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-6" href="#2_I_cannot_find_the_downgrade_package_under_the_local_upgrade_option_Why" title="2. I cannot find the downgrade package under the local upgrade option. Why?">2. I cannot find the downgrade package under the local upgrade option. Why?</a></li><li class="ez-toc-page-1 ez-toc-heading-level-3"><a class="ez-toc-link ez-toc-heading-7" href="#3_Why_have_I_not_received_the_OxygenOS_12_update_on_my_Oneplus_99_Pro" title="3. Why have I not received the OxygenOS 12 update on my Oneplus 9/9 Pro?">3. Why have I not received the OxygenOS 12 update on my Oneplus 9/9 Pro?</a></li></ul></li></ul></nav></div>
<h2><span class="ez-toc-section" id="Pre-Requisites"></span>Pre-Requisites<span class="ez-toc-section-end"></span></h2>
<ol>
<li>OnePlus 9/9 Pro running Oxygen OS 12.</li>
<li>Download Downgrade Zip<br>
<strong>OnePlus 9</strong><br>
i. <a href="https://oxygenos.oneplus.net/OnePlus9Oxygen_22.I.11_OTA_0110_all_2107082123_downgrade_65e1b0f1895c422d.zip" target="_blank" rel="noopener">India</a><br>
ii. <a href="https://oxygenos.oneplus.net/OnePlus9Oxygen_22.O.11_OTA_0110_all_2107082125_downgrade_059624cc7298428b.zip" target="_blank" rel="noopener">NA</a><br>
iii. <a href="https://oxygenos.oneplus.net/OnePlus9Oxygen_22.E.11_OTA_0110_all_2107082125_downgrade_09b1a0a810824761.zip" target="_blank" rel="noopener">Europe</a>
<p><strong>OnePlus 9 Pro</strong><br>
i. <a href="https://oxygenos.oneplus.net/OnePlus9ProOxygen_22.I.11_OTA_0110_all_2107082121_downgrade_66a1f653e8ee4eb5" target="_blank" rel="noopener">India</a><br>
ii. <a href="https://oxygenos.oneplus.net/OnePlus9ProOxygen_22.O.11_OTA_0110_all_2107082120_downgrade_2e0c2b9ecc3c4102.zip" target="_blank" rel="noopener">NA</a><br>
iii. <a href="https://oxygenos.oneplus.net/OnePlus9ProOxygen_22.E.11_OTA_0110_all_2107082125_downgrade_2a8892dd474c4472.zip" target="_blank" rel="noopener">Europe</a></p></li>
<li><a href="https://oxygenos.oneplus.net/OPLocalUpdate_For_Android12.apk" target="_blank" rel="noopener">Oxygen Updater apk</a> (Remove .zip from the file name after downloading and then install the APK)</li>
<li>Make sure the device has at least a 50% charge.</li>
</ol>
<p><strong><em>Before we start the downgrading process, make sure to perform a complete backup of the device as the downgrade process will factory reset your device.</em></strong></p>
<h2><span class="ez-toc-section" id="Steps_to_downgrade_OxygenOS_12_to_OxygenOS_11"></span>Steps to downgrade OxygenOS 12 to OxygenOS 11<span class="ez-toc-section-end"></span></h2>
<ol>
<li>Once you have downloaded the downgrade zip, place it in your internal storage, make sure it is not placed in any folder.</li>
<li>Now you need to rename the file from .jar to <strong>.zip</strong>. This is a critical step; otherwise, the device will not detect the downloaded zip file.<br>

		<style type="text/css">
			#gallery-1 {
				margin: auto;
			}
			#gallery-1 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 50%;
			}
			#gallery-1 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-1 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div id="gallery-1" class="gallery galleryid-182787 gallery-columns-2 gallery-size-full"><dl class="gallery-item">
			<dt class="gallery-icon portrait">
				<a href="https://techpp.com/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/downgrade-oxygen-os-12-2/"><img width="573" height="1280" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20573%201280'%2F%3E" class="attachment-full size-full" alt="rename file oxygen os 12" title="downgrade oxygen os 12 2" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/downgrade-oxygen-os-12-2.jpeg"></a>
			</dt></dl><dl class="gallery-item">
			<dt class="gallery-icon portrait">
				<a href="https://techpp.com/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/downgrade-oxygen-os-12-3/"><img width="573" height="1280" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20573%201280'%2F%3E" class="attachment-full size-full" alt="renaming file oxygen os 12" title="downgrade oxygen os 12 3" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/downgrade-oxygen-os-12-3.jpeg"></a>
			</dt></dl><br style="clear: both">
		</div>
</li>
<li>Launch the Oneplus updater app we downloaded earlier and hit the <strong>settings icon</strong> in the upper right corner of the screen.<br>
<img class="aligncenter size-full wp-image-182798" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20573%201280'%2F%3E" alt="oxygen updater" width="573" height="1280" title="downgrade oxygen os 12 1" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/downgrade-oxygen-os-12-1.jpeg"></li>
<li>Here, select the <strong>Local upgrade</strong> option and choose the downgrade package we downloaded earlier in phone storage.<br>
<img class="aligncenter size-full wp-image-182795" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20573%201280'%2F%3E" alt="local upgrade oxygen os 12" width="573" height="1280" title="downgrade oxygen os 12 4" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/downgrade-oxygen-os-12-4.jpeg"></li>
<li>Confirm the data wipe warning pop-up message, and it will now start installing the file.<br>
<img class="aligncenter size-full wp-image-182794" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20573%201280'%2F%3E" alt="downgrade oxygen os 12 confirmation" width="573" height="1280" title="downgrade oxygen os 12 5" loading="lazy" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/12/downgrade-oxygen-os-12-5.jpeg"></li>
<li>Once the installation is completed, click <strong>restart</strong>.</li>
<li>Boom, it will not wipe your device and downgrade Oxygen OS 12 to Oxygen OS 11 successfully.</li>
</ol>
<h2><span class="ez-toc-section" id="Downgrade_OxygenOS_12_to_OxygenOS_11_with_ease"></span>Downgrade OxygenOS 12 to OxygenOS 11 with ease<span class="ez-toc-section-end"></span></h2>
<p>Downgrading from OxygenOS 12 to OxygenOS 11 on your OnePlus 9/9 Pro should be easy with the steps we shared above. But as mentioned earlier, please backup all your important data as the device will be reset to factory settings during the downgrade process.</p>
<p>Let us know in the comments below if you found this guide helpful and if you successfully downgraded from OxygenOS 12 to OxygenOS 11 on your OnePlus 9/9 Pro with ease.</p>
<h2><span class="ez-toc-section" id="Frequently_Asked_Questions"></span>Frequently Asked Questions<span class="ez-toc-section-end"></span></h2>
<h3><span class="ez-toc-section" id="1_Is_there_any_way_to_downgrade_OxygenOS_12_without_wiping_data"></span>1. Is there any way to downgrade OxygenOS 12 without wiping data?<span class="ez-toc-section-end"></span></h3>
<p>Unfortunately, you cannot downgrade Oxygen OS 12 without losing data. Since it is a downgrade of the Android version, a data wipe is required to avoid problems after downgrading the device.</p>
<h3><span class="ez-toc-section" id="2_I_cannot_find_the_downgrade_package_under_the_local_upgrade_option_Why"></span>2. I cannot find the downgrade package under the local upgrade option. Why?<span class="ez-toc-section-end"></span></h3>
<p>The main reason the downgrade package is not visible is the file extension. It is crucial to rename the file from .jar to <strong>.zip</strong>; otherwise, the file will not be visible. Also, make sure you have downloaded the right download package for your OnePlus 9/9 Pro.</p>
<h3><span class="ez-toc-section" id="3_Why_have_I_not_received_the_OxygenOS_12_update_on_my_Oneplus_99_Pro"></span>3. Why have I not received the OxygenOS 12 update on my Oneplus 9/9 Pro?<span class="ez-toc-section-end"></span></h3>
<p>According to recent reports, as of December 12th, 2021, OnePlus has withdrawn the Oxygen OS 12 update for the OnePlus 9/9 Pro due to bugs. But do not worry because the company will rerelease the update in batches after fixing the issues.</p>
</div><div id="code_block-137-164022" class="ct-code-block"></div><div id="code_block-142-164022" class="ct-code-block"><div class="tags-container">
  <h3 class="tag-heading">Tags</h3>
</div>
<div class="tags-list">
  <a href="https://techpp.com/tag/android-12/">#android 12</a> <a href="https://techpp.com/tag/how-to-guide/">#how to guide</a> <a href="https://techpp.com/tag/oneplus/">#oneplus</a> <a href="https://techpp.com/tag/oneplus-9/">#oneplus 9</a> <a href="https://techpp.com/tag/oneplus-9-pro/">#oneplus 9 pro</a> <a href="https://techpp.com/tag/oxygen-os/">#Oxygen OS</a> <a href="https://techpp.com/tag/oxygenos/">#OxygenOS</a></div></div><div id="mobile-share" class="ct-code-block" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;"><div class="share-container">
  <h3 class="share-heading">Share post</h3>
</div>
<script type="text/javascript" src="data:text/javascript,%0A%09document.title%20%3D%20document.getElementsByTagName%28%22H1%22%29%5B0%5D.innerHTML%3B%0A" defer></script>
<style>.social-share-btn{background-color:#004e92;border-radius:50%;padding:12px;width:48px;height:48px;margin-bottom:20px;display:grid;place-items:center}.social-share-btn:hover{background-color:#000428;border-color:transparent}.social-share-btn svg{fill:#fff}@media (max-width:767px){.social-share-btn{display:inline-block;margin-bottom:0px}}</style>
<div class="social-share-article">
	<a class="social-share-btn facebook" href="" rel="noopener noreferrer" target="_blank" title="Share on Facebook" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=' + encodeURIComponent(document.URL) + '&amp;t=' + encodeURIComponent(document.URL),'popup','width=600,height=600'); return false;"><svg viewbox="0 0 18 18"><path class="facebookTPP" d="M11.344,5.71c0-0.73,0.074-1.122,1.199-1.122h1.502V1.871h-2.404c-2.886,0-3.903,1.36-3.903,3.646v1.765h-1.8V10h1.8v8.128h3.601V10h2.403l0.32-2.718h-2.724L11.344,5.71z"></path></svg></a>
	<a class="social-share-btn twitter" href="" rel="noopener noreferrer" target="popup" title="Share on Twitter" onclick="window.open('https://twitter.com/intent/tweet?text=' + encodeURIComponent(document.title) + ':%20 ' + encodeURIComponent(document.URL)+' &amp;via=techpp','popup','width=600,height=600'); return false;"><svg viewbox="0 0 18 18"><path class="twitterTPP" d="M18.258,3.266c-0.693,0.405-1.46,0.698-2.277,0.857c-0.653-0.686-1.586-1.115-2.618-1.115c-1.98,0-3.586,1.581-3.586,3.53c0,0.276,0.031,0.545,0.092,0.805C6.888,7.195,4.245,5.79,2.476,3.654C2.167,4.176,1.99,4.781,1.99,5.429c0,1.224,0.633,2.305,1.596,2.938C2.999,8.349,2.445,8.19,1.961,7.925C1.96,7.94,1.96,7.954,1.96,7.97c0,1.71,1.237,3.138,2.877,3.462c-0.301,0.08-0.617,0.123-0.945,0.123c-0.23,0-0.456-0.021-0.674-0.062c0.456,1.402,1.781,2.422,3.35,2.451c-1.228,0.947-2.773,1.512-4.454,1.512c-0.291,0-0.575-0.016-0.855-0.049c1.588,1,3.473,1.586,5.498,1.586c6.598,0,10.205-5.379,10.205-10.045c0-0.153-0.003-0.305-0.01-0.456c0.7-0.499,1.308-1.12,1.789-1.827c-0.644,0.28-1.334,0.469-2.06,0.555C17.422,4.782,17.99,4.091,18.258,3.266"></path></svg></a>	
	<a class="social-share-btn whatsapp" href="" rel="noopener noreferrer" target="popup" title="Share on Whatsapp" onclick="window.open('whatsapp://send?text='+encodeURIComponent(document.title)+'%20 '+encodeURIComponent(document.URL),'popup','width=600,height=600');return false;"><svg viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path class="whatsappTPP" d="M17.472 14.382c-.297-.149-1.758-.867-2.03-.967-.273-.099-.471-.148-.67.15-.197.297-.767.966-.94 1.164-.173.199-.347.223-.644.075-.297-.15-1.255-.463-2.39-1.475-.883-.788-1.48-1.761-1.653-2.059-.173-.297-.018-.458.13-.606.134-.133.298-.347.446-.52.149-.174.198-.298.298-.497.099-.198.05-.371-.025-.52-.075-.149-.669-1.612-.916-2.207-.242-.579-.487-.5-.669-.51-.173-.008-.371-.01-.57-.01-.198 0-.52.074-.792.372-.272.297-1.04 1.016-1.04 2.479 0 1.462 1.065 2.875 1.213 3.074.149.198 2.096 3.2 5.077 4.487.709.306 1.262.489 1.694.625.712.227 1.36.195 1.871.118.571-.085 1.758-.719 2.006-1.413.248-.694.248-1.289.173-1.413-.074-.124-.272-.198-.57-.347m-5.421 7.403h-.004a9.87 9.87 0 01-5.031-1.378l-.361-.214-3.741.982.998-3.648-.235-.374a9.86 9.86 0 01-1.51-5.26c.001-5.45 4.436-9.884 9.888-9.884 2.64 0 5.122 1.03 6.988 2.898a9.825 9.825 0 012.893 6.994c-.003 5.45-4.437 9.884-9.885 9.884m8.413-18.297A11.815 11.815 0 0012.05 0C5.495 0 .16 5.335.157 11.892c0 2.096.547 4.142 1.588 5.945L.057 24l6.305-1.654a11.882 11.882 0 005.683 1.448h.005c6.554 0 11.89-5.335 11.893-11.893a11.821 11.821 0 00-3.48-8.413Z"></path></svg></a>
	<a class="social-share-btn telegram" href="" rel="noopener noreferrer" target="popup" title="Share on Telegram" onclick="window.open('https://t.me/share/url?url='+encodeURIComponent(document.URL)+'&amp;text='+encodeURIComponent(document.title),'popup','width=600,height=600');return false;"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path class="telegramTPP" d="M23.91 3.79L20.3 20.84c-.25 1.21-.98 1.5-2 .94l-5.5-4.07-2.66 2.57c-.3.3-.55.56-1.1.56-.72 0-.6-.27-.84-.95L6.3 13.7l-5.45-1.7c-1.18-.35-1.19-1.16.26-1.75l21.26-8.2c.97-.43 1.9.24 1.53 1.73z"></path></svg></a>
	<a class="social-share-btn email" href="" rel="noopener noreferrer" target="popup" title="Share on Email" onclick="window.open('mailto:?subject=' + encodeURIComponent(document.title) + '&amp;body=' + encodeURIComponent(document.URL),'popup','width=600,height=600'); return false;"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path class="emailTPP" d="M12 12.713l-11.985-9.713h23.97l-11.985 9.713zm0 2.574l-12-9.725v15.438h24v-15.438l-12 9.725z"></path></svg></a>
</div>
</div><div id="code_block-212-164562" class="ct-code-block"><div class="code-block code-block-5" style="margin: 8px 0; clear: both;">
<div id="matchedad">
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-7017902435008658" data-ad-slot="1078769579"></ins>
<script src="data:text/javascript,%0A%20%20%20%20%20%28adsbygoogle%20%3D%20window.adsbygoogle%20%7C%7C%20%5B%5D%29.push%28%7B%7D%29%3B%0A" type="text/javascript" defer></script>
</div></div>
</div><div id="shortcode-3-173032" class="ct-shortcode "><div class="fluentform fluentform_wrapper_3"><form data-form_id="3" id="fluentform_3" class="frm-fluent-form fluent_form_3 ff-el-form-top ff_form_instance_3_1 ff-form-loading" data-form_instance="ff_form_instance_3_1" method="POST">        <span style="display: none !important;"><input type="checkbox" name="item__3__fluent_checkme_" value="1" style="display:none !important;" tabindex="-1"></span>
        <input type="hidden" name="__fluent_form_embded_post_id" value="182787"><input type="hidden" id="_fluentform_3_fluentformnonce" name="_fluentform_3_fluentformnonce" value="9d2b2db479"><input type="hidden" name="_wp_http_referer" value="/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/"><div class="ff-el-group ff-nw-header" data-name="custom_html-3_1"><h4 class="ff-nw-heading" style="font-size: 30px; line-height: 24px; font-weight: bold;"><span style="color: #ffffff;">Weekly Newsletter</span></h4>
<p class="ff-nw-text" style="font-size: 14px; line-height: 20px;"><span style="color: #ffffff;">Sign up for a specially curated Tech Newsletter.</span></p></div><div class="ff-el-group ff-el-form-hide_label ff-nw-email-container"><div class="ff-el-input--content"><input type="email" name="email" id="ff_3_email" class="ff-el-form-control ff-nw-email" placeholder="Enter email" data-name="email"></div></div><div class="ff-el-group ff-text-left ff-nw-sub-container ff_submit_btn_wrapper ff_submit_btn_wrapper_custom"><button class="ff-btn ff-btn-submit ff-btn-md ff-nw-sub ff_btn_style wpf_has_custom_css" type="submit" name="custom_submit_button-3_2" data-name="custom_submit_button-3_2">Subscribe</button><style>form.fluent_form_3 .wpf_has_custom_css.ff-btn-submit { background-color:rgba(0, 78, 146, 1);border-color:rgba(0, 78, 146, 1);color:#ffffff;min-width:100%; }form.fluent_form_3 .wpf_has_custom_css.ff-btn-submit:hover { background-color:rgba(5, 55, 99, 1);border-color:rgba(5, 55, 99, 1);color:#FFFFFF;min-width:100%; } </style></div><div class="ff-el-group ff-nw-footer" data-name="custom_html-3_3"><p class="ff-nw-policy"><span style="color: #ffffff;">By submitting your email, you agree to the Terms of Use and <a style="color: #ffffff;" href="https://techpp.com/about/privacy-policy/" target="_blank" rel="noopener">Privacy Policy</a>.</span></p></div></form><div id="fluentform_3_errors" class="ff-errors-in-stack ff_form_instance_3_1 ff-form-loading_errors ff_form_instance_3_1_errors"></div></div>        <script type="text/javascript" src="data:text/javascript,%0A%20%20%20%20%20%20%20%20%20%20%20%20window.fluent_form_ff_form_instance_3_1%20%3D%20%7B%22id%22%3A%223%22%2C%22settings%22%3A%7B%22layout%22%3A%7B%22labelPlacement%22%3A%22top%22%2C%22helpMessagePlacement%22%3A%22with_label%22%2C%22errorMessagePlacement%22%3A%22inline%22%2C%22asteriskPlacement%22%3A%22asterisk-right%22%7D%2C%22restrictions%22%3A%7B%22denyEmptySubmission%22%3A%7B%22enabled%22%3Afalse%7D%7D%7D%2C%22form_instance%22%3A%22ff_form_instance_3_1%22%2C%22form_id_selector%22%3A%22fluentform_3%22%2C%22rules%22%3A%7B%22email%22%3A%7B%22required%22%3A%7B%22value%22%3Afalse%2C%22message%22%3A%22This%20field%20is%20required%22%7D%2C%22email%22%3A%7B%22value%22%3Atrue%2C%22message%22%3A%22This%20field%20must%20contain%20a%20valid%20email%22%7D%7D%7D%7D%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20" defer></script>
        </div><div id="related-posts" class="ct-code-block" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;"><div class="related-container">
  <h3 class="related-heading">Related Articles</h3>
</div>

<div class="crp_related  "><div class="related-contex"><article class="contex-article"><a href="https://techpp.com/2020/08/01/oneplus-phone-buying-guide/" class="crp_link post-163524"><figure><img loading="lazy" width="334" height="188" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20188'%2F%3E" class="crp_thumb crp_featured" alt="From 7T to the Nord: Which is the right OnePlus for you?" title="From 7T to the Nord: Which is the right OnePlus for you?" data-origin-src="https://media.techpp.com/wp-content/uploads/2020/08/oneplus-buying-guide.jpg"></figure><span class="crp_title">From 7T to the Nord: Which is the right OnePlus for you?</span></a></article><article class="contex-article"><a href="https://techpp.com/2019/11/25/realme-x2-pro-vs-oneplus-7t-comparison/" class="crp_link post-154279"><figure><img loading="lazy" width="334" height="223" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20223'%2F%3E" class="crp_thumb crp_featured" alt="[Face Off] Realme X2 Pro vs OnePlus 7T" title="[Face Off] Realme X2 Pro vs OnePlus 7T" data-origin-src="https://media.techpp.com/wp-content/uploads/2019/11/realme-x2-pro-vs-oneplus-7t-14.jpg"></figure><span class="crp_title">[Face Off] Realme X2 Pro vs OnePlus 7T</span></a></article><article class="contex-article"><a href="https://techpp.com/2019/09/28/oneplus-7-pro-vs-oneplus-7t-comparison/" class="crp_link post-152412"><figure><img loading="lazy" width="334" height="223" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20223'%2F%3E" class="crp_thumb crp_featured" alt="OnePlus 7 Pro vs OnePlus 7T: To GoPro or GoT is the question" title="OnePlus 7 Pro vs OnePlus 7T: To GoPro or GoT is the question" data-origin-src="https://media.techpp.com/wp-content/uploads/2019/09/oneplus-7t-vs-oneplus-7-pro-10.jpg"></figure><span class="crp_title">OnePlus 7 Pro vs OnePlus 7T: To GoPro or GoT is the question</span></a></article><article class="contex-article"><a href="https://techpp.com/2021/04/08/oneplus-9r-first-impressions/" class="crp_link post-176158"><figure><img loading="lazy" width="334" height="234" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20234'%2F%3E" class="crp_thumb crp_featured" alt="[First cut] OnePlus 9R: Flagship killing potential" title="[First cut] OnePlus 9R: Flagship killing potential" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/04/oneplus-9r-review-6-334x234.jpg"></figure><span class="crp_title">[First cut] OnePlus 9R: Flagship killing potential</span></a></article><article class="contex-article"><a href="https://techpp.com/2021/03/18/redmi-note-10-pro-max-faq/" class="crp_link post-175577"><figure><img loading="lazy" width="334" height="234" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20234'%2F%3E" class="crp_thumb crp_featured" alt="Redmi Note 10 Pro and Redmi Note 10 Pro Max FAQ" title="Redmi Note 10 Pro and Redmi Note 10 Pro Max FAQ" data-origin-src="https://media.techpp.com/wp-content/uploads/2021/03/redmi-note-10-pro-max-review-20-1-334x234.jpg"></figure><span class="crp_title">Redmi Note 10 Pro and Redmi Note 10 Pro Max FAQ</span></a></article><article class="contex-article"><a href="https://techpp.com/2020/06/13/oneplus-8-pro-review/" class="crp_link post-160825"><figure><img loading="lazy" width="334" height="223" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg'%20viewBox%3D'0%200%20334%20223'%2F%3E" class="crp_thumb crp_featured" alt="OnePlus 8 Pro Review: Big Time for OnePlus!" title="OnePlus 8 Pro Review: Big Time for OnePlus!" data-origin-src="https://media.techpp.com/wp-content/uploads/2020/06/oneplus-8t-pro-review-1.jpg"></figure><span class="crp_title">OnePlus 8 Pro Review: Big Time for OnePlus!</span></a></article></div><div class="crp_clear"></div></div></div><section id="comment-div" class="ct-div-block" style="content-visibility:auto;contain-intrinsic-size:1px 1000px;"><div id="code_block-148-164022" class="ct-code-block"><div class="tags-container">
  <h3 class="tag-heading">Comments</h3>
</div></div>
                <div id="_comment_form-150-164022" class="oxy-comment-form">
                	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/#respond" style="display:none;">Cancel reply</a></small></h3><form action="" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required"></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required"></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"> <input type="hidden" name="comment_post_ID" value="182787" id="comment_post_ID">
<input type="hidden" name="comment_parent" id="comment_parent" value="0">
</p><p><input type="checkbox" name="comment_mail_notify" id="comment_mail_notify" value="comment_mail_notify" style="width: auto;"><label for="comment_mail_notify" style="margin-left:7px;display: inline;position: relative;top: 2px;">Email me when someone replies to my comment</label></p></form>	</div><!-- #respond -->
	                </div>
        
        
                <div id="_comments-151-164022" class="oxy-comments">
                </div>
        </section></section></div></div><aside id="aside-two" class="ct-div-block"><div id="related-sidebar" class="ct-code-block"><div class="code-block code-block-1 ai-track" data-ai="WzEsMCwiQmxvY2sgMSIsIiIsMV0=" style="margin: 8px 0; clear: both; height: 620px;">
<div class="no-visibility-check ai-check-1-35121929" data-insertion="after" data-selector=".ai-check-1-35121929" data-code="PGRpdiBjbGFzcz0iYWktYXR0cmlidXRlcyI+CjxkaXYgY2xhc3M9ImNvZGUtYmxvY2stbGFiZWwiPkFkPC9kaXY+CjxzcGFuIGNsYXNzPSdhaS1jaGVjay1ibG9jayBhaS1jZnAnIGRhdGEtYWktYmxvY2s9JzEnIGRhdGEtYWktbWF4LWNsaWNrcz0nMycgZGF0YS1haS1saW1pdC1jbGlja3MtcGVyLXRpbWU9JzInIGRhdGEtYWktbGltaXQtY2xpY2tzLXRpbWU9JzEnIGRhdGEtYWktaGFzaD0nMjI5NDMnIGRhdGEtYWktY2ZwLXRpbWU9JzEnPjwvc3Bhbj4KPC9kaXY+CjwhLS0gU2lkZWJhcl92ZXJ0aWNhbF9iYW5uZXJfcmVzcCAtLT4KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6aW5saW5lLWJsb2NrO3dpZHRoOjMwMHB4O2hlaWdodDo2MDBweCIKICAgICBkYXRhLWFkLWNsaWVudD0iY2EtcHViLTcwMTc5MDI0MzUwMDg2NTgiCiAgICAgZGF0YS1hZC1zbG90PSI0MDgwMDI5MTYyIj48L2lucz4KPHNjcmlwdD4KICAgICAoYWRzYnlnb29nbGUgPSB3aW5kb3cuYWRzYnlnb29nbGUgfHwgW10pLnB1c2goe30pOwo8L3NjcmlwdD4=" data-block="1"><span class="ai-check-block ai-cfp" data-ai-block="1" data-ai-max-clicks="3" data-ai-limit-clicks-per-time="2" data-ai-limit-clicks-time="1" data-ai-hash="22943" data-ai-cfp-time="1"></span></div>

</div>
</div><div id="newsletter-shortcode" class="ct-shortcode " style="content-visibility:auto;contain-intrinsic-size:1px 1000px;"><div class="fluentform fluentform_wrapper_3"><form data-form_id="3" id="fluentform_3" class="frm-fluent-form fluent_form_3 ff-el-form-top ff_form_instance_3_2 ff-form-loading" data-form_instance="ff_form_instance_3_2" method="POST">        <span style="display: none !important;"><input type="checkbox" name="item__3__fluent_checkme_" value="1" style="display:none !important;" tabindex="-1"></span>
        <input type="hidden" name="__fluent_form_embded_post_id" value="182787"><input type="hidden" id="_fluentform_3_fluentformnonce" name="_fluentform_3_fluentformnonce" value="9d2b2db479"><input type="hidden" name="_wp_http_referer" value="/2021/12/13/downgrade-oxygenos-12-to-oxygenos-11-oneplus-9/"><div class="ff-el-group ff-nw-header" data-name="custom_html-3_1"><h4 class="ff-nw-heading" style="font-size: 30px; line-height: 24px; font-weight: bold;"><span style="color: #ffffff;">Weekly Newsletter</span></h4>
<p class="ff-nw-text" style="font-size: 14px; line-height: 20px;"><span style="color: #ffffff;">Sign up for a specially curated Tech Newsletter.</span></p></div><div class="ff-el-group ff-el-form-hide_label ff-nw-email-container"><div class="ff-el-input--content"><input type="email" name="email" id="ff_3_email" class="ff-el-form-control ff-nw-email" placeholder="Enter email" data-name="email"></div></div><div class="ff-el-group ff-text-left ff-nw-sub-container ff_submit_btn_wrapper ff_submit_btn_wrapper_custom"><button class="ff-btn ff-btn-submit ff-btn-md ff-nw-sub ff_btn_style wpf_has_custom_css" type="submit" name="custom_submit_button-3_2" data-name="custom_submit_button-3_2">Subscribe</button><style>form.fluent_form_3 .wpf_has_custom_css.ff-btn-submit { background-color:rgba(0, 78, 146, 1);border-color:rgba(0, 78, 146, 1);color:#ffffff;min-width:100%; }form.fluent_form_3 .wpf_has_custom_css.ff-btn-submit:hover { background-color:rgba(5, 55, 99, 1);border-color:rgba(5, 55, 99, 1);color:#FFFFFF;min-width:100%; } </style></div><div class="ff-el-group ff-nw-footer" data-name="custom_html-3_3"><p class="ff-nw-policy"><span style="color: #ffffff;">By submitting your email, you agree to the Terms of Use and <a style="color: #ffffff;" href="https://techpp.com/about/privacy-policy/" target="_blank" rel="noopener">Privacy Policy</a>.</span></p></div></form><div id="fluentform_3_errors" class="ff-errors-in-stack ff_form_instance_3_2 ff-form-loading_errors ff_form_instance_3_2_errors"></div></div>        <script type="text/javascript" src="data:text/javascript,%0A%20%20%20%20%20%20%20%20%20%20%20%20window.fluent_form_ff_form_instance_3_2%20%3D%20%7B%22id%22%3A%223%22%2C%22settings%22%3A%7B%22layout%22%3A%7B%22labelPlacement%22%3A%22top%22%2C%22helpMessagePlacement%22%3A%22with_label%22%2C%22errorMessagePlacement%22%3A%22inline%22%2C%22asteriskPlacement%22%3A%22asterisk-right%22%7D%2C%22restrictions%22%3A%7B%22denyEmptySubmission%22%3A%7B%22enabled%22%3Afalse%7D%7D%7D%2C%22form_instance%22%3A%22ff_form_instance_3_2%22%2C%22form_id_selector%22%3A%22fluentform_3%22%2C%22rules%22%3A%7B%22email%22%3A%7B%22required%22%3A%7B%22value%22%3Afalse%2C%22message%22%3A%22This%20field%20is%20required%22%7D%2C%22email%22%3A%7B%22value%22%3Atrue%2C%22message%22%3A%22This%20field%20must%20contain%20a%20valid%20email%22%7D%7D%7D%7D%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20" defer></script>
        </div><div id="block-sidebar-bottom" class="ct-code-block"><div class="code-block code-block-2 ai-track" data-ai="WzIsMCwiQmxvY2sgMiIsIiIsMV0=" style="margin: 8px 0; clear: both; height: 620px;">
<div class="no-visibility-check ai-check-2-38316046" data-insertion="after" data-selector=".ai-check-2-38316046" data-code="PGRpdiBjbGFzcz0iYWktYXR0cmlidXRlcyI+CjxkaXYgY2xhc3M9ImNvZGUtYmxvY2stbGFiZWwiPkFkPC9kaXY+CjxzcGFuIGNsYXNzPSdhaS1jaGVjay1ibG9jayBhaS1jZnAnIGRhdGEtYWktYmxvY2s9JzInIGRhdGEtYWktbWF4LWNsaWNrcz0nMycgZGF0YS1haS1saW1pdC1jbGlja3MtcGVyLXRpbWU9JzInIGRhdGEtYWktbGltaXQtY2xpY2tzLXRpbWU9JzEnIGRhdGEtYWktaGFzaD0nMjIwMDQnIGRhdGEtYWktY2ZwLXRpbWU9JzEnPjwvc3Bhbj4KPC9kaXY+CjwhLS0gU2lkZWJhcl9zdGlja3lfcmVzcCAtLT4KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiCiAgICAgc3R5bGU9ImRpc3BsYXk6aW5saW5lLWJsb2NrO3dpZHRoOjMwMHB4O2hlaWdodDo2MDBweCIKICAgICBkYXRhLWFkLWNsaWVudD0iY2EtcHViLTcwMTc5MDI0MzUwMDg2NTgiCiAgICAgZGF0YS1hZC1zbG90PSIyMTYyMzAwNDIyIj48L2lucz4KPHNjcmlwdD4KICAgICAoYWRzYnlnb29nbGUgPSB3aW5kb3cuYWRzYnlnb29nbGUgfHwgW10pLnB1c2goe30pOwo8L3NjcmlwdD4=" data-block="2"><span class="ai-check-block ai-cfp" data-ai-block="2" data-ai-max-clicks="3" data-ai-limit-clicks-per-time="2" data-ai-limit-clicks-time="1" data-ai-hash="22004" data-ai-cfp-time="1"></span></div>

</div>
</div></aside></div></section></article><div id="anchor-block" class="ct-code-block"></div><footer id="footer-section" class=" ct-section"><div class="ct-section-inner-wrap"><div id="scroll-top" class="ct-code-block back_to_top"><svg viewbox="0 0 18 28" width="48px" height="48px" fill="#fff"><path d="M16.797 18.5c0 0.125-0.063 0.266-0.156 0.359l-0.781 0.781c-0.094 0.094-0.219 0.156-0.359 0.156-0.125 0-0.266-0.063-0.359-0.156l-6.141-6.141-6.141 6.141c-0.094 0.094-0.234 0.156-0.359 0.156s-0.266-0.063-0.359-0.156l-0.781-0.781c-0.094-0.094-0.156-0.234-0.156-0.359s0.063-0.266 0.156-0.359l7.281-7.281c0.094-0.094 0.234-0.156 0.359-0.156s0.266 0.063 0.359 0.156l7.281 7.281c0.094 0.094 0.156 0.234 0.156 0.359z">
  </path>
</svg></div><div id="code_block-142-163931" class="ct-code-block"></div><div id="site-footer" class="ct-div-block"><div id="copyright-text" class="ct-code-block">© 2008-2021. <a href="https://techpp.com/">Technology Personalized.</a> Made with <svg class="heart-svg" fill="#E81224" width="24" height="24" viewbox="0 0 24 24"><path d="M12 4.248c-3.148-5.402-12-3.825-12 2.944 0 4.661 5.571 9.427 12 15.808 6.43-6.381 12-11.147 12-15.808 0-6.792-8.875-8.306-12-2.944z"></path></svg> by <a rel="nofollow" href="https://joychetry.com/" target="_blank">crowwwn</a>.</div></div></div></footer>	<!-- WP_FOOTER -->
<!-- Google Tag Manager (noscript) -->
<noscript><iframe height="0" width="0" style="display:none;visibility:hidden" data-lazy-src="https://www.googletagmanager.com/ns.html?id=GTM-PPZ9ZDL" data-lazy-method="viewport" data-lazy-attributes="src"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
		
		<script type="text/javascript" src="data:text/javascript,%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Initialize%20Oxygen%20Modals%0A%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28document%29.ready%28function%28%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20function%20showModal%28%20modal%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24modal%20%3D%20jQuery%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.addClass%28%22live%22%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20modalId%20%3D%20%24modal%5B0%5D.querySelector%28%27.ct-modal%27%29.id%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Check%20if%20this%20modal%20can%20be%20shown%20according%20to%20settings%20and%20last%20shown%20time%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Current%20and%20last%20time%20in%20milliseconds%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20currentTime%20%3D%20new%20Date%28%29.getTime%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20lastShownTime%20%3D%20localStorage%20%26%26%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-last-shown-time%27%5D%20%3F%20JSON.parse%28%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-last-shown-time%27%5D%20%29%20%3A%20false%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20manual%20triggers%20aren%27t%20affected%20by%20last%20shown%20time%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.data%28%20%27trigger%27%20%29%20%21%3D%20%27user_clicks_element%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20switch%28%20%24modal.data%28%20%27open-again%27%20%29%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%27never_show_again%27%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20if%20it%20was%20shown%20at%20least%20once%2C%20don%27t%20show%20it%20again%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20lastShownTime%20%21%3D%3D%20false%20%29%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%27show_again_after%27%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20settingDays%20%3D%20parseInt%28%20%24modal.data%28%20%27open-again-after-days%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20actualDays%20%3D%20%28%20currentTime%20-%20lastShownTime%20%29%20%2F%20%28%2060%2A60%2A24%2A1000%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20actualDays%20%3C%20settingDays%20%29%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20default%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2Falways%20show%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20save%20current%20time%20as%20last%20shown%20time%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20localStorage%20%29%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-last-shown-time%27%5D%20%3D%20JSON.stringify%28%20currentTime%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20trick%20to%20make%20jQuery%20fadeIn%20with%20flex%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.css%28%22display%22%2C%20%22flex%22%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.hide%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20trick%20to%20force%20AOS%20trigger%20on%20elements%20inside%20the%20modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%22.aos-animate%22%29.removeClass%28%22aos-animate%22%29.addClass%28%22aos-animate-disabled%22%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20show%20the%20modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.fadeIn%28250%2C%20function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20trick%20to%20force%20AOS%20trigger%20on%20elements%20inside%20the%20modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%22.aos-animate-disabled%22%29.removeClass%28%22aos-animate-disabled%22%29.addClass%28%22aos-animate%22%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.data%28%20%27close-automatically%27%20%29%20%3D%3D%20%27yes%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20time%20%3D%20parseInt%28%20%24modal.data%28%20%27close-after-time%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.data%28%20%27close-after-time-unit%27%20%29%20%3D%3D%20%27seconds%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20time%20%3D%20parseInt%28%20parseFloat%28%20%24modal.data%28%20%27close-after-time%27%20%29%20%29%20%2A%201000%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28%20function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20time%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20close%20modal%20automatically%20after%20form%20submit%20%28Non-AJAX%29%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.data%28%20%27close-after-form-submit%27%20%29%20%3D%3D%20%27yes%27%20%26%26%20%24modal.data%28%22trigger%22%29%20%3D%3D%20%22after_specified_time%22%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20WPForms%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20WPForms%20replaces%20the%20form%20with%20a%20confirmation%20message%20on%20page%20refresh%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.find%28%22.wpforms-confirmation-container-full%22%29.length%20%3E%200%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%203000%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Formidable%20Forms%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Formidable%20Forms%20replaces%20the%20form%20with%20a%20confirmation%20message%20on%20page%20refresh%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.find%28%22.frm_message%22%29.length%20%3E%200%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%203000%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Caldera%20Forms%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Caldera%20Forms%20replaces%20the%20form%20with%20a%20confirmation%20message%20on%20page%20refresh%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.find%28%22.caldera-grid%20.alert-success%22%29.length%20%3E%200%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%203000%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20hideModal%20%3D%20function%20%28%20modal%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20The%20function%20may%20be%20called%20by%20third%20party%20code%2C%20without%20argument%2C%20so%20we%20must%20close%20the%20first%20visible%20modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20typeof%20modal%20%3D%3D%3D%20%27undefined%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20openModals%20%3D%20jQuery%28%22.oxy-modal-backdrop.live%22%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20openModals.length%20%3D%3D%200%20%29%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20modal%20%3D%20openModals%5B0%5D%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24modal%20%3D%20jQuery%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20refresh%20any%20iframe%20so%20media%20embedded%20this%20way%20is%20stopped%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%20%27iframe%27%29.each%28function%28index%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20this.src%20%3D%20this.src%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20HTML5%20videos%20can%20be%20stopped%20easily%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%20%27video%27%20%29.each%28function%28index%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20this.pause%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20If%20there%20are%20any%20forms%20in%20the%20modal%2C%20reset%20them%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%22form%22%29.each%28function%28index%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20this.reset%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.fadeOut%28400%2C%20function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.removeClass%28%22live%22%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.oxyCloseModal%20%3D%20hideModal%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20%22.oxy-modal-backdrop%22%20%29.each%28function%28%20index%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20modal%20%3D%20this%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%28function%28%20modal%20%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24modal%20%3D%20jQuery%28%20modal%20%29%3B%0A%09%09%09%09%09%09%0A%09%09%09%09%09%09var%20exitIntentFunction%20%3D%20function%28%20e%20%29%7B%0A%09%09%09%09%09%09%09if%28%20e.clientY%20%3C%3D%200%20%29%20%7B%0A%09%09%09%09%09%09%09%09showModal%28%20modal%20%29%3B%0A%09%09%09%09%09%09%09%09document.removeEventListener%28%20%22mouseleave%22%2C%20exitIntentFunction%20%29%3B%0A%09%09%09%09%09%09%09%09document.removeEventListener%28%20%22mouseout%22%2C%20exitIntentFunction%20%29%3B%0A%09%09%09%09%09%09%09%7D%0A%09%09%09%09%09%09%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20switch%20%28%20jQuery%28%20modal%20%29.data%28%22trigger%22%29%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22on_exit_intent%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22mouseleave%22%2C%20exitIntentFunction%2C%20false%29%3B%0A%09%09%09%09%09%09%09%09document.addEventListener%28%20%22mouseout%22%2C%20exitIntentFunction%2C%20false%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22user_clicks_element%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20jQuery%28%20modal%20%29.data%28%20%27trigger-selector%27%20%29%20%29.click%28%20function%28%20event%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20event.preventDefault%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22after_specified_time%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20time%20%3D%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27trigger-time%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20jQuery%28%20modal%20%29.data%28%20%27trigger-time-unit%27%20%29%20%3D%3D%20%27seconds%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20time%20%3D%20parseInt%28%20parseFloat%28%20jQuery%28%20modal%20%29.data%28%20%27trigger-time%27%20%29%20%29%20%2A%201000%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28%20function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20time%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22after_scrolled_amount%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.addEventListener%28%22scroll%22%2C%20function%20scrollDetection%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20winheight%3D%20window.innerHeight%20%7C%7C%20%28document.documentElement%20%7C%7C%20document.body%29.clientHeight%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20docheight%20%3D%20jQuery%28document%29.height%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20scrollTop%20%3D%20window.pageYOffset%20%7C%7C%20%28document.documentElement%20%7C%7C%20document.body.parentNode%20%7C%7C%20document.body%29.scrollTop%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20isScrollUp%20%3D%20false%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20oxyPreviousScrollTop%20%3D%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27previous_scroll_top%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%21isNaN%28%20oxyPreviousScrollTop%20%29%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20oxyPreviousScrollTop%20%3E%20scrollTop%29%20isScrollUp%20%3D%20true%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20modal%20%29.data%28%20%27previous_scroll_top%27%2C%20scrollTop%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20trackLength%20%3D%20docheight%20-%20winheight%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20pctScrolled%20%3D%20Math.floor%28scrollTop%2FtrackLength%20%2A%20100%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20isNaN%28%20pctScrolled%20%29%20%29%20pctScrolled%20%3D%200%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%28%20isScrollUp%20%26%26%20jQuery%28%20modal%20%29.data%28%20%27trigger_scroll_direction%27%20%29%20%3D%3D%20%27up%27%20%29%20%7C%7C%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%28%20%21isScrollUp%20%26%26%20jQuery%28%20modal%20%29.data%28%20%27trigger_scroll_direction%27%20%29%20%3D%3D%20%27down%27%20%26%26%20pctScrolled%20%3E%3D%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27trigger_scroll_amount%27%20%29%20%29%20%29%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.removeEventListener%28%20%22scroll%22%2C%20scrollDetection%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20false%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22on_scroll_to_element%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.addEventListener%28%22scroll%22%2C%20function%20scrollDetection%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24element%20%3D%20jQuery%28%20jQuery%28%20modal%20%29.data%28%20%27scroll_to_selector%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24element.length%20%3D%3D%200%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.removeEventListener%28%20%22scroll%22%2C%20scrollDetection%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20top_of_element%20%3D%20%24element.offset%28%29.top%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20bottom_of_element%20%3D%20%24element.offset%28%29.top%20%2B%20%24element.outerHeight%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20bottom_of_screen%20%3D%20jQuery%28window%29.scrollTop%28%29%20%2B%20jQuery%28window%29.innerHeight%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20top_of_screen%20%3D%20jQuery%28window%29.scrollTop%28%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%20%28%28bottom_of_screen%20%3E%20bottom_of_element%20-%20%24element.outerHeight%28%29%20%2F2%20%29%20%26%26%20%28top_of_screen%20%3C%20top_of_element%20%2B%20%24element.outerHeight%28%29%20%2F2%20%29%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20window.removeEventListener%28%20%22scroll%22%2C%20scrollDetection%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20false%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22after_number_of_clicks%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%22click%22%2C%20function%20clickDetection%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20number_of_clicks%20%3D%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27number_of_clicks%27%20%29%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20clicks_performed%20%3D%20isNaN%28%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27clicks_performed%27%20%29%20%29%20%29%20%3F%201%20%3A%20%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27clicks_performed%27%20%29%20%29%20%2B%201%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20modal%20%29.data%28%20%27clicks_performed%27%2C%20clicks_performed%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%20%28%20clicks_performed%20%3D%3D%20number_of_clicks%20%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.removeEventListener%28%20%22click%22%2C%20clickDetection%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20false%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22after_time_inactive%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20time%20%3D%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27time_inactive%27%20%29%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20jQuery%28%20modal%20%29.data%28%20%27time-inactive-unit%27%20%29%20%3D%3D%20%27seconds%27%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20time%20%3D%20parseInt%28%20parseFloat%28%20jQuery%28%20modal%20%29.data%28%20%27time_inactive%27%20%29%20%29%20%2A%201000%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20activityDetected%20%3D%20function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20modal%20%29.data%28%20%27millis_idle%27%2C%200%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22click%22%2C%20activityDetected%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22mousemove%22%2C%20activityDetected%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22keypress%22%2C%20activityDetected%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22scroll%22%2C%20activityDetected%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20idleInterval%20%3D%20setInterval%28function%28%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20millis_idle%20%3D%20isNaN%28%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27millis_idle%27%20%29%20%29%20%29%20%3F%20100%20%3A%20%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27millis_idle%27%20%29%20%29%20%2B%20100%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%20modal%20%29.data%28%20%27millis_idle%27%2C%20millis_idle%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20millis_idle%20%3E%20time%20%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20clearInterval%28%20idleInterval%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.removeEventListener%28%20%22click%22%2C%20activityDetected%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.removeEventListener%28%20%22mousemove%22%2C%20activityDetected%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.removeEventListener%28%20%22keypress%22%2C%20activityDetected%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.removeEventListener%28%20%22scroll%22%2C%20activityDetected%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20100%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20case%20%22after_number_of_page_views%22%3A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20modalId%20%3D%20modal.querySelector%28%27.ct-modal%27%29.id%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20pageViews%20%3D%20localStorage%20%26%26%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-page-views%27%5D%20%3F%20parseInt%28%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-page-views%27%5D%20%29%20%3A%200%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20pageViews%2B%2B%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20localStorage%20%29%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-page-views%27%5D%20%3D%20pageViews%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20parseInt%28%20jQuery%28%20modal%20%29.data%28%20%27number_of_page_views%27%20%29%20%29%20%3D%3D%20pageViews%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20localStorage%20%29%20localStorage%5B%27oxy-%27%20%2B%20modalId%20%2B%20%27-page-views%27%5D%20%3D%200%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20showModal%28%20modal%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20break%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20add%20event%20handler%20to%20close%20modal%20automatically%20after%20AJAX%20form%20submit%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.data%28%20%27close-after-form-submit%27%20%29%20%3D%3D%20%27yes%27%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Contact%20Form%207%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%20%28typeof%20wpcf7%20%21%3D%3D%20%27undefined%27%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%24modal.find%28%27div.wpcf7%27%29.each%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24form%20%3D%20jQuery%28this%29.find%28%27form%27%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20this.addEventListener%28%27wpcf7submit%27%2C%20function%20%28event%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%20%28event.detail.contactFormId%20%3D%3D%20%24form.attr%28%22id%22%29%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%203000%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%20false%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Caldera%20Forms%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20document.addEventListener%28%20%22cf.submission%22%2C%20function%28event%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Pending%2C%20Caldera%20AJAX%20form%20submissions%20aren%27t%20working%20since%20Oxygen%202.2%2C%20see%3A%20https%3A%2F%2Fgithub.com%2Fsoflyy%2Foxygen%2Fissues%2F1638%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20console.log%28%20event%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Ninja%20Forms%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28document%29.on%28%22nfFormSubmitResponse%22%2C%20function%28event%2C%20response%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Only%20close%20the%20modal%20if%20the%20event%20was%20triggered%20from%20a%20Ninja%20Form%20inside%20the%20modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24modal.find%28%22%23nf-form-%22%20%2B%20response.id%20%2B%20%22-cont%22%29.length%20%3E%200%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20setTimeout%28function%20%28%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28modal%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%2C%203000%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%28%20modal%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20handle%20clicks%20on%20modal%20backdrop%20and%20on%20.oxy-close-modal%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%22body%22%29.on%28%27click%20touchend%27%2C%20%27.oxy-modal-backdrop%2C%20.oxy-close-modal%27%2C%20function%28%20event%20%29%20%7B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24this%20%3D%20jQuery%28%20this%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24target%20%3D%20jQuery%28%20event.target%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2F%2F%20Click%20event%20in%20the%20modal%20div%20and%20it%27s%20children%20is%20propagated%20to%20the%20backdrop%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%21%24target.hasClass%28%20%27oxy-modal-backdrop%27%20%29%20%26%26%20%21%24this.hasClass%28%20%27oxy-close-modal%27%20%29%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20event.stopPropagation%28%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24target.hasClass%28%20%27oxy-modal-backdrop%27%20%29%20%26%26%20%24this.hasClass%28%20%27oxy-not-closable%27%20%29%20%29%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20return%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20%24this.hasClass%28%20%27oxy-close-modal%27%20%29%20%29%20event.preventDefault%28%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20var%20%24modal%20%3D%20%24this.hasClass%28%20%27oxy-close-modal%27%20%29%20%3F%20%24this.closest%28%27.oxy-modal-backdrop%27%29%20%3A%20%24this%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20hideModal%28%20%24modal%5B0%5D%20%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28document%29.keyup%28%20function%28e%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20e.key%20%3D%3D%20%27Escape%27%20%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20jQuery%28%22.oxy-modal-backdrop%3Avisible%22%29.each%28function%28index%29%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20if%28%20jQuery%28this%29.data%28%22close_on_esc%22%29%20%3D%3D%20%27on%27%20%29%20hideModal%28this%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%7D%20%29%3B%0A%0A%20%20%20%20%20%20%20%20%20%20%20%20%7D%29%3B%0A%0A%09%09" defer></script>

	<link rel="stylesheet" id="fluent-form-styles-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/e0d2cfc88c1e.fluent-forms-public.css" type="text/css" media="all">
<link rel="stylesheet" id="fluentform-public-default-css" href="https://media.techpp.com/wp-content/cache/flying-press/techpp.com/c1484ab617e0.fluentform-public-default.css" type="text/css" media="all">
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/flying-press/assets/preload.min.js?ver=4dcfe7c54278" id="flying_press_preload-js" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-includes/js/wp-embed.min.js?ver=905225d5711b" id="wp-embed-js" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=6a61ebde2088" id="jquery-smooth-scroll-js" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=0edaa42e837d" id="js-cookie-js" defer></script>
<script type="text/javascript" id="ez-toc-js-js-extra" src="data:text/javascript,%0A%2F%2A%20%3C%21%5BCDATA%5B%20%2A%2F%0Avar%20ezTOC%20%3D%20%7B%22smooth_scroll%22%3A%221%22%2C%22visibility_hide_by_default%22%3A%22%22%2C%22width%22%3A%22auto%22%2C%22scroll_offset%22%3A%2230%22%7D%3B%0A%2F%2A%20%5D%5D%3E%20%2A%2F%0A" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=a8b98e80b723" id="ez-toc-js-js" defer></script>
<script type="text/javascript" id="fluent-form-submission-js-extra" src="data:text/javascript,%0A%2F%2A%20%3C%21%5BCDATA%5B%20%2A%2F%0Avar%20fluentFormVars%20%3D%20%7B%22ajaxUrl%22%3A%22https%3A%5C%2F%5C%2Ftechpp.com%5C%2Fwp-admin%5C%2Fadmin-ajax.php%22%2C%22forms%22%3A%5B%5D%2C%22step_text%22%3A%22Step%20%25activeStep%25%20of%20%25totalStep%25%20-%20%25stepTitle%25%22%2C%22is_rtl%22%3A%22%22%2C%22date_i18n%22%3A%7B%22previousMonth%22%3A%22Previous%20Month%22%2C%22nextMonth%22%3A%22Next%20Month%22%2C%22months%22%3A%7B%22shorthand%22%3A%5B%22Jan%22%2C%22Feb%22%2C%22Mar%22%2C%22Apr%22%2C%22May%22%2C%22Jun%22%2C%22Jul%22%2C%22Aug%22%2C%22Sep%22%2C%22Oct%22%2C%22Nov%22%2C%22Dec%22%5D%2C%22longhand%22%3A%5B%22January%22%2C%22February%22%2C%22March%22%2C%22April%22%2C%22May%22%2C%22June%22%2C%22July%22%2C%22August%22%2C%22September%22%2C%22October%22%2C%22November%22%2C%22December%22%5D%7D%2C%22weekdays%22%3A%7B%22longhand%22%3A%5B%22Sunday%22%2C%22Monday%22%2C%22Tuesday%22%2C%22Wednesday%22%2C%22Thursday%22%2C%22Friday%22%2C%22Saturday%22%5D%2C%22shorthand%22%3A%5B%22Sun%22%2C%22Mon%22%2C%22Tue%22%2C%22Wed%22%2C%22Thu%22%2C%22Fri%22%2C%22Sat%22%5D%7D%2C%22daysInMonth%22%3A%5B31%2C28%2C31%2C30%2C31%2C30%2C31%2C31%2C30%2C31%2C30%2C31%5D%2C%22rangeSeparator%22%3A%22%20to%20%22%2C%22weekAbbreviation%22%3A%22Wk%22%2C%22scrollTitle%22%3A%22Scroll%20to%20increment%22%2C%22toggleTitle%22%3A%22Click%20to%20toggle%22%2C%22amPM%22%3A%5B%22AM%22%2C%22PM%22%5D%2C%22yearAriaLabel%22%3A%22Year%22%7D%2C%22pro_version%22%3A%224.2.0%22%2C%22fluentform_version%22%3A%224.2.21%22%2C%22force_init%22%3A%22%22%2C%22stepAnimationDuration%22%3A%22350%22%2C%22upload_completed_txt%22%3A%22100%25%20Completed%22%2C%22upload_start_txt%22%3A%220%25%20Completed%22%2C%22uploading_txt%22%3A%22Uploading%22%2C%22choice_js_vars%22%3A%7B%22noResultsText%22%3A%22No%20results%20found%22%2C%22loadingText%22%3A%22Loading...%22%2C%22noChoicesText%22%3A%22No%20choices%20to%20choose%20from%22%2C%22itemSelectText%22%3A%22Press%20to%20select%22%2C%22maxItemText%22%3A%22Only%20%25%25maxItemCount%25%25%20values%20can%20be%20added%22%7D%7D%3B%0Avar%20fluentFormVars%20%3D%20%7B%22ajaxUrl%22%3A%22https%3A%5C%2F%5C%2Ftechpp.com%5C%2Fwp-admin%5C%2Fadmin-ajax.php%22%2C%22forms%22%3A%5B%5D%2C%22step_text%22%3A%22Step%20%25activeStep%25%20of%20%25totalStep%25%20-%20%25stepTitle%25%22%2C%22is_rtl%22%3A%22%22%2C%22date_i18n%22%3A%7B%22previousMonth%22%3A%22Previous%20Month%22%2C%22nextMonth%22%3A%22Next%20Month%22%2C%22months%22%3A%7B%22shorthand%22%3A%5B%22Jan%22%2C%22Feb%22%2C%22Mar%22%2C%22Apr%22%2C%22May%22%2C%22Jun%22%2C%22Jul%22%2C%22Aug%22%2C%22Sep%22%2C%22Oct%22%2C%22Nov%22%2C%22Dec%22%5D%2C%22longhand%22%3A%5B%22January%22%2C%22February%22%2C%22March%22%2C%22April%22%2C%22May%22%2C%22June%22%2C%22July%22%2C%22August%22%2C%22September%22%2C%22October%22%2C%22November%22%2C%22December%22%5D%7D%2C%22weekdays%22%3A%7B%22longhand%22%3A%5B%22Sunday%22%2C%22Monday%22%2C%22Tuesday%22%2C%22Wednesday%22%2C%22Thursday%22%2C%22Friday%22%2C%22Saturday%22%5D%2C%22shorthand%22%3A%5B%22Sun%22%2C%22Mon%22%2C%22Tue%22%2C%22Wed%22%2C%22Thu%22%2C%22Fri%22%2C%22Sat%22%5D%7D%2C%22daysInMonth%22%3A%5B31%2C28%2C31%2C30%2C31%2C30%2C31%2C31%2C30%2C31%2C30%2C31%5D%2C%22rangeSeparator%22%3A%22%20to%20%22%2C%22weekAbbreviation%22%3A%22Wk%22%2C%22scrollTitle%22%3A%22Scroll%20to%20increment%22%2C%22toggleTitle%22%3A%22Click%20to%20toggle%22%2C%22amPM%22%3A%5B%22AM%22%2C%22PM%22%5D%2C%22yearAriaLabel%22%3A%22Year%22%7D%2C%22pro_version%22%3A%224.2.0%22%2C%22fluentform_version%22%3A%224.2.21%22%2C%22force_init%22%3A%22%22%2C%22stepAnimationDuration%22%3A%22350%22%2C%22upload_completed_txt%22%3A%22100%25%20Completed%22%2C%22upload_start_txt%22%3A%220%25%20Completed%22%2C%22uploading_txt%22%3A%22Uploading%22%2C%22choice_js_vars%22%3A%7B%22noResultsText%22%3A%22No%20results%20found%22%2C%22loadingText%22%3A%22Loading...%22%2C%22noChoicesText%22%3A%22No%20choices%20to%20choose%20from%22%2C%22itemSelectText%22%3A%22Press%20to%20select%22%2C%22maxItemText%22%3A%22Only%20%25%25maxItemCount%25%25%20values%20can%20be%20added%22%7D%7D%3B%0A%2F%2A%20%5D%5D%3E%20%2A%2F%0A" defer></script>
<script type="text/javascript" src="https://media.techpp.com/wp-content/plugins/fluentform/public/js/form-submission.js?ver=979b43cf5f76" id="fluent-form-submission-js" defer></script>
<script type="text/javascript" id="ct-footer-js"></script>
<script src="data:text/javascript,let%20commentForm%20%3D%20document.querySelector%28%22%23commentform%2C%20%23ast-commentform%2C%20%23fl-comment-form%2C%20%23ht-commentform%22%29%3Bdocument.onscroll%20%3D%20function%20%28%29%20%7BcommentForm.action%20%3D%20%22%2Fwp-comments-post.php%3F71435d5e3c6675a37a3fcd05a1ffd0ca%22%3B%7D%3B" type="text/javascript" defer></script>
<script type="text/javascript" id="ct_code_block_js_8" src="data:text/javascript,%28function%28%24%29%20%7B%0A%20%20%24%28%22%23desktop-share%22%29.sticky%28%7BtopSpacing%3A16%7D%29%3B%0A%7D%28jQuery%29%29%3B" defer></script>
<style type="text/css" id="ct_code_block_css_1">@media (max-width: 768px){
  #techpp.com_sidebar_300x600_responsive_1{
  display: none;
  }
}

.ct-inner-content iframe {
    width: 100%;
}
</style>
<script type="text/javascript" id="ct_code_block_js_4" src="data:text/javascript,%28function%28%24%29%20%7B%0A%20%20%24%28%22%23block-sidebar-bottom%22%29.sticky%28%7BtopSpacing%3A0%7D%29%3B%0A%7D%28jQuery%29%29%3B" defer></script>
<style type="text/css" id="ct_code_block_css_4">#block-sidebar-bottom-sticky-wrapper {
  align-self: stretch;
  width: 100%;
  min-height: 250px;
}</style>
<script type="text/javascript" id="ct_code_block_js_100106" src="data:text/javascript,%28function%28%29%20%7B%0A%20%20%27use%20strict%27%3B%0A%20%20function%20trackScroll%28%29%20%7B%0A%20%20%20%20var%20scrolled%20%3D%20window.pageYOffset%3B%0A%20%20%20%20var%20coords%20%3D%20document.documentElement.clientHeight%3B%0A%20%20%20%20if%20%28scrolled%20%3E%20coords%29%20%7B%0A%20%20%20%20%20%20goTopBtn.classList.add%28%27back_to_top-show%27%29%3B%0A%20%20%20%20%7D%0A%20%20%20%20if%20%28scrolled%20%3C%20coords%29%20%7B%0A%20%20%20%20%20%20goTopBtn.classList.remove%28%27back_to_top-show%27%29%3B%0A%20%20%20%20%7D%0A%20%20%7D%0A%20%20function%20backToTop%28%29%20%7B%0A%20%20%20%20if%20%28window.pageYOffset%20%3E%200%29%20%7B%0A%20%20%20%20%20%20window.scrollBy%280%2C%20-80%29%3B%0A%20%20%20%20%20%20setTimeout%28backToTop%2C%200%29%3B%0A%20%20%20%20%7D%0A%20%20%7D%0A%20%20var%20goTopBtn%20%3D%20document.querySelector%28%27.back_to_top%27%29%3B%0A%20%20window.addEventListener%28%27scroll%27%2C%20trackScroll%29%3B%0A%20%20goTopBtn.addEventListener%28%27click%27%2C%20backToTop%29%3B%0A%7D%29%28%29%3B" defer></script>
<script src="data:text/javascript,%0Afunction%20b2a%28a%29%7Bvar%20b%2Cc%3D0%2Cl%3D0%2Cf%3D%22%22%2Cg%3D%5B%5D%3Bif%28%21a%29return%20a%3Bdo%7Bvar%20e%3Da.charCodeAt%28c%2B%2B%29%3Bvar%20h%3Da.charCodeAt%28c%2B%2B%29%3Bvar%20k%3Da.charCodeAt%28c%2B%2B%29%3Bvar%20d%3De%3C%3C16%7Ch%3C%3C8%7Ck%3Be%3D63%26d%3E%3E18%3Bh%3D63%26d%3E%3E12%3Bk%3D63%26d%3E%3E6%3Bd%26%3D63%3Bg%5Bl%2B%2B%5D%3D%22ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789%2B%2F%3D%22.charAt%28e%29%2B%22ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789%2B%2F%3D%22.charAt%28h%29%2B%22ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789%2B%2F%3D%22.charAt%28k%29%2B%22ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789%2B%2F%3D%22.charAt%28d%29%7Dwhile%28c%3C%0D%0Aa.length%29%3Breturn%20f%3Dg.join%28%22%22%29%2Cb%3Da.length%253%2C%28b%3Ff.slice%280%2Cb-3%29%3Af%29%2B%22%3D%3D%3D%22.slice%28b%7C%7C3%29%7Dfunction%20a2b%28a%29%7Bvar%20b%2Cc%2Cl%2Cf%3D%7B%7D%2Cg%3D0%2Ce%3D0%2Ch%3D%22%22%2Ck%3DString.fromCharCode%2Cd%3Da.length%3Bfor%28b%3D0%3B64%3Eb%3Bb%2B%2B%29f%5B%22ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789%2B%2F%22.charAt%28b%29%5D%3Db%3Bfor%28c%3D0%3Bd%3Ec%3Bc%2B%2B%29for%28b%3Df%5Ba.charAt%28c%29%5D%2Cg%3D%28g%3C%3C6%29%2Bb%2Ce%2B%3D6%3B8%3C%3De%3B%29%28%28l%3D255%26g%3E%3E%3E%28e-%3D8%29%29%7C%7Cd-2%3Ec%29%26%26%28h%2B%3Dk%28l%29%29%3Breturn%20h%7Db64e%3Dfunction%28a%29%7Breturn%20btoa%28encodeURIComponent%28a%29.replace%28%2F%25%28%5B0-9A-F%5D%7B2%7D%29%2Fg%2Cfunction%28b%2Ca%29%7Breturn%20String.fromCharCode%28%220x%22%2Ba%29%7D%29%29%7D%3B%0D%0Ab64d%3Dfunction%28a%29%7Breturn%20decodeURIComponent%28atob%28a%29.split%28%22%22%29.map%28function%28a%29%7Breturn%22%25%22%2B%28%2200%22%2Ba.charCodeAt%280%29.toString%2816%29%29.slice%28-2%29%7D%29.join%28%22%22%29%29%7D%3B%0D%0A%2F%2A%20%3C%21%5BCDATA%5B%20%2A%2F%0Aai_front%20%3D%20%7B%22insertion_before%22%3A%22BEFORE%22%2C%22insertion_after%22%3A%22AFTER%22%2C%22insertion_prepend%22%3A%22PREPEND%20CONTENT%22%2C%22insertion_append%22%3A%22APPEND%20CONTENT%22%2C%22insertion_replace_content%22%3A%22REPLACE%20CONTENT%22%2C%22insertion_replace_element%22%3A%22REPLACE%20ELEMENT%22%2C%22visible%22%3A%22VISIBLE%22%2C%22hidden%22%3A%22HIDDEN%22%2C%22fallback%22%3A%22FALLBACK%22%2C%22automatically_placed%22%3A%22Automatically%20placed%20by%20AdSense%20Auto%20ads%20code%22%2C%22cancel%22%3A%22Cancel%22%2C%22use%22%3A%22Use%22%2C%22add%22%3A%22Add%22%2C%22parent%22%3A%22Parent%22%2C%22cancel_element_selection%22%3A%22Cancel%20element%20selection%22%2C%22select_parent_element%22%3A%22Select%20parent%20element%22%2C%22css_selector%22%3A%22CSS%20selector%22%2C%22use_current_selector%22%3A%22Use%20current%20selector%22%2C%22element%22%3A%22ELEMENT%22%2C%22path%22%3A%22PATH%22%2C%22selector%22%3A%22SELECTOR%22%7D%3B%0A%2F%2A%20%5D%5D%3E%20%2A%2F%0Afunction%20ai_run_scripts%28%29%7B%28function%28a%29%7Bif%28%22function%22%3D%3D%3Dtypeof%20define%26%26define.amd%29%7Bdefine%28a%29%3Bvar%20c%3D%210%7D%22object%22%3D%3D%3Dtypeof%20exports%26%26%28module.exports%3Da%28%29%2Cc%3D%210%29%3Bif%28%21c%29%7Bvar%20d%3Dwindow.Cookies%2Cb%3Dwindow.Cookies%3Da%28%29%3Bb.noConflict%3Dfunction%28%29%7Bwindow.Cookies%3Dd%3Breturn%20b%7D%7D%7D%29%28function%28%29%7Bfunction%20a%28%29%7Bfor%28var%20d%3D0%2Cb%3D%7B%7D%3Bd%3Carguments.length%3Bd%2B%2B%29%7Bvar%20f%3Darguments%5Bd%5D%2Ce%3Bfor%28e%20in%20f%29b%5Be%5D%3Df%5Be%5D%7Dreturn%20b%7Dfunction%20c%28d%29%7Bfunction%20b%28%29%7B%7Dfunction%20f%28h%2Ck%2Cg%29%7Bif%28%22undefined%22%21%3D%3Dtypeof%20document%29%7Bg%3Da%28%7Bpath%3A%22%2F%22%2CsameSite%3A%22Lax%22%7D%2Cb.defaults%2Cg%29%3B%22number%22%3D%3D%3Dtypeof%20g.expires%26%26%28g.expires%3D%0D%0Anew%20Date%281%2Anew%20Date%2B864E5%2Ag.expires%29%29%3Bg.expires%3Dg.expires%3Fg.expires.toUTCString%28%29%3A%22%22%3Btry%7Bvar%20l%3DJSON.stringify%28k%29%3B%2F%5E%5B%5C%7B%5C%5B%5D%2F.test%28l%29%26%26%28k%3Dl%29%7Dcatch%28p%29%7B%7Dk%3Dd.write%3Fd.write%28k%2Ch%29%3AencodeURIComponent%28String%28k%29%29.replace%28%2F%25%2823%7C24%7C26%7C2B%7C3A%7C3C%7C3E%7C3D%7C2F%7C3F%7C40%7C5B%7C5D%7C5E%7C60%7C7B%7C7D%7C7C%29%2Fg%2CdecodeURIComponent%29%3Bh%3DencodeURIComponent%28String%28h%29%29.replace%28%2F%25%2823%7C24%7C26%7C2B%7C5E%7C60%7C7C%29%2Fg%2CdecodeURIComponent%29.replace%28%2F%5B%5C%28%5C%29%5D%2Fg%2Cescape%29%3Bl%3D%22%22%3Bfor%28var%20n%20in%20g%29g%5Bn%5D%26%26%28l%2B%3D%22%3B%20%22%2Bn%2C%210%21%3D%3Dg%5Bn%5D%26%26%28l%2B%3D%22%3D%22%2Bg%5Bn%5D.split%28%22%3B%22%29%5B0%5D%29%29%3Breturn%20document.cookie%3D%0D%0Ah%2B%22%3D%22%2Bk%2Bl%7D%7Dfunction%20e%28h%2Ck%29%7Bif%28%22undefined%22%21%3D%3Dtypeof%20document%29%7Bfor%28var%20g%3D%7B%7D%2Cl%3Ddocument.cookie%3Fdocument.cookie.split%28%22%3B%20%22%29%3A%5B%5D%2Cn%3D0%3Bn%3Cl.length%3Bn%2B%2B%29%7Bvar%20p%3Dl%5Bn%5D.split%28%22%3D%22%29%2Cm%3Dp.slice%281%29.join%28%22%3D%22%29%3Bk%7C%7C%27%22%27%21%3D%3Dm.charAt%280%29%7C%7C%28m%3Dm.slice%281%2C-1%29%29%3Btry%7Bvar%20q%3Dp%5B0%5D.replace%28%2F%28%25%5B0-9A-Z%5D%7B2%7D%29%2B%2Fg%2CdecodeURIComponent%29%3Bm%3D%28d.read%7C%7Cd%29%28m%2Cq%29%7C%7Cm.replace%28%2F%28%25%5B0-9A-Z%5D%7B2%7D%29%2B%2Fg%2CdecodeURIComponent%29%3Bif%28k%29try%7Bm%3DJSON.parse%28m%29%7Dcatch%28r%29%7B%7Dg%5Bq%5D%3Dm%3Bif%28h%3D%3D%3Dq%29break%7Dcatch%28r%29%7B%7D%7Dreturn%20h%3Fg%5Bh%5D%3Ag%7D%7Db.set%3Df%3Bb.get%3Dfunction%28h%29%7Breturn%20e%28h%2C%211%29%7D%3Bb.getJSON%3Dfunction%28h%29%7Breturn%20e%28h%2C%0D%0A%210%29%7D%3Bb.remove%3Dfunction%28h%2Ck%29%7Bf%28h%2C%22%22%2Ca%28k%2C%7Bexpires%3A-1%7D%29%29%7D%3Bb.defaults%3D%7B%7D%3Bb.withConverter%3Dc%3Breturn%20b%7Dreturn%20c%28function%28%29%7B%7D%29%7D%29%3BAiCookies%3DCookies.noConflict%28%29%3B%0D%0Aai_check_block%3Dfunction%28a%29%7Bif%28null%3D%3Da%29return%210%3Bvar%20c%3DAiCookies.getJSON%28%22aiBLOCKS%22%29%3Bai_debug_cookie_status%3D%22%22%3Bnull%3D%3Dc%26%26%28c%3D%7B%7D%29%3B%22undefined%22%21%3D%3Dtypeof%20ai_delay_showing_pageviews%26%26%28c.hasOwnProperty%28a%29%7C%7C%28c%5Ba%5D%3D%7B%7D%29%2Cc%5Ba%5D.hasOwnProperty%28%22d%22%29%7C%7C%28c%5Ba%5D.d%3Dai_delay_showing_pageviews%29%29%3Bif%28c.hasOwnProperty%28a%29%29%7Bfor%28var%20d%20in%20c%5Ba%5D%29%7Bif%28%22x%22%3D%3Dd%29%7Bvar%20b%3D%22%22%2Cf%3Ddocument.querySelectorAll%28%27span%5Bdata-ai-block%3D%22%27%2Ba%2B%27%22%5D%27%29%5B0%5D%3B%22aiHash%22in%20f.dataset%26%26%28b%3Df.dataset.aiHash%29%3Bf%3D%22%22%3Bc%5Ba%5D.hasOwnProperty%28%22h%22%29%26%26%28f%3Dc%5Ba%5D.h%29%3Bvar%20e%3Dnew%20Date%3Be%3Dc%5Ba%5D%5Bd%5D-%0D%0AMath.round%28e.getTime%28%29%2F1E3%29%3Bif%280%3Ce%26%26f%3D%3Db%29return%20ai_debug_cookie_status%3Da%3D%22closed%20for%20%22%2Be%2B%22%20s%20%3D%20%22%2BMath.round%281E4%2Ae%2F3600%2F24%29%2F1E4%2B%22%20days%22%2C%211%3Bai_set_cookie%28a%2C%22x%22%2C%22%22%29%3Bc%5Ba%5D.hasOwnProperty%28%22i%22%29%7C%7Cc%5Ba%5D.hasOwnProperty%28%22c%22%29%7C%7Cai_set_cookie%28a%2C%22h%22%2C%22%22%29%7Delse%20if%28%22d%22%3D%3Dd%29%7Bif%280%21%3Dc%5Ba%5D%5Bd%5D%29return%20ai_debug_cookie_status%3Da%3D%22delayed%20for%20%22%2Bc%5Ba%5D%5Bd%5D%2B%22%20pageviews%22%2C%211%7Delse%20if%28%22i%22%3D%3Dd%29%7Bb%3D%22%22%3Bf%3Ddocument.querySelectorAll%28%27span%5Bdata-ai-block%3D%22%27%2Ba%2B%27%22%5D%27%29%5B0%5D%3B%22aiHash%22in%20f.dataset%26%26%28b%3Df.dataset.aiHash%29%3Bf%3D%22%22%3Bc%5Ba%5D.hasOwnProperty%28%22h%22%29%26%26%28f%3Dc%5Ba%5D.h%29%3B%0D%0Aif%280%3D%3Dc%5Ba%5D%5Bd%5D%26%26f%3D%3Db%29return%20ai_debug_cookie_status%3Da%3D%22max%20impressions%20reached%22%2C%211%3Bif%280%3Ec%5Ba%5D%5Bd%5D%26%26f%3D%3Db%29%7Be%3Dnew%20Date%3Be%3D-c%5Ba%5D%5Bd%5D-Math.round%28e.getTime%28%29%2F1E3%29%3Bif%280%3Ce%29return%20ai_debug_cookie_status%3Da%3D%22max%20imp.%20reached%20%28%22%2BMath.round%281E4%2Ae%2F24%2F3600%29%2F1E4%2B%22%20days%20%3D%20%22%2Be%2B%22%20s%29%22%2C%211%3Bai_set_cookie%28a%2C%22i%22%2C%22%22%29%3Bc%5Ba%5D.hasOwnProperty%28%22c%22%29%7C%7Cc%5Ba%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28a%2C%22h%22%2C%22%22%29%7D%7Dif%28%22ipt%22%3D%3Dd%26%260%3D%3Dc%5Ba%5D%5Bd%5D%26%26%28e%3Dnew%20Date%2Cb%3DMath.round%28e.getTime%28%29%2F1E3%29%2Ce%3Dc%5Ba%5D.it-b%2C0%3Ce%29%29return%20ai_debug_cookie_status%3Da%3D%22max%20imp.%20per%20time%20reached%20%28%22%2B%0D%0AMath.round%281E4%2Ae%2F24%2F3600%29%2F1E4%2B%22%20days%20%3D%20%22%2Be%2B%22%20s%29%22%2C%211%3Bif%28%22c%22%3D%3Dd%29%7Bb%3D%22%22%3Bf%3Ddocument.querySelectorAll%28%27span%5Bdata-ai-block%3D%22%27%2Ba%2B%27%22%5D%27%29%5B0%5D%3B%22aiHash%22in%20f.dataset%26%26%28b%3Df.dataset.aiHash%29%3Bf%3D%22%22%3Bc%5Ba%5D.hasOwnProperty%28%22h%22%29%26%26%28f%3Dc%5Ba%5D.h%29%3Bif%280%3D%3Dc%5Ba%5D%5Bd%5D%26%26f%3D%3Db%29return%20ai_debug_cookie_status%3Da%3D%22max%20clicks%20reached%22%2C%211%3Bif%280%3Ec%5Ba%5D%5Bd%5D%26%26f%3D%3Db%29%7Be%3Dnew%20Date%3Be%3D-c%5Ba%5D%5Bd%5D-Math.round%28e.getTime%28%29%2F1E3%29%3Bif%280%3Ce%29return%20ai_debug_cookie_status%3Da%3D%22max%20clicks%20reached%20%28%22%2BMath.round%281E4%2Ae%2F24%2F3600%29%2F1E4%2B%22%20days%20%3D%20%22%2Be%2B%22%20s%29%22%2C%211%3Bai_set_cookie%28a%2C%22c%22%2C%22%22%29%3Bc%5Ba%5D.hasOwnProperty%28%22i%22%29%7C%7C%0D%0Ac%5Ba%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28a%2C%22h%22%2C%22%22%29%7D%7Dif%28%22cpt%22%3D%3Dd%26%260%3D%3Dc%5Ba%5D%5Bd%5D%26%26%28e%3Dnew%20Date%2Cb%3DMath.round%28e.getTime%28%29%2F1E3%29%2Ce%3Dc%5Ba%5D.ct-b%2C0%3Ce%29%29return%20ai_debug_cookie_status%3Da%3D%22max%20clicks%20per%20time%20reached%20%28%22%2BMath.round%281E4%2Ae%2F24%2F3600%29%2F1E4%2B%22%20days%20%3D%20%22%2Be%2B%22%20s%29%22%2C%211%7Dif%28c.hasOwnProperty%28%22G%22%29%26%26c.G.hasOwnProperty%28%22cpt%22%29%26%260%3D%3Dc.G.cpt%26%26%28e%3Dnew%20Date%2Cb%3DMath.round%28e.getTime%28%29%2F1E3%29%2Ce%3Dc.G.ct-b%2C0%3Ce%29%29return%20ai_debug_cookie_status%3Da%3D%22max%20global%20clicks%20per%20time%20reached%20%28%22%2BMath.round%281E4%2Ae%2F24%2F3600%29%2F1E4%2B%22%20days%20%3D%20%22%2Be%2B%22%20s%29%22%2C%211%7Dai_debug_cookie_status%3D%0D%0A%22OK%22%3Breturn%210%7D%3B%0D%0Aai_check_and_insert_block%3Dfunction%28a%2Cc%29%7Bif%28null%3D%3Da%29return%210%3Bvar%20d%3Ddocument.getElementsByClassName%28c%29%3Bif%28d.length%29%7Bd%3Dd%5B0%5D%3Bvar%20b%3Dd.closest%28%22.code-block%22%29%2Cf%3Dai_check_block%28a%29%3B%21f%26%260%21%3DparseInt%28d.getAttribute%28%22limits-fallback%22%29%29%26%26d.hasAttribute%28%22data-fallback-code%22%29%26%26%28d.setAttribute%28%22data-code%22%2Cd.getAttribute%28%22data-fallback-code%22%29%29%2Cb.hasAttribute%28%22data-ai%22%29%26%26d.hasAttribute%28%22fallback-tracking%22%29%26%26d.hasAttribute%28%22fallback_level%22%29%26%26b.setAttribute%28%22data-ai-%22%2Bd.getAttribute%28%22fallback_level%22%29%2Cd.getAttribute%28%22fallback-tracking%22%29%29%2C%0D%0Af%3D%210%29%3Bif%28f%29ai_insert_code%28d%29%2Cb%26%26%28f%3Db.querySelectorAll%28%22.ai-debug-block%22%29%2Cb%26%26f.length%26%26%28b.classList.remove%28%22ai-list-block%22%29%2Cb.classList.remove%28%22ai-list-block-ip%22%29%2Cb.classList.remove%28%22ai-list-block-filter%22%29%2Cb.style.visibility%3D%22%22%2Cb.classList.contains%28%22ai-remove-position%22%29%26%26%28b.style.position%3D%22%22%29%29%29%3Belse%7Bf%3Dd.closest%28%22div%5Bdata-ai%5D%22%29%3Bif%28null%21%3Df%26%26%22undefined%22%21%3Dtypeof%20f.getAttribute%28%22data-ai%22%29%29%7Bvar%20e%3DJSON.parse%28b64d%28f.getAttribute%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20e%26%26e.constructor%3D%3D%3DArray%26%26%28e%5B1%5D%3D%22%22%2Cf.setAttribute%28%22data-ai%22%2C%0D%0Ab64e%28JSON.stringify%28e%29%29%29%29%7Df%3Db.querySelectorAll%28%22.ai-debug-block%22%29%3Bb%26%26f.length%26%26%28b.classList.remove%28%22ai-list-block%22%29%2Cb.classList.remove%28%22ai-list-block-ip%22%29%2Cb.classList.remove%28%22ai-list-block-filter%22%29%2Cb.style.visibility%3D%22%22%2Cb.classList.contains%28%22ai-remove-position%22%29%26%26%28b.style.position%3D%22%22%29%29%7Dd.classList.remove%28c%29%7Dd%3Ddocument.querySelectorAll%28%22.%22%2Bc%2B%22-dbg%22%29%3Bb%3D0%3Bfor%28f%3Dd.length%3Bb%3Cf%3Bb%2B%2B%29e%3Dd%5Bb%5D%2Ce.querySelector%28%22.ai-status%22%29.textContent%3Dai_debug_cookie_status%2Ce.querySelector%28%22.ai-cookie-data%22%29.textContent%3Dai_get_cookie_text%28a%29%2C%0D%0Ae.classList.remove%28c%2B%22-dbg%22%29%7D%3Bfunction%20ai_load_cookie%28%29%7Bvar%20a%3DAiCookies.getJSON%28%22aiBLOCKS%22%29%3Bnull%3D%3Da%26%26%28a%3D%7B%7D%29%3Breturn%20a%7Dfunction%20ai_get_cookie%28a%2Cc%29%7Bvar%20d%3D%22%22%2Cb%3Dai_load_cookie%28%29%3Bb.hasOwnProperty%28a%29%26%26b%5Ba%5D.hasOwnProperty%28c%29%26%26%28d%3Db%5Ba%5D%5Bc%5D%29%3Breturn%20d%7D%0D%0Afunction%20ai_set_cookie%28a%2Cc%2Cd%29%7Bvar%20b%3Dai_load_cookie%28%29%3Bif%28%22%22%3D%3D%3Dd%29%7Bif%28b.hasOwnProperty%28a%29%29%7Bdelete%20b%5Ba%5D%5Bc%5D%3Ba%3A%7Bc%3Db%5Ba%5D%3Bfor%28f%20in%20c%29if%28c.hasOwnProperty%28f%29%29%7Bvar%20f%3D%211%3Bbreak%20a%7Df%3D%210%7Df%26%26delete%20b%5Ba%5D%7D%7Delse%20b.hasOwnProperty%28a%29%7C%7C%28b%5Ba%5D%3D%7B%7D%29%2Cb%5Ba%5D%5Bc%5D%3Dd%3B0%3D%3D%3DObject.keys%28b%29.length%26%26b.constructor%3D%3D%3DObject%3FAiCookies.remove%28%22aiBLOCKS%22%29%3AAiCookies.set%28%22aiBLOCKS%22%2Cb%2C%7Bexpires%3A365%2Cpath%3A%22%2F%22%7D%29%3Breturn%20b%7D%0D%0Aai_get_cookie_text%3Dfunction%28a%29%7Bvar%20c%3DAiCookies.getJSON%28%22aiBLOCKS%22%29%3Bnull%3D%3Dc%26%26%28c%3D%7B%7D%29%3Bvar%20d%3D%22%22%3Bc.hasOwnProperty%28%22G%22%29%26%26%28d%3D%22G%5B%22%2BJSON.stringify%28c.G%29.replace%28%2F%22%2Fg%2C%22%22%29.replace%28%22%7B%22%2C%22%22%29.replace%28%22%7D%22%2C%22%22%29%2B%22%5D%20%22%29%3Bvar%20b%3D%22%22%3Bc.hasOwnProperty%28a%29%26%26%28b%3DJSON.stringify%28c%5Ba%5D%29.replace%28%2F%22%2Fg%2C%22%22%29.replace%28%22%7B%22%2C%22%22%29.replace%28%22%7D%22%2C%22%22%29%29%3Breturn%20d%2Bb%7D%3B%0D%0Aai_insert%3Dfunction%28c%2Ch%2Ct%29%7Bfor%28var%20n%3D-1%21%3Dh.indexOf%28%22%3Aeq%22%29%3FjQuery%28h%29%3Adocument.querySelectorAll%28h%29%2Cu%3D0%2Cy%3Dn.length%3Bu%3Cy%3Bu%2B%2B%29%7Bvar%20b%3Dn%5Bu%5D%3Bselector_string%3Db.hasAttribute%28%22id%22%29%3F%22%23%22%2Bb.getAttribute%28%22id%22%29%3Ab.hasAttribute%28%22class%22%29%3F%22.%22%2Bb.getAttribute%28%22class%22%29.replace%28RegExp%28%22%20%22%2C%22g%22%29%2C%22.%22%29%3A%22%22%3Bvar%20v%3Ddocument.createElement%28%22div%22%29%3Bv.innerHTML%3Dt%3Bvar%20m%3Dv.getElementsByClassName%28%22ai-selector-counter%22%29%5B0%5D%3Bnull%21%3Dm%26%26%28m.innerText%3Du%2B1%29%3Bm%3Dv.getElementsByClassName%28%22ai-debug-name%20ai-main%22%29%5B0%5D%3Bif%28null%21%3Dm%29%7Bvar%20l%3D%22%22%3B%22before%22%3D%3Dc%3Fl%3D%0Aai_front.insertion_before%3A%22after%22%3D%3Dc%3Fl%3Dai_front.insertion_after%3A%22prepend%22%3D%3Dc%3Fl%3Dai_front.insertion_prepend%3A%22append%22%3D%3Dc%3Fl%3Dai_front.insertion_append%3A%22replace-content%22%3D%3Dc%3Fl%3Dai_front.insertion_replace_content%3A%22replace-element%22%3D%3Dc%26%26%28l%3Dai_front.insertion_replace_element%29%3B-1%3D%3Dselector_string.indexOf%28%22.ai-viewports%22%29%26%26%28m.innerText%3Dl%2B%22%20%22%2Bh%2B%22%20%28%22%2Bb.tagName.toLowerCase%28%29%2Bselector_string%2B%22%29%22%29%7Dm%3Ddocument.createRange%28%29%3Bl%3D%210%3Btry%7Bvar%20w%3Dm.createContextualFragment%28v.innerHTML%29%7Dcatch%28r%29%7Bl%3D%211%7D%22before%22%3D%3Dc%3Fl%3Fb.parentNode.insertBefore%28w%2C%0Ab%29%3AjQuery%28v.innerHTML%29.insertBefore%28jQuery%28b%29%29%3A%22after%22%3D%3Dc%3Fl%3Fb.parentNode.insertBefore%28w%2Cb.nextSibling%29%3AjQuery%28v.innerHTML%29.insertBefore%28jQuery%28b.nextSibling%29%29%3A%22prepend%22%3D%3Dc%3Fl%3Fb.insertBefore%28w%2Cb.firstChild%29%3AjQuery%28v.innerHTML%29.insertBefore%28jQuery%28b.firstChild%29%29%3A%22append%22%3D%3Dc%3Fl%3Fb.insertBefore%28w%2Cnull%29%3AjQuery%28v.innerHTML%29.appendTo%28jQuery%28b%29%29%3A%22replace-content%22%3D%3Dc%3F%28b.innerHTML%3D%22%22%2Cl%3Fb.insertBefore%28w%2Cnull%29%3AjQuery%28v.innerHTML%29.appendTo%28jQuery%28b%29%29%29%3A%22replace-element%22%3D%3Dc%26%26%28l%3Fb.parentNode.insertBefore%28w%2Cb%29%3AjQuery%28v.innerHTML%29.insertBefore%28jQuery%28b%29%29%2C%0Ab.parentNode.removeChild%28b%29%29%7D%7D%3B%0Aai_insert_code%3Dfunction%28c%29%7Bfunction%20h%28m%2Cl%29%7Breturn%20null%3D%3Dm%3F%211%3Am.classList%3Fm.classList.contains%28l%29%3A-1%3C%28%22%20%22%2Bm.className%2B%22%20%22%29.indexOf%28%22%20%22%2Bl%2B%22%20%22%29%7Dfunction%20t%28m%2Cl%29%7Bnull%21%3Dm%26%26%28m.classList%3Fm.classList.add%28l%29%3Am.className%2B%3D%22%20%22%2Bl%29%7Dfunction%20n%28m%2Cl%29%7Bnull%21%3Dm%26%26%28m.classList%3Fm.classList.remove%28l%29%3Am.className%3Dm.className.replace%28new%20RegExp%28%22%28%5E%7C%5C%5Cb%29%22%2Bl.split%28%22%20%22%29.join%28%22%7C%22%29%2B%22%28%5C%5Cb%7C%24%29%22%2C%22gi%22%29%2C%22%20%22%29%29%7Dif%28%22undefined%22%21%3Dtypeof%20c%29%7Bvar%20u%3D%211%3Bif%28h%28c%2C%22no-visibility-check%22%29%7C%7Cc.offsetWidth%7C%7Cc.offsetHeight%7C%7Cc.getClientRects%28%29.length%29%7Bu%3D%0Ac.getAttribute%28%22data-code%22%29%3Bvar%20y%3Dc.getAttribute%28%22data-insertion%22%29%2Cb%3Dc.getAttribute%28%22data-selector%22%29%3Bif%28null%21%3Du%29if%28null%21%3Dy%26%26null%21%3Db%29%7Bif%28-1%21%3Db.indexOf%28%22%3Aeq%22%29%3FjQuery%28b%29.length%3Adocument.querySelectorAll%28b%29.length%29ai_insert%28y%2Cb%2Cb64d%28u%29%29%2Cn%28c%2C%22ai-viewports%22%29%7Delse%7By%3Ddocument.createRange%28%29%3Bb%3D%210%3Btry%7Bvar%20v%3Dy.createContextualFragment%28b64d%28u%29%29%7Dcatch%28m%29%7Bb%3D%211%7Db%3Fc.parentNode.insertBefore%28v%2Cc.nextSibling%29%3AjQuery%28b64d%28u%29%29.insertBefore%28jQuery%28c.nextSibling%29%29%3Bn%28c%2C%22ai-viewports%22%29%7Du%3D%210%7Delse%20v%3Dc.previousElementSibling%2C%0Ah%28v%2C%22ai-debug-bar%22%29%26%26h%28v%2C%22ai-debug-script%22%29%26%26%28n%28v%2C%22ai-debug-script%22%29%2Ct%28v%2C%22ai-debug-viewport-invisible%22%29%29%2Cn%28c%2C%22ai-viewports%22%29%3Breturn%20u%7D%7D%3B%0Aai_insert_list_code%3Dfunction%28c%29%7Bvar%20h%3Ddocument.getElementsByClassName%28c%29%5B0%5D%3Bif%28%22undefined%22%21%3Dtypeof%20h%29%7Bvar%20t%3Dai_insert_code%28h%29%2Cn%3Dh.closest%28%22div.code-block%22%29%3Bif%28n%29%7Bt%7C%7Cn.removeAttribute%28%22data-ai%22%29%3Bvar%20u%3Dn.querySelectorAll%28%22.ai-debug-block%22%29%3Bn%26%26u.length%26%26%28n.classList.remove%28%22ai-list-block%22%29%2Cn.classList.remove%28%22ai-list-block-ip%22%29%2Cn.classList.remove%28%22ai-list-block-filter%22%29%2Cn.style.visibility%3D%22%22%2Cn.classList.contains%28%22ai-remove-position%22%29%26%26%28n.style.position%3D%22%22%29%29%7Dh.classList.remove%28c%29%3Bt%26%26%0Aai_process_elements%28%29%7D%7D%3Bai_insert_viewport_code%3Dfunction%28c%29%7Bvar%20h%3Ddocument.getElementsByClassName%28c%29%5B0%5D%3Bif%28%22undefined%22%21%3Dtypeof%20h%29%7Bvar%20t%3Dai_insert_code%28h%29%3Bh.classList.remove%28c%29%3Bt%26%26%28c%3Dh.closest%28%22div.code-block%22%29%2Cnull%21%3Dc%26%26%28t%3Dh.getAttribute%28%22style%22%29%2Cnull%21%3Dt%26%26c.setAttribute%28%22style%22%2Cc.getAttribute%28%22style%22%29%2B%22%20%22%2Bt%29%29%29%3BsetTimeout%28function%28%29%7Bh.removeAttribute%28%22style%22%29%7D%2C2%29%3Bai_process_elements%28%29%7D%7D%3B%0Aai_insert_code_by_class%3Dfunction%28c%29%7Bvar%20h%3Ddocument.getElementsByClassName%28c%29%5B0%5D%3B%22undefined%22%21%3Dtypeof%20h%26%26%28ai_insert_code%28h%29%2Ch.classList.remove%28c%29%29%7D%3Bai_insert_client_code%3Dfunction%28c%2Ch%29%7Bvar%20t%3Ddocument.getElementsByClassName%28c%29%5B0%5D%3Bif%28%22undefined%22%21%3Dtypeof%20t%29%7Bvar%20n%3Dt.getAttribute%28%22data-code%22%29%3Bnull%21%3Dn%26%26ai_check_block%28%29%26%26ai_check_and_insert_block%28%29%26%26%28t.setAttribute%28%22data-code%22%2Cn.substring%28Math.floor%28h%2F19%29%29%29%2Cai_insert_code_by_class%28c%29%2Ct.remove%28%29%29%7D%7D%3Bai_process_elements_active%3D%211%3B%0Afunction%20ai_process_elements%28%29%7Bai_process_elements_active%7C%7CsetTimeout%28function%28%29%7Bai_process_elements_active%3D%211%3B%22function%22%3D%3Dtypeof%20ai_process_rotations%26%26ai_process_rotations%28%29%3B%22function%22%3D%3Dtypeof%20ai_process_lists%26%26ai_process_lists%28jQuery%28%22.ai-list-data%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_ip_addresses%26%26ai_process_ip_addresses%28jQuery%28%22.ai-ip-data%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_filter_hooks%26%26ai_process_filter_hooks%28jQuery%28%22.ai-filter-check%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_adb_process_blocks%26%26ai_adb_process_blocks%28%29%3B%0A%22function%22%3D%3Dtypeof%20ai_process_impressions%26%261%3D%3Dai_tracking_finished%26%26ai_process_impressions%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_click_trackers%26%261%3D%3Dai_tracking_finished%26%26ai_install_click_trackers%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_close_buttons%26%26ai_install_close_buttons%28document%29%7D%2C5%29%3Bai_process_elements_active%3D%210%7D%0Avar%20Arrive%3Dfunction%28c%2Ch%2Ct%29%7Bfunction%20n%28r%2Cd%2Ce%29%7Bb.addMethod%28d%2Ce%2Cr.unbindEvent%29%3Bb.addMethod%28d%2Ce%2Cr.unbindEventWithSelectorOrCallback%29%3Bb.addMethod%28d%2Ce%2Cr.unbindEventWithSelectorAndCallback%29%7Dfunction%20u%28r%29%7Br.arrive%3Dl.bindEvent%3Bn%28l%2Cr%2C%22unbindArrive%22%29%3Br.leave%3Dw.bindEvent%3Bn%28w%2Cr%2C%22unbindLeave%22%29%7Dif%28c.MutationObserver%26%26%22undefined%22%21%3D%3Dtypeof%20HTMLElement%29%7Bvar%20y%3D0%2Cb%3Dfunction%28%29%7Bvar%20r%3DHTMLElement.prototype.matches%7C%7CHTMLElement.prototype.webkitMatchesSelector%7C%7CHTMLElement.prototype.mozMatchesSelector%7C%7CHTMLElement.prototype.msMatchesSelector%3B%0Areturn%7BmatchesSelector%3Afunction%28d%2Ce%29%7Breturn%20d%20instanceof%20HTMLElement%26%26r.call%28d%2Ce%29%7D%2CaddMethod%3Afunction%28d%2Ce%2Cf%29%7Bvar%20a%3Dd%5Be%5D%3Bd%5Be%5D%3Dfunction%28%29%7Bif%28f.length%3D%3Darguments.length%29return%20f.apply%28this%2Carguments%29%3Bif%28%22function%22%3D%3Dtypeof%20a%29return%20a.apply%28this%2Carguments%29%7D%7D%2CcallCallbacks%3Afunction%28d%2Ce%29%7Be%26%26e.options.onceOnly%26%261%3D%3De.firedElems.length%26%26%28d%3D%5Bd%5B0%5D%5D%29%3Bfor%28var%20f%3D0%2Ca%3Ba%3Dd%5Bf%5D%3Bf%2B%2B%29a%26%26a.callback%26%26a.callback.call%28a.elem%2Ca.elem%29%3Be%26%26e.options.onceOnly%26%261%3D%3De.firedElems.length%26%26e.me.unbindEventWithSelectorAndCallback.call%28e.target%2C%0Ae.selector%2Ce.callback%29%7D%2CcheckChildNodesRecursively%3Afunction%28d%2Ce%2Cf%2Ca%29%7Bfor%28var%20g%3D0%2Ck%3Bk%3Dd%5Bg%5D%3Bg%2B%2B%29f%28k%2Ce%2Ca%29%26%26a.push%28%7Bcallback%3Ae.callback%2Celem%3Ak%7D%29%2C0%3Ck.childNodes.length%26%26b.checkChildNodesRecursively%28k.childNodes%2Ce%2Cf%2Ca%29%7D%2CmergeArrays%3Afunction%28d%2Ce%29%7Bvar%20f%3D%7B%7D%2Ca%3Bfor%28a%20in%20d%29d.hasOwnProperty%28a%29%26%26%28f%5Ba%5D%3Dd%5Ba%5D%29%3Bfor%28a%20in%20e%29e.hasOwnProperty%28a%29%26%26%28f%5Ba%5D%3De%5Ba%5D%29%3Breturn%20f%7D%2CtoElementsArray%3Afunction%28d%29%7B%22undefined%22%3D%3D%3Dtypeof%20d%7C%7C%22number%22%3D%3D%3Dtypeof%20d.length%26%26d%21%3D%3Dc%7C%7C%28d%3D%5Bd%5D%29%3Breturn%20d%7D%7D%7D%28%29%2Cv%3Dfunction%28%29%7Bvar%20r%3Dfunction%28%29%7Bthis._eventsBucket%3D%0A%5B%5D%3Bthis._beforeRemoving%3Dthis._beforeAdding%3Dnull%7D%3Br.prototype.addEvent%3Dfunction%28d%2Ce%2Cf%2Ca%29%7Bd%3D%7Btarget%3Ad%2Cselector%3Ae%2Coptions%3Af%2Ccallback%3Aa%2CfiredElems%3A%5B%5D%7D%3Bthis._beforeAdding%26%26this._beforeAdding%28d%29%3Bthis._eventsBucket.push%28d%29%3Breturn%20d%7D%3Br.prototype.removeEvent%3Dfunction%28d%29%7Bfor%28var%20e%3Dthis._eventsBucket.length-1%2Cf%3Bf%3Dthis._eventsBucket%5Be%5D%3Be--%29d%28f%29%26%26%28this._beforeRemoving%26%26this._beforeRemoving%28f%29%2C%28f%3Dthis._eventsBucket.splice%28e%2C1%29%29%26%26f.length%26%26%28f%5B0%5D.callback%3Dnull%29%29%7D%3Br.prototype.beforeAdding%3Dfunction%28d%29%7Bthis._beforeAdding%3D%0Ad%7D%3Br.prototype.beforeRemoving%3Dfunction%28d%29%7Bthis._beforeRemoving%3Dd%7D%3Breturn%20r%7D%28%29%2Cm%3Dfunction%28r%2Cd%29%7Bvar%20e%3Dnew%20v%2Cf%3Dthis%2Ca%3D%7BfireOnAttributesModification%3A%211%7D%3Be.beforeAdding%28function%28g%29%7Bvar%20k%3Dg.target%3Bif%28k%3D%3D%3Dc.document%7C%7Ck%3D%3D%3Dc%29k%3Ddocument.getElementsByTagName%28%22html%22%29%5B0%5D%3Bvar%20p%3Dnew%20MutationObserver%28function%28x%29%7Bd.call%28this%2Cx%2Cg%29%7D%29%3Bvar%20q%3Dr%28g.options%29%3Bp.observe%28k%2Cq%29%3Bg.observer%3Dp%3Bg.me%3Df%7D%29%3Be.beforeRemoving%28function%28g%29%7Bg.observer.disconnect%28%29%7D%29%3Bthis.bindEvent%3Dfunction%28g%2Ck%2Cp%29%7Bk%3Db.mergeArrays%28a%2Ck%29%3Bfor%28var%20q%3Db.toElementsArray%28this%29%2C%0Ax%3D0%3Bx%3Cq.length%3Bx%2B%2B%29e.addEvent%28q%5Bx%5D%2Cg%2Ck%2Cp%29%7D%3Bthis.unbindEvent%3Dfunction%28%29%7Bvar%20g%3Db.toElementsArray%28this%29%3Be.removeEvent%28function%28k%29%7Bfor%28var%20p%3D0%3Bp%3Cg.length%3Bp%2B%2B%29if%28this%3D%3D%3Dt%7C%7Ck.target%3D%3D%3Dg%5Bp%5D%29return%210%3Breturn%211%7D%29%7D%3Bthis.unbindEventWithSelectorOrCallback%3Dfunction%28g%29%7Bvar%20k%3Db.toElementsArray%28this%29%3Be.removeEvent%28%22function%22%3D%3D%3Dtypeof%20g%3Ffunction%28p%29%7Bfor%28var%20q%3D0%3Bq%3Ck.length%3Bq%2B%2B%29if%28%28this%3D%3D%3Dt%7C%7Cp.target%3D%3D%3Dk%5Bq%5D%29%26%26p.callback%3D%3D%3Dg%29return%210%3Breturn%211%7D%3Afunction%28p%29%7Bfor%28var%20q%3D0%3Bq%3Ck.length%3Bq%2B%2B%29if%28%28this%3D%3D%3Dt%7C%7Cp.target%3D%3D%3Dk%5Bq%5D%29%26%26p.selector%3D%3D%3D%0Ag%29return%210%3Breturn%211%7D%29%7D%3Bthis.unbindEventWithSelectorAndCallback%3Dfunction%28g%2Ck%29%7Bvar%20p%3Db.toElementsArray%28this%29%3Be.removeEvent%28function%28q%29%7Bfor%28var%20x%3D0%3Bx%3Cp.length%3Bx%2B%2B%29if%28%28this%3D%3D%3Dt%7C%7Cq.target%3D%3D%3Dp%5Bx%5D%29%26%26q.selector%3D%3D%3Dg%26%26q.callback%3D%3D%3Dk%29return%210%3Breturn%211%7D%29%7D%3Breturn%20this%7D%2Cl%3Dnew%20function%28%29%7Bfunction%20r%28f%2Ca%2Cg%29%7Breturn%20b.matchesSelector%28f%2Ca.selector%29%26%26%28f._id%3D%3D%3Dt%26%26%28f._id%3Dy%2B%2B%29%2C-1%3D%3Da.firedElems.indexOf%28f._id%29%29%3F%28a.firedElems.push%28f._id%29%2C%210%29%3A%211%7Dvar%20d%3D%7BfireOnAttributesModification%3A%211%2ConceOnly%3A%211%2Cexisting%3A%211%7D%3Bl%3Dnew%20m%28function%28f%29%7Bvar%20a%3D%0A%7Battributes%3A%211%2CchildList%3A%210%2Csubtree%3A%210%7D%3Bf.fireOnAttributesModification%26%26%28a.attributes%3D%210%29%3Breturn%20a%7D%2Cfunction%28f%2Ca%29%7Bf.forEach%28function%28g%29%7Bvar%20k%3Dg.addedNodes%2Cp%3Dg.target%2Cq%3D%5B%5D%3Bnull%21%3D%3Dk%26%260%3Ck.length%3Fb.checkChildNodesRecursively%28k%2Ca%2Cr%2Cq%29%3A%22attributes%22%3D%3D%3Dg.type%26%26r%28p%2Ca%2Cq%29%26%26q.push%28%7Bcallback%3Aa.callback%2Celem%3Ap%7D%29%3Bb.callCallbacks%28q%2Ca%29%7D%29%7D%29%3Bvar%20e%3Dl.bindEvent%3Bl.bindEvent%3Dfunction%28f%2Ca%2Cg%29%7B%22undefined%22%3D%3D%3Dtypeof%20g%3F%28g%3Da%2Ca%3Dd%29%3Aa%3Db.mergeArrays%28d%2Ca%29%3Bvar%20k%3Db.toElementsArray%28this%29%3Bif%28a.existing%29%7Bfor%28var%20p%3D%5B%5D%2Cq%3D0%3Bq%3Ck.length%3Bq%2B%2B%29for%28var%20x%3D%0Ak%5Bq%5D.querySelectorAll%28f%29%2Cz%3D0%3Bz%3Cx.length%3Bz%2B%2B%29p.push%28%7Bcallback%3Ag%2Celem%3Ax%5Bz%5D%7D%29%3Bif%28a.onceOnly%26%26p.length%29return%20g.call%28p%5B0%5D.elem%2Cp%5B0%5D.elem%29%3BsetTimeout%28b.callCallbacks%2C1%2Cp%29%7De.call%28this%2Cf%2Ca%2Cg%29%7D%3Breturn%20l%7D%2Cw%3Dnew%20function%28%29%7Bfunction%20r%28f%2Ca%29%7Breturn%20b.matchesSelector%28f%2Ca.selector%29%7Dvar%20d%3D%7B%7D%3Bw%3Dnew%20m%28function%28%29%7Breturn%7BchildList%3A%210%2Csubtree%3A%210%7D%7D%2Cfunction%28f%2Ca%29%7Bf.forEach%28function%28g%29%7Bg%3Dg.removedNodes%3Bvar%20k%3D%5B%5D%3Bnull%21%3D%3Dg%26%260%3Cg.length%26%26b.checkChildNodesRecursively%28g%2Ca%2Cr%2Ck%29%3Bb.callCallbacks%28k%2Ca%29%7D%29%7D%29%3Bvar%20e%3Dw.bindEvent%3Bw.bindEvent%3D%0Afunction%28f%2Ca%2Cg%29%7B%22undefined%22%3D%3D%3Dtypeof%20g%3F%28g%3Da%2Ca%3Dd%29%3Aa%3Db.mergeArrays%28d%2Ca%29%3Be.call%28this%2Cf%2Ca%2Cg%29%7D%3Breturn%20w%7D%3Bh%26%26u%28h.fn%29%3Bu%28HTMLElement.prototype%29%3Bu%28NodeList.prototype%29%3Bu%28HTMLCollection.prototype%29%3Bu%28HTMLDocument.prototype%29%3Bu%28Window.prototype%29%3Bh%3D%7B%7D%3Bn%28l%2Ch%2C%22unbindAllArrive%22%29%3Bn%28w%2Ch%2C%22unbindAllLeave%22%29%3Breturn%20h%7D%7D%28window%2C%22undefined%22%3D%3D%3Dtypeof%20jQuery%3Fnull%3AjQuery%2Cvoid%200%29%3B%0AjQuery%28function%28a%29%7Bfunction%20u%28%29%7Ba%28%22div.ai-rotate.ai-rotation-groups%22%29.each%28function%28f%2Cl%29%7Ba%28this%29.addClass%28%22ai-timer%22%29%3Bai_process_rotation%28this%29%7D%29%7Dvar%20p%3D%5B%5D%3Bai_process_rotation%3Dfunction%28f%29%7Bif%28a%28f%29.hasClass%28%22ai-unprocessed%22%29%7C%7Ca%28f%29.hasClass%28%22ai-timer%22%29%29%7Ba%28f%29.removeClass%28%22ai-unprocessed%22%29.removeClass%28%22ai-timer%22%29%3Bvar%20l%3D%211%3Bif%28%22undefined%22%21%3Dtypeof%20a%28f%29.data%28%22info%22%29%29%7Bvar%20g%3D%22div.ai-rotate.ai-%22%2BJSON.parse%28atob%28a%28f%29.data%28%22info%22%29%29%29%5B0%5D%3Bp.includes%28g%29%26%26%28p.splice%28p.indexOf%28g%29%2C1%29%2Cl%3D%210%29%7Dif%28%22number%22%3D%3Dtypeof%20f.length%29for%28l%3D%0A0%3Bl%3Cf.length%3Bl%2B%2B%290%3D%3Dl%3Fai_process_single_rotation%28f%5Bl%5D%2C%210%29%3Aai_process_single_rotation%28f%5Bl%5D%2C%211%29%3Belse%20ai_process_single_rotation%28f%2C%21l%29%7D%7D%3Bai_process_single_rotation%3Dfunction%28f%2Cl%29%7Bvar%20g%3Da%28f%29.children%28%22.ai-rotate-option%22%29%3Bif%280%21%3Dg.length%29%7Bg.hide%28%29%3Bif%28%22undefined%22%3D%3Dtypeof%20a%28f%29.data%28%22next%22%29%29if%28%22undefined%22%21%3Dtypeof%20a%28g%5B0%5D%29.data%28%22group%22%29%29%7Bvar%20h%3D-1%2Ct%3D%5B%5D%3Ba%28%22span%5Bdata-ai-groups%5D%22%29.each%28function%28q%29%7B%28a%28this%29%5B0%5D.offsetWidth%7C%7Ca%28this%29%5B0%5D.offsetHeight%7C%7Ca%28this%29%5B0%5D.getClientRects%28%29.length%29%26%26t.push%28this%29%7D%29%3B1%3C%3Dt.length%26%26JSON.parse%28b64d%28a%28t%29.first%28%29.data%28%22ai-groups%22%29%29%29.forEach%28function%28q%2C%0Aw%29%7B-1%3D%3Dh%26%26g.each%28function%28v%29%7Bif%28b64d%28a%28this%29.data%28%22group%22%29%29%3D%3Dq%29return%20h%3Dv%2C%211%7D%29%7D%29%7Delse%7Bvar%20e%3Da%28f%29.data%28%22shares%22%29%3Bif%28%22string%22%3D%3D%3Dtypeof%20e%29%7Be%3DJSON.parse%28atob%28e%29%29%3Bvar%20d%3DMath.round%28100%2AMath.random%28%29%29%3Bfor%28var%20b%3D0%3Bb%3Ce.length%26%26%28h%3Db%2C0%3Ee%5Bb%5D%7C%7C%21%28d%3C%3De%5Bb%5D%29%29%3Bb%2B%2B%29%3B%7Delse%20e%3Da%28f%29.hasClass%28%22ai-unique%22%29%2Cd%3Dnew%20Date%2Ce%3F%28%22number%22%21%3Dtypeof%20ai_rotation_seed%26%26%28ai_rotation_seed%3D%28Math.floor%281E3%2AMath.random%28%29%29%2Bd.getMilliseconds%28%29%29%25g.length%29%2Ce%3Da%28f%29.data%28%22counter%22%29%2Ch%3Dai_rotation_seed%2Be%2Ch%3E%3Dg.length%26%26%28h-%3Dg.length%29%29%3A%28h%3DMath.floor%28Math.random%28%29%2A%0Ag.length%29%2Cd.getMilliseconds%28%29%252%26%26%28h%3Dg.length-h-1%29%29%7Delse%20h%3DparseInt%28a%28f%29.attr%28%22data-next%22%29%29%2Cd%3Da%28g%5Bh%5D%29%2C%22undefined%22%21%3Dtypeof%20d.data%28%22code%22%29%26%26%28d%3Da%28b64d%28d.data%28%22code%22%29%29%29%29%2C0%21%3Dd.find%28%22span%5Bdata-ai-groups%5D%22%29.addBack%28%22span%5Bdata-ai-groups%5D%22%29.length%26%260%21%3Da%28%22.ai-rotation-groups%22%29.length%26%26setTimeout%28function%28%29%7Bu%28%29%7D%2C5%29%3Bif%28a%28f%29.hasClass%28%22ai-rotation-scheduling%22%29%29for%28h%3D-1%2Ce%3D0%3Be%3Cg.length%3Be%2B%2B%29if%28d%3Da%28g%5Be%5D%29%2Cd%3Dd.data%28%22scheduling%22%29%2C%22undefined%22%21%3Dtypeof%20d%29%7Bb%3Db64d%28d%29%3Bd%3D%210%3B0%3D%3Db.indexOf%28%22%5E%22%29%26%26%28d%3D%211%2Cb%3Db.substring%281%29%29%3Bvar%20m%3Db.split%28%22%3D%22%29%2C%0Ac%3D-1%21%3Db.indexOf%28%22%25%22%29%3Fm%5B0%5D.split%28%22%25%22%29%3A%5Bm%5B0%5D%5D%3Bb%3Dc%5B0%5D.trim%28%29.toLowerCase%28%29%3Bc%3D%22undefined%22%21%3Dtypeof%20c%5B1%5D%3Fc%5B1%5D.trim%28%29%3A0%3Bm%3Dm%5B1%5D.replace%28%22%20%22%2C%22%22%29%3Bvar%20n%3D%28new%20Date%29.getTime%28%29%3Bn%3Dnew%20Date%28n%29%3Bvar%20k%3D0%3Bswitch%28b%29%7Bcase%20%22s%22%3Ak%3Dn.getSeconds%28%29%3Bbreak%3Bcase%20%22i%22%3Ak%3Dn.getMinutes%28%29%3Bbreak%3Bcase%20%22h%22%3Ak%3Dn.getHours%28%29%3Bbreak%3Bcase%20%22d%22%3Ak%3Dn.getDate%28%29%3Bbreak%3Bcase%20%22m%22%3Ak%3Dn.getMonth%28%29%3Bbreak%3Bcase%20%22y%22%3Ak%3Dn.getFullYear%28%29%3Bbreak%3Bcase%20%22w%22%3Ak%3Dn.getDay%28%29%2Ck%3D0%3D%3Dk%3F6%3Ak-1%7Db%3D0%21%3Dc%3Fk%25c%3Ak%3Bc%3Dm.split%28%22%2C%22%29%3Bm%3D%21d%3Bfor%28n%3D0%3Bn%3Cc.length%3Bn%2B%2B%29if%28k%3Dc%5Bn%5D%2C-1%21%3Dk.indexOf%28%22-%22%29%29%7Bif%28k%3D%0Ak.split%28%22-%22%29%2Cb%3E%3Dk%5B0%5D%26%26b%3C%3Dk%5B1%5D%29%7Bm%3Dd%3Bbreak%7D%7Delse%20if%28b%3D%3Dk%29%7Bm%3Dd%3Bbreak%7Dif%28m%29%7Bh%3De%3Bbreak%7D%7Dif%28%21%280%3Eh%7C%7Ch%3E%3Dg.length%29%29%7Bd%3Da%28g%5Bh%5D%29%3Be%3D%22%22%3Bif%28%22undefined%22%21%3Dtypeof%20d.data%28%22time%22%29%29%7Bb%3Datob%28d.data%28%22time%22%29%29%3Bif%280%3D%3Db%26%261%3Cg.length%29%7Bc%3Dh%3Bdo%7Bc%2B%2B%3Bc%3E%3Dg.length%26%26%28c%3D0%29%3Bm%3Da%28g%5Bc%5D%29%3Bif%28%22undefined%22%3D%3Dtypeof%20m.data%28%22time%22%29%29%7Bh%3Dc%3Bd%3Da%28g%5Bh%5D%29%3Bb%3D0%3Bbreak%7Dm%3Datob%28m.data%28%22time%22%29%29%7Dwhile%280%3D%3Dm%26%26c%21%3Dh%29%3B0%21%3Db%26%26%28h%3Dc%2Cd%3Da%28g%5Bh%5D%29%2Cb%3Datob%28d.data%28%22time%22%29%29%29%7Dif%280%3Cb%26%26%28c%3Dh%2B1%2Cc%3E%3Dg.length%26%26%28c%3D0%29%2C%22undefined%22%21%3Dtypeof%20a%28f%29.data%28%22info%22%29%29%29%7Be%3DJSON.parse%28atob%28a%28f%29.data%28%22info%22%29%29%29%5B0%5D%3B%0Aa%28f%29.attr%28%22data-next%22%2Cc%29%3Bvar%20r%3D%22div.ai-rotate.ai-%22%2Be%3Bp.includes%28r%29%26%26%28l%3D%211%29%3Bl%26%26%28p.push%28r%29%2CsetTimeout%28function%28%29%7Ba%28r%29.addClass%28%22ai-timer%22%29%3Bai_process_rotation%28a%28r%29%29%7D%2C1E3%2Ab%29%29%3Be%3D%22%20%28%22%2Bb%2B%22%20s%29%22%7D%7Delse%22undefined%22%3D%3Dtypeof%20d.data%28%22group%22%29%26%26g.each%28function%28q%29%7Bq%21%3Dh%26%26a%28this%29.remove%28%29%7D%29%3Bd.css%28%7Bdisplay%3A%22%22%2Cvisibility%3A%22%22%2Cposition%3A%22%22%2Cwidth%3A%22%22%2Cheight%3A%22%22%2Ctop%3A%22%22%2Cleft%3A%22%22%7D%29.removeClass%28%22ai-rotate-hidden%22%29.removeClass%28%22ai-rotate-hidden-2%22%29%3Ba%28f%29.css%28%7Bposition%3A%22%22%7D%29%3B%22undefined%22%21%3Dtypeof%20d.data%28%22code%22%29%26%26%28g.empty%28%29%2Cb%3Db64d%28d.data%28%22code%22%29%29%2C%0Ad.append%28b%29%2Cai_process_elements%28%29%29%3Bd%3Db64d%28d.data%28%22name%22%29%29%3Bc%3Da%28f%29.closest%28%22.ai-debug-block%22%29%3B0%21%3Dc.length%26%26%28b%3Dc.find%28%22kbd.ai-option-name%22%29%2Cc%3Dc.find%28%22.ai-debug-block%22%29%2C%22undefined%22%21%3Dtypeof%20c%26%26%28c%3Dc.find%28%22kbd.ai-option-name%22%29%2Cb%3Db.slice%280%2Cb.length-c.length%29%29%2C%22undefined%22%21%3Dtypeof%20b%26%26%28c%3Db.first%28%29.data%28%22separator%22%29%2C%22undefined%22%3D%3Dtypeof%20c%26%26%28c%3D%22%22%29%2Cb.html%28c%2Bd%2Be%29%29%29%3Bb%3D%211%3Bc%3Da%28f%29.closest%28%22.ai-adb-show%22%29%3B0%21%3Dc.length%26%26c.attr%28%22data-ai-tracking%22%29%26%26%28e%3DJSON.parse%28b64d%28c.attr%28%22data-ai-tracking%22%29%29%29%2C%22undefined%22%21%3D%3Dtypeof%20e%26%26%0Ae.constructor%3D%3D%3DArray%26%26%28e%5B1%5D%3Dh%2B1%2Ce%5B3%5D%3Dd%2Cc.attr%28%22data-ai-tracking%22%2Cb64e%28JSON.stringify%28e%29%29%29%2Cc.addClass%28%22ai-track%22%29%2Cb%3D%210%29%29%3Bb%7C%7C%28b%3Da%28f%29.closest%28%22div%5Bdata-ai%5D%22%29%2C%22undefined%22%21%3Dtypeof%20b.attr%28%22data-ai%22%29%26%26%28e%3DJSON.parse%28b64d%28b.attr%28%22data-ai%22%29%29%29%2C%22undefined%22%21%3D%3Dtypeof%20e%26%26e.constructor%3D%3D%3DArray%26%26%28e%5B1%5D%3Dh%2B1%2Ce%5B3%5D%3Dd%2Cb.attr%28%22data-ai%22%2Cb64e%28JSON.stringify%28e%29%29%29%2Cb.addClass%28%22ai-track%22%29%29%29%29%7D%7D%7D%3Bai_process_rotations%3Dfunction%28%29%7Ba%28%22div.ai-rotate%22%29.each%28function%28f%2Cl%29%7Bai_process_rotation%28this%29%7D%29%7D%3Bai_process_rotations_in_element%3Dfunction%28f%29%7Ba%28%22div.ai-rotate%22%2C%0Af%29.each%28function%28l%2Cg%29%7Bai_process_rotation%28this%29%7D%29%7D%3Ba%28document%29.ready%28function%28f%29%7BsetTimeout%28function%28%29%7Bai_process_rotations%28%29%7D%2C10%29%7D%29%7D%29%3Bai_process_elements_active%3D%211%3B%0Afunction%20ai_process_elements%28%29%7Bai_process_elements_active%7C%7CsetTimeout%28function%28%29%7Bai_process_elements_active%3D%211%3B%22function%22%3D%3Dtypeof%20ai_process_rotations%26%26ai_process_rotations%28%29%3B%22function%22%3D%3Dtypeof%20ai_process_lists%26%26ai_process_lists%28jQuery%28%22.ai-list-data%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_ip_addresses%26%26ai_process_ip_addresses%28jQuery%28%22.ai-ip-data%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_filter_hooks%26%26ai_process_filter_hooks%28jQuery%28%22.ai-filter-check%22%29%29%3B%22function%22%3D%3Dtypeof%20ai_adb_process_blocks%26%26ai_adb_process_blocks%28%29%3B%0A%22function%22%3D%3Dtypeof%20ai_install_click_trackers%26%261%3D%3Dai_tracking_finished%26%26ai_install_click_trackers%28%29%3B%22function%22%3D%3Dtypeof%20ai_process_impressions%26%261%3D%3Dai_tracking_finished%26%26ai_process_impressions%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_click_trackers%26%261%3D%3Dai_tracking_finished%26%26ai_install_click_trackers%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_close_buttons%26%26ai_install_close_buttons%28document%29%7D%2C5%29%3Bai_process_elements_active%3D%210%7D%3B%0Avar%20%24jscomp%3D%24jscomp%7C%7C%7B%7D%3B%24jscomp.scope%3D%7B%7D%3B%24jscomp.createTemplateTagFirstArg%3Dfunction%28a%29%7Breturn%20a.raw%3Da%7D%3B%24jscomp.createTemplateTagFirstArgWithRaw%3Dfunction%28a%2Cn%29%7Ba.raw%3Dn%3Breturn%20a%7D%3B%24jscomp.arrayIteratorImpl%3Dfunction%28a%29%7Bvar%20n%3D0%3Breturn%20function%28%29%7Breturn%20n%3Ca.length%3F%7Bdone%3A%211%2Cvalue%3Aa%5Bn%2B%2B%5D%7D%3A%7Bdone%3A%210%7D%7D%7D%3B%24jscomp.arrayIterator%3Dfunction%28a%29%7Breturn%7Bnext%3A%24jscomp.arrayIteratorImpl%28a%29%7D%7D%3B%24jscomp.makeIterator%3Dfunction%28a%29%7Bvar%20n%3D%22undefined%22%21%3Dtypeof%20Symbol%26%26Symbol.iterator%26%26a%5BSymbol.iterator%5D%3Breturn%20n%3Fn.call%28a%29%3A%24jscomp.arrayIterator%28a%29%7D%3B%0D%0AjQuery%28function%28a%29%7Bfunction%20n%28d%29%7Bd%3Dd.match%28ba%29%3Breturn%20null%21%3Dd%26%261%3Cd.length%26%26%22string%22%3D%3D%3Dtypeof%20d%5B1%5D%26%260%3Cd%5B1%5D.length%3Fd%5B1%5D.toLowerCase%28%29%3Anull%7Dfunction%20B%28d%29%7Breturn%20d.includes%28%22%3A%22%29%3F%28d%3Dd.split%28%22%3A%22%29%2C1E3%2A%283600%2AparseInt%28d%5B0%5D%29%2B60%2AparseInt%28d%5B1%5D%29%2BparseInt%28d%5B2%5D%29%29%29%3Anull%7Dfunction%20t%28d%29%7Btry%7Bvar%20l%3DDate.parse%28d%29%3BisNaN%28l%29%26%26%28l%3Dnull%29%7Dcatch%28F%29%7Bl%3Dnull%7Dif%28null%3D%3Dl%26%26d.includes%28%22%20%22%29%29%7Bd%3Dd.split%28%22%20%22%29%3Btry%7Bl%3DDate.parse%28d%5B0%5D%29%2Cl%2B%3DB%28d%5B1%5D%29%2CisNaN%28l%29%26%26%28l%3Dnull%29%7Dcatch%28F%29%7Bl%3Dnull%7D%7Dreturn%20l%7Dfunction%20G%28%29%7B%28jQuery%28%22%23ai-iab-tcf-bar%22%29.length%7C%7CjQuery%28%22.ai-list-manual%22%29.length%29%26%26%0D%0A%22function%22%3D%3Dtypeof%20__tcfapi%26%26%22function%22%3D%3Dtypeof%20ai_load_blocks%26%26%22undefined%22%3D%3Dtypeof%20ai_iab_tcf_callback_installed%26%26%28__tcfapi%28%22addEventListener%22%2C2%2Cfunction%28d%2Cl%29%7Bl%26%26%22useractioncomplete%22%3D%3D%3Dd.eventStatus%26%26%28ai_tcData%3Dd%2Cai_load_blocks%28%29%2CjQuery%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20DATA%20LOADED%22%29%2CjQuery%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-ok%22%29.removeClass%28%22status-error%22%29%29%7D%29%2Cai_iab_tcf_callback_installed%3D%210%29%7Dfunction%20u%28d%29%7Bd%3D%28%22%3B%20%22%2Bdocument.cookie%29.split%28%22%3B%20%22%2Bd%2B%22%3D%22%29%3Bif%282%3D%3D%3Dd.length%29return%20d.pop%28%29.split%28%22%3B%22%29.shift%28%29%7D%0D%0Afunction%20m%28d%29%7Bif%28u%28d%29%29%7Bvar%20l%3Dwindow.location.hostname%3Bu%28d%29%26%26%28document.cookie%3Dd%2B%22%3D%3Bpath%3D%2F%22%2B%28l%3F%22%3Bdomain%3D%22%2Bl%3A%22%22%29%2B%22%3Bexpires%3DThu%2C%2001%20Jan%201970%2000%3A00%3A01%20GMT%22%29%3Bdocument.cookie%3Dd%2B%22%3D%3B%20Path%3D%2F%3B%20Expires%3DThu%2C%2001%20Jan%201970%2000%3A00%3A01%20GMT%3B%22%7D%7DArray.prototype.includes%7C%7C%28Array.prototype.includes%3Dfunction%28d%29%7Breturn%21%21~this.indexOf%28d%29%7D%29%3Bvar%20ba%3DRegExp%28%22%3A%5C%5C%2F%5C%5C%2F%28.%5B%5E%2F%3A%5D%2B%29%22%2C%22i%22%29%3Bai_process_lists%3Dfunction%28d%29%7Bfunction%20l%28e%2Cc%2Ck%29%7Bif%280%3D%3De.length%29%7Bif%28%22%21%40%21%22%3D%3Dk%29return%210%3Bc%21%3Dk%26%26%28%22true%22%3D%3Dk.toLowerCase%28%29%3Fk%3D%210%3A%22false%22%3D%3Dk.toLowerCase%28%29%26%26%28k%3D%0D%0A%211%29%29%3Breturn%20c%3D%3Dk%7Dif%28%22object%22%21%3Dtypeof%20c%26%26%22array%22%21%3Dtypeof%20c%29return%211%3Bvar%20f%3De%5B0%5D%3Be%3De.slice%281%29%3Bif%28%22%2A%22%3D%3Df%29for%28c%3D%24jscomp.makeIterator%28Object.entries%28c%29%29%2Cf%3Dc.next%28%29%3B%21f.done%3Bf%3Dc.next%28%29%29%7Bif%28f%3D%24jscomp.makeIterator%28f.value%29%2Cf.next%28%29%2Cf%3Df.next%28%29.value%2Cl%28e%2Cf%2Ck%29%29return%210%7Delse%20if%28f%20in%20c%29return%20l%28e%2Cc%5Bf%5D%2Ck%29%3Breturn%211%7Dfunction%20F%28e%2Cc%2Ck%29%7Bif%28%22object%22%21%3Dtypeof%20e%7C%7C-1%3D%3Dc.indexOf%28%22%5B%22%29%29return%211%3Bc%3Dc.replace%28%2F%5D%7C%20%2Fgi%2C%22%22%29.split%28%22%5B%22%29%3Breturn%20l%28c%2Ce%2Ck%29%7Dfunction%20ca%28%29%7B%22function%22%3D%3Dtypeof%20__tcfapi%26%26%28a%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20DETECTED%22%29%2C%0D%0A__tcfapi%28%22getTCData%22%2C2%2Cfunction%28e%2Cc%29%7Bc%3F%28a%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-ok%22%29%2C%22tcloaded%22%3D%3De.eventStatus%7C%7C%22useractioncomplete%22%3D%3De.eventStatus%3F%28ai_tcData%3De%2Ce.gdprApplies%3Fa%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20DATA%20LOADED%22%29%3AjQuery%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20GDPR%20DOES%20NOT%20APPLY%22%29%2Ca%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-ok%22%29.removeClass%28%22status-error%22%29%2CsetTimeout%28function%28%29%7Bai_process_lists%28%29%7D%2C10%29%29%3A%22cmpuishown%22%3D%3De.eventStatus%26%26%28ai_cmpuishown%3D%210%2Ca%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20CMP%20UI%20SHOWN%22%29%2C%0D%0Aa%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-ok%22%29.removeClass%28%22status-error%22%29%29%29%3A%28a%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20__tcfapi%20getTCData%20failed%22%29%2Ca%28%22%23ai-iab-tcf-bar%22%29.removeClass%28%22status-ok%22%29.addClass%28%22status-error%22%29%29%7D%29%29%7Dfunction%20K%28e%29%7B%22function%22%3D%3Dtypeof%20__tcfapi%3F%28%22undefined%22%3D%3Dtypeof%20ai_iab_tcf_callback_installed%26%26G%28%29%2C%22undefined%22%3D%3Dtypeof%20ai_tcData_requested%26%26%28ai_tcData_requested%3D%210%2Cca%28%29%2Curl_parameters_need_tcData%3D%210%29%29%3Ae%26%26%28a%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-error%22%29.removeClass%28%22status-ok%22%29%2Ca%28%22%23ai-iab-tcf-status%22%29.text%28%22IAB%20TCF%202.0%20MISSING%3A%20__tcfapi%20function%20not%20found%22%29%29%7D%0D%0Ad%3Dnull%3D%3Dd%3Fa%28%22div.ai-list-data%2C%20meta.ai-list-data%22%29%3Ad.filter%28%22.ai-list-data%22%29%3Bif%28d.length%29%7Bd.removeClass%28%22ai-list-data%22%29%3Bvar%20J%3Ddocument.cookie.split%28%22%3B%22%29%3BJ.forEach%28function%28e%2Cc%29%7BJ%5Bc%5D%3De.trim%28%29%7D%29%3Bvar%20V%3DgetAllUrlParams%28window.location.search%29%3Bif%28null%21%3DV.referrer%29var%20w%3DV.referrer%3Belse%20w%3Ddocument.referrer%2C%22%22%21%3Dw%26%26%28w%3Dn%28w%29%29%3Bvar%20R%3Dwindow.navigator.userAgent%2CS%3DR.toLowerCase%28%29%2CW%3Dnavigator.language%2CL%3DW.toLowerCase%28%29%3Bif%28%22undefined%22%21%3D%3Dtypeof%20MobileDetect%29var%20X%3Dnew%20MobileDetect%28R%29%3Bd.each%28function%28%29%7Bvar%20e%3Da%28this%29.closest%28%22div.code-block%22%29%2C%0D%0Ac%3D%210%2Ck%3Da%28this%29.attr%28%22referer-list%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20k%29%7Bk%3Db64d%28k%29.split%28%22%2C%22%29%3Bvar%20f%3Da%28this%29.attr%28%22referer-list-type%22%29%2CC%3D%211%3Ba.each%28k%2Cfunction%28A%2Cg%29%7Bif%28%22%22%3D%3Dg%29return%210%3Bif%28%22%2A%22%3D%3Dg.charAt%280%29%29if%28%22%2A%22%3D%3Dg.charAt%28g.length-1%29%29%7Bif%28g%3Dg.substr%281%2Cg.length-2%29%2C-1%21%3Dw.indexOf%28g%29%29return%20C%3D%210%2C%211%7Delse%7Bif%28g%3Dg.substr%281%29%2Cw.substr%28-g.length%29%3D%3Dg%29return%20C%3D%210%2C%211%7Delse%20if%28%22%2A%22%3D%3Dg.charAt%28g.length-1%29%29%7Bif%28g%3Dg.substr%280%2Cg.length-1%29%2C0%3D%3Dw.indexOf%28g%29%29return%20C%3D%210%2C%211%7Delse%20if%28%22%23%22%3D%3Dg%29%7Bif%28%22%22%3D%3Dw%29return%20C%3D%210%2C%211%7Delse%20if%28g%3D%3Dw%29return%20C%3D%210%2C%211%7D%29%3B%0D%0Aswitch%28f%29%7Bcase%20%22B%22%3AC%26%26%28c%3D%211%29%3Bbreak%3Bcase%20%22W%22%3AC%7C%7C%28c%3D%211%29%7D%7Dif%28c%26%26%28k%3Da%28this%29.attr%28%22client-list%22%29%2C%22undefined%22%21%3Dtypeof%20k%26%26%22undefined%22%21%3D%3Dtypeof%20X%29%29switch%28k%3Db64d%28k%29.split%28%22%2C%22%29%2Cf%3Da%28this%29.attr%28%22client-list-type%22%29%2Cr%3D%211%2Ca.each%28k%2Cfunction%28A%2Cg%29%7Bif%28%22%22%3D%3Dg.trim%28%29%29return%210%3Bvar%20M%3Dg.split%28%22%26%26%22%29%3Ba.each%28M%2Cfunction%28da%2Cb%29%7Bvar%20x%3D%210%2Cq%3D%211%3Bb%3Db.trim%28%29%3B%22%21%21%22%3D%3Db.substring%280%2C2%29%26%26%28x%3D%211%2Cb%3Db.substring%282%29%29%3B%22language%3A%22%3D%3Db.substring%280%2C9%29%26%26%28q%3D%210%2Cb%3Db.substring%289%29.toLowerCase%28%29%29%3Bvar%20p%3D%211%3Bq%3F%22%2A%22%3D%3Db.charAt%280%29%3F%22%2A%22%3D%3Db.charAt%28b.length-1%29%3F%28b%3Db.substr%281%2C%0D%0Ab.length-2%29.toLowerCase%28%29%2C-1%21%3DL.indexOf%28b%29%26%26%28p%3D%210%29%29%3A%28b%3Db.substr%281%29.toLowerCase%28%29%2CL.substr%28-b.length%29%3D%3Db%26%26%28p%3D%210%29%29%3A%22%2A%22%3D%3Db.charAt%28b.length-1%29%3F%28b%3Db.substr%280%2Cb.length-1%29.toLowerCase%28%29%2C0%3D%3DL.indexOf%28b%29%26%26%28p%3D%210%29%29%3Ab%3D%3DL%26%26%28p%3D%210%29%3A%22%2A%22%3D%3Db.charAt%280%29%3F%22%2A%22%3D%3Db.charAt%28b.length-1%29%3F%28b%3Db.substr%281%2Cb.length-2%29.toLowerCase%28%29%2C-1%21%3DS.indexOf%28b%29%26%26%28p%3D%210%29%29%3A%28b%3Db.substr%281%29.toLowerCase%28%29%2CS.substr%28-b.length%29%3D%3Db%26%26%28p%3D%210%29%29%3A%22%2A%22%3D%3Db.charAt%28b.length-1%29%3F%28b%3Db.substr%280%2Cb.length-1%29.toLowerCase%28%29%2C0%3D%3DS.indexOf%28b%29%26%26%28p%3D%210%29%29%3AX.is%28b%29%26%26%28p%3D%210%29%3Br%3Dp%3Fx%3A%21x%3B%0D%0Aif%28%21r%29return%211%7D%29%3Bif%28r%29return%211%7D%29%2Cf%29%7Bcase%20%22B%22%3Ar%26%26%28c%3D%211%29%3Bbreak%3Bcase%20%22W%22%3Ar%7C%7C%28c%3D%211%29%7Dvar%20N%3Dk%3D%211%3Bif%28c%29%7Bvar%20h%3Da%28this%29.attr%28%22parameter-list%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20h%29%7Bh%3Db64d%28h%29%3Bf%3Da%28this%29.attr%28%22parameter-list-type%22%29%3Bh%3Dh.replace%28%22tcf-gdpr%22%2C%22tcf-v2%5BgdprApplies%5D%3Dtrue%22%29%3Bh%3Dh.replace%28%22tcf-no-gdpr%22%2C%22tcf-v2%5BgdprApplies%5D%3Dfalse%22%29%3Bh%3Dh.replace%28%22tcf-google%22%2C%22tcf-v2%5Bvendor%5D%5Bconsents%5D%5B755%5D%3Dtrue%20%26%26%20tcf-v2%5Bpurpose%5D%5Bconsents%5D%5B1%5D%3Dtrue%22%29%3Bh%3Dh.replace%28%22tcf-media.net%22%2C%22tcf-v2%5Bvendor%5D%5Bconsents%5D%5B142%5D%3Dtrue%20%26%26%20tcf-v2%5Bpurpose%5D%5Bconsents%5D%5B1%5D%3Dtrue%22%29%3B%0D%0Ah%3Dh.replace%28%22tcf-amazon%22%2C%22tcf-v2%5Bvendor%5D%5Bconsents%5D%5B793%5D%3Dtrue%20%26%26%20tcf-v2%5Bpurpose%5D%5Bconsents%5D%5B1%5D%3Dtrue%22%29%3Bh%3Dh.replace%28%22tcf-ezoic%22%2C%22tcf-v2%5Bvendor%5D%5Bconsents%5D%5B347%5D%3Dtrue%20%26%26%20tcf-v2%5Bpurpose%5D%5Bconsents%5D%5B1%5D%3Dtrue%22%29%3Bh%3Dh.split%28%22%2C%22%29%3Bvar%20Y%3D%5B%5D%3BJ.forEach%28function%28A%29%7BA%3DA.split%28%22%3D%22%29%3Btry%7Bvar%20g%3DJSON.parse%28decodeURIComponent%28A%5B1%5D%29%29%7Dcatch%28M%29%7Bg%3DdecodeURIComponent%28A%5B1%5D%29%7DY%5BA%5B0%5D%5D%3Dg%7D%29%3Bvar%20r%3D%211%2CO%3Da%28this%29%3Ba.each%28h%2Cfunction%28A%2Cg%29%7Bvar%20M%3Dg.split%28%22%26%26%22%29%3Ba.each%28M%2Cfunction%28da%2Cb%29%7Bvar%20x%3D%210%3Bb%3Db.trim%28%29%3B%22%21%21%22%3D%3Db.substring%280%2C2%29%26%26%28x%3D%211%2Cb%3Db.substring%282%29%29%3B%0D%0Avar%20q%3Db%2Cp%3D%22%21%40%21%22%2CZ%3D-1%21%3Db.indexOf%28%22%5B%22%29%2Caa%3D%280%3D%3Db.indexOf%28%22tcf-v2%22%29%7C%7C0%3D%3Db.indexOf%28%22euconsent-v2%22%29%29%26%26-1%21%3Db.indexOf%28%22%5B%22%29%3B-1%21%3Db.indexOf%28%22%3D%22%29%26%26%28p%3Db.split%28%22%3D%22%29%2Cq%3Dp%5B0%5D%2Cp%3Dp%5B1%5D%2CZ%3D-1%21%3Dq.indexOf%28%22%5B%22%29%2Caa%3D%280%3D%3Dq.indexOf%28%22tcf-v2%22%29%7C%7C0%3D%3Dq.indexOf%28%22euconsent-v2%22%29%29%26%26-1%21%3Dq.indexOf%28%22%5B%22%29%29%3Bif%28aa%29a%28%22%23ai-iab-tcf-bar%22%29.show%28%29%2C%22object%22%3D%3Dtypeof%20ai_tcData%3F%28a%28%22%23ai-iab-tcf-bar%22%29.addClass%28%22status-ok%22%29%2Cq%3Dq.replace%28%2F%5D%7C%20%2Fgi%2C%22%22%29.split%28%22%5B%22%29%2Cq.shift%28%29%2Cr%3D%28q%3Dl%28q%2Cai_tcData%2Cp%29%29%3Fx%3A%21x%29%3A%28O.addClass%28%22ai-list-data%22%29%2CN%3D%210%2C%22function%22%3D%3Dtypeof%20__tcfapi%3F%0D%0AK%28%211%29%3A%22undefined%22%3D%3Dtypeof%20ai_tcData_retrying%26%26%28ai_tcData_retrying%3D%210%2CsetTimeout%28function%28%29%7B%22function%22%3D%3Dtypeof%20__tcfapi%3FK%28%211%29%3AsetTimeout%28function%28%29%7B%22function%22%3D%3Dtypeof%20__tcfapi%3FK%28%211%29%3AsetTimeout%28function%28%29%7BK%28%210%29%7D%2C3E3%29%7D%2C1E3%29%7D%2C600%29%29%29%3Belse%20if%28Z%29r%3D%28q%3DF%28Y%2Cq%2Cp%29%29%3Fx%3A%21x%3Belse%7Bvar%20T%3D%211%3B%22%21%40%21%22%3D%3Dp%3FJ.every%28function%28ea%29%7Breturn%20ea.split%28%22%3D%22%29%5B0%5D%3D%3Db%3F%28T%3D%210%2C%211%29%3A%210%7D%29%3AT%3D-1%21%3DJ.indexOf%28b%29%3Br%3DT%3Fx%3A%21x%7Dif%28%21r%29return%211%7D%29%3Bif%28r%29return%211%7D%29%3Br%26%26%28N%3D%211%29%3Bswitch%28f%29%7Bcase%20%22B%22%3Ar%26%26%28c%3D%211%29%3Bbreak%3Bcase%20%22W%22%3Ar%7C%7C%28c%3D%211%29%7Da%28this%29.hasClass%28%22ai-list-manual%22%29%26%26%0D%0A%28c%3F%28O.removeClass%28%22ai-list-data%22%29%2CO.removeClass%28%22ai-list-manual%22%29%29%3A%28k%3D%210%2CO.addClass%28%22ai-list-data%22%29%29%29%3Bif%28%21k%26%26%21N%26%26%28f%3Da%28this%29.data%28%22debug-info%22%29%2C%22undefined%22%21%3Dtypeof%20f%26%26%28f%3Da%28%22.%22%2Bf%29%2C0%21%3Df.length%29%29%29%7Bvar%20v%3Df.parent%28%29%3Bv.hasClass%28%22ai-debug-info%22%29%26%26v.remove%28%29%7D%7D%7Dv%3Da%28this%29.prevAll%28%22.ai-debug-bar.ai-debug-lists%22%29%3Bf%3D%22%22%3D%3Dw%3F%22%23%22%3Aw%3Bv.find%28%22.ai-debug-name.ai-list-info%22%29.text%28f%29.attr%28%22title%22%2CR%2B%22%5Cn%22%2BW%29%3Bv.find%28%22.ai-debug-name.ai-list-status%22%29.text%28c%3Fai_front.visible%3Aai_front.hidden%29%3Bf%3D%211%3Bif%28c%29%7Bvar%20D%3Da%28this%29.attr%28%22scheduling-start%22%29%3B%0D%0Ah%3Da%28this%29.attr%28%22scheduling-end%22%29%3Bvar%20H%3Da%28this%29.attr%28%22scheduling-days%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20D%26%26%22undefined%22%21%3Dtypeof%20h%26%26%22undefined%22%21%3Dtypeof%20H%29%7Bf%3D%210%3Bvar%20y%3Db64d%28D%29%2CP%3Db64d%28h%29%2CU%3DparseInt%28a%28this%29.attr%28%22scheduling-fallback%22%29%29%2CQ%3DparseInt%28a%28this%29.attr%28%22gmt%22%29%29%3By.includes%28%22-%22%29%7C%7CP.includes%28%22-%22%29%3F%28h%3Dt%28y%29%2BQ%2CD%3Dt%28P%29%2BQ%29%3A%28h%3DB%28y%29%2CD%3DB%28P%29%29%3BH%3Db64d%28H%29.split%28%22%2C%22%29%3Bv%3Da%28this%29.attr%28%22scheduling-type%22%29%3Bvar%20z%3D%28new%20Date%29.getTime%28%29%2BQ%2CE%3Dnew%20Date%28z%29%2CI%3DE.getDay%28%29%3By.includes%28%22-%22%29%7C%7CP.includes%28%22-%22%29%7C%7C%28y%3D%28new%20Date%28E.getFullYear%28%29%2CE.getMonth%28%29%2C%0D%0AE.getDate%28%29%29%29.getTime%28%29%2BQ%2Cz-%3Dy%2C0%3Ez%26%26%28z%2B%3D864E5%29%29%3B0%3D%3DI%3FI%3D6%3AI--%3By%3Dz%3E%3Dh%26%26z%3CD%26%26H.includes%28I.toString%28%29%29%3Bswitch%28v%29%7Bcase%20%22B%22%3Ay%3D%21y%7Dy%7C%7C%28c%3D%211%29%3BE%3DE.toISOString%28%29.split%28%22.%22%29%5B0%5D.replace%28%22T%22%2C%22%20%22%29%3Bv%3Da%28this%29.prevAll%28%22.ai-debug-bar.ai-debug-scheduling%22%29%3Bv.find%28%22.ai-debug-name.ai-scheduling-info%22%29.text%28E%2B%22%20%22%2BI%2B%22%20current_time%3A%22%2BMath.floor%28z.toString%28%29%2F1E3%29%2B%22%20%20start_date%3A%22%2BMath.floor%28h%2F1E3%29.toString%28%29%2B%22%20%3D%22%2B%28z%3E%3Dh%29.toString%28%29%2B%22%20end_date%3A%22%2BMath.floor%28D%2F1E3%29.toString%28%29%2B%22%20%3D%3A%22%2B%28z%3CD%29.toString%28%29%2B%22%20days%3A%22%2BH.toString%28%29%2B%22%20%3D%3A%22%2B%0D%0AH.includes%28I.toString%28%29%29.toString%28%29%29%3Bv.find%28%22.ai-debug-name.ai-scheduling-status%22%29.text%28c%3Fai_front.visible%3Aai_front.hidden%29%3Bc%7C%7C0%3D%3DU%7C%7C%28v.removeClass%28%22ai-debug-scheduling%22%29.addClass%28%22ai-debug-fallback%22%29%2Cv.find%28%22.ai-debug-name.ai-scheduling-status%22%29.text%28ai_front.fallback%2B%22%20%3D%20%22%2BU%29%29%7D%7Dif%28k%7C%7CN%29return%210%3Ba%28this%29.css%28%7Bvisibility%3A%22%22%2Cposition%3A%22%22%2Cwidth%3A%22%22%2Cheight%3A%22%22%2C%22z-index%22%3A%22%22%7D%29%3Bc%3F%28e.css%28%7Bvisibility%3A%22%22%7D%29%2Ce.hasClass%28%22ai-remove-position%22%29%26%26e.css%28%7Bposition%3A%22%22%7D%29%2C%22undefined%22%21%3Dtypeof%20a%28this%29.data%28%22code%22%29%26%26%28c%3Db64d%28a%28this%29.data%28%22code%22%29%29%2C%0D%0A0%21%3Da%28this%29.closest%28%22head%22%29.length%3F%28a%28this%29.after%28c%29%2Ca%28this%29.remove%28%29%29%3Aa%28this%29.append%28c%29%2Cai_process_element_lists%28this%29%29%29%3Af%26%26%21y%26%260%21%3DU%3F%28e.css%28%7Bvisibility%3A%22%22%7D%29%2Ce.hasClass%28%22ai-remove-position%22%29%26%26e.css%28%7Bposition%3A%22%22%7D%29%2Ca%28this%29.next%28%22.ai-fallback%22%29.removeClass%28%22ai-fallback%22%29%2C%22undefined%22%21%3Dtypeof%20a%28this%29.data%28%22fallback-code%22%29%3F%28c%3Db64d%28a%28this%29.data%28%22fallback-code%22%29%29%2Ca%28this%29.append%28c%29%2Cai_process_element_lists%28this%29%29%3A%28a%28this%29.hide%28%29%2Ce.find%28%22.ai-debug-block%22%29.length%7C%7C-1%21%3De.attr%28%22style%22%29.indexOf%28%22height%3A%22%29%7C%7Ce.hide%28%29%29%2C%0D%0Ac%3De.attr%28%22data-ai%22%29%2C%22undefined%22%21%3D%3Dtypeof%20c%26%26%211%21%3D%3Dc%26%26%28c%3Da%28this%29.attr%28%22fallback-tracking%22%29%2C%22undefined%22%21%3D%3Dtypeof%20c%26%26%211%21%3D%3Dc%26%26e.attr%28%22data-ai-%22%2Ba%28this%29.attr%28%22fallback_level%22%29%2Cc%29%29%29%3A%28a%28this%29.hide%28%29%2Ce.length%26%26%28e.removeAttr%28%22data-ai%22%29.removeClass%28%22ai-track%22%29%2Ce.find%28%22.ai-debug-block%22%29.length%3F%28e.css%28%7Bvisibility%3A%22%22%7D%29.removeClass%28%22ai-close%22%29%2Ce.hasClass%28%22ai-remove-position%22%29%26%26e.css%28%7Bposition%3A%22%22%7D%29%29%3A-1%3D%3De.attr%28%22style%22%29.indexOf%28%22height%3A%22%29%26%26e.hide%28%29%29%29%3Ba%28this%29.attr%28%22data-code%22%2C%22%22%29%3Ba%28this%29.attr%28%22data-fallback-code%22%2C%0D%0A%22%22%29%3Be.removeClass%28%22ai-list-block%22%29%7D%29%7D%7D%3Ba%28document%29.ready%28function%28d%29%7BsetTimeout%28function%28%29%7Bai_process_lists%28%29%3BsetTimeout%28function%28%29%7BG%28%29%3Bif%28%22function%22%3D%3Dtypeof%20ai_load_blocks%29%7Bvar%20l%3Dfunction%28F%29%7B%22cmplzEnableScripts%22%21%3DF.type%26%26%22all%22%21%3D%3DF.consentLevel%7C%7Cai_load_blocks%28%29%7D%3BjQuery%28document%29.on%28%22cmplzEnableScripts%22%2Cl%29%3BjQuery%28document%29.on%28%22cmplz_event_marketing%22%2Cl%29%7D%7D%2C50%29%3BjQuery%28%22.ai-debug-page-type%22%29.dblclick%28function%28%29%7BjQuery%28%22%23ai-iab-tcf-status%22%29.text%28%22CONSENT%20COOKIES%22%29%3BjQuery%28%22%23ai-iab-tcf-bar%22%29.show%28%29%7D%29%3BjQuery%28%22%23ai-iab-tcf-bar%22%29.click%28function%28%29%7Bm%28%22euconsent-v2%22%29%3B%0D%0Am%28%22__lxG__consent__v2%22%29%3Bm%28%22__lxG__consent__v2_daisybit%22%29%3Bm%28%22__lxG__consent__v2_gdaisybit%22%29%3Bm%28%22CookieLawInfoConsent%22%29%3Bm%28%22cookielawinfo-checkbox-advertisement%22%29%3Bm%28%22cookielawinfo-checkbox-analytics%22%29%3Bm%28%22cookielawinfo-checkbox-necessary%22%29%3Bm%28%22complianz_policy_id%22%29%3Bm%28%22complianz_consent_status%22%29%3Bm%28%22cmplz_marketing%22%29%3Bm%28%22cmplz_consent_status%22%29%3Bm%28%22cmplz_preferences%22%29%3Bm%28%22cmplz_statistics-anonymous%22%29%3Bm%28%22cmplz_choice%22%29%3Bm%28%22moove_gdpr_popup%22%29%3Bm%28%22real_cookie_banner-blog%3A1-tcf%22%29%3Bm%28%22real_cookie_banner-blog%3A1%22%29%3BjQuery%28%22%23ai-iab-tcf-status%22%29.text%28%22CONSENT%20COOKIES%20DELETED%22%29%7D%29%7D%2C%0D%0A5%29%7D%29%7D%29%3B%0D%0Afunction%20ai_process_element_lists%28a%29%7BsetTimeout%28function%28%29%7B%22function%22%3D%3Dtypeof%20ai_process_rotations_in_element%26%26ai_process_rotations_in_element%28a%29%3B%22function%22%3D%3Dtypeof%20ai_process_lists%26%26ai_process_lists%28jQuery%28%22.ai-list-data%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_ip_addresses%26%26ai_process_ip_addresses%28jQuery%28%22.ai-ip-data%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_filter_hooks%26%26ai_process_filter_hooks%28jQuery%28%22.ai-filter-check%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_adb_process_blocks%26%26ai_adb_process_blocks%28a%29%3B%22function%22%3D%3Dtypeof%20ai_process_impressions%26%26%0D%0A1%3D%3Dai_tracking_finished%26%26ai_process_impressions%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_click_trackers%26%261%3D%3Dai_tracking_finished%26%26ai_install_click_trackers%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_close_buttons%26%26ai_install_close_buttons%28document%29%7D%2C5%29%7D%0D%0Afunction%20getAllUrlParams%28a%29%7Bvar%20n%3Da%3Fa.split%28%22%3F%22%29%5B1%5D%3Awindow.location.search.slice%281%29%3Ba%3D%7B%7D%3Bif%28n%29%7Bn%3Dn.split%28%22%23%22%29%5B0%5D%3Bn%3Dn.split%28%22%26%22%29%3Bfor%28var%20B%3D0%3BB%3Cn.length%3BB%2B%2B%29%7Bvar%20t%3Dn%5BB%5D.split%28%22%3D%22%29%2CG%3Dvoid%200%2Cu%3Dt%5B0%5D.replace%28%2F%5C%5B%5Cd%2A%5C%5D%2F%2Cfunction%28m%29%7BG%3Dm.slice%281%2C-1%29%3Breturn%22%22%7D%29%3Bt%3D%22undefined%22%3D%3D%3Dtypeof%20t%5B1%5D%3F%22%22%3At%5B1%5D%3Bu%3Du.toLowerCase%28%29%3Bt%3Dt.toLowerCase%28%29%3Ba%5Bu%5D%3F%28%22string%22%3D%3D%3Dtypeof%20a%5Bu%5D%26%26%28a%5Bu%5D%3D%5Ba%5Bu%5D%5D%29%2C%22undefined%22%3D%3D%3Dtypeof%20G%3Fa%5Bu%5D.push%28t%29%3Aa%5Bu%5D%5BG%5D%3Dt%29%3Aa%5Bu%5D%3Dt%7D%7Dreturn%20a%7D%3B%0D%0AjQuery%28function%28a%29%7Bfunction%20u%28e%2Cc%29%7Bc%7C%7C%28c%3Dwindow.location.href%29%3Be%3De.replace%28%2F%5B%5C%5B%5C%5D%5D%2Fg%2C%22%5C%5C%24%26%22%29%3Bvar%20f%3D%28new%20RegExp%28%22%5B%3F%26%5D%22%2Be%2B%22%28%3D%28%5B%5E%26%23%5D%2A%29%7C%26%7C%23%7C%24%29%22%29%29.exec%28c%29%3Breturn%20f%3Ff%5B2%5D%3FdecodeURIComponent%28f%5B2%5D.replace%28%2F%5C%2B%2Fg%2C%22%20%22%29%29%3A%22%22%3Anull%7Dfunction%20v%28e%29%7Be.removeClass%28%22ai-ip-data%22%29%3Bvar%20c%3D%211%3Bif%28%22%22%21%3Dai_ip_data%29%7Btry%7Bvar%20f%3DJSON.parse%28ai_ip_data%29%2Cg%3Df%5B0%5D%2Cl%3Df%5B1%5D%2Cn%3Df%5B2%5D%2Cp%3Df%5B3%5D%7Dcatch%28d%29%7Breturn%7Dvar%20r%3D%211%3B-1%21%3Dg.indexOf%28%22%23%22%29%26%26%28r%3D%210%2Cg%3Dg.replace%28%22%23%22%2C%22%22%29%29%3Bvar%20q%3D%22%22%3Br%26%26%28q%3D%22CFP%20BLOCKED%2C%20%22%29%3Bq%3Dq%2Bg%2B%22%2C%20%22%2Bl%3Bnull%21%3Dn%26%26null%21%3Dp%26%26%28q%3Dq%2B%22%3A%22%2Bn%2B%22%3A%22%2Bp%29%3Bnull%3D%3D%0An%26%26%28n%3D%22%22%29%3Bnull%3D%3Dp%26%26%28p%3D%22%22%29%3Bnull%21%3Df%26%26e.each%28function%28%29%7Bvar%20d%3Da%28this%29.closest%28%22div.code-block%22%29%3Bc%3D%210%3Bvar%20h%3Da%28this%29.attr%28%22ip-addresses%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20h%29%7Bh%3Dh.split%28%22%2C%22%29%3Bvar%20t%3Da%28this%29.attr%28%22ip-address-list%22%29%2Ck%3D%211%3Ba.each%28h%2Cfunction%28w%2Cb%29%7Bif%28%22%2A%22%3D%3Db.charAt%280%29%29if%28%22%2A%22%3D%3Db.charAt%28b.length-1%29%29%7Bif%28b%3Db.substr%281%2Cb.length-2%29%2C-1%21%3Dg.indexOf%28b%29%29return%20k%3D%210%2C%211%7Delse%7Bif%28b%3Db.substr%281%29%2Cg.substr%28-b.length%29%3D%3Db%29return%20k%3D%210%2C%211%7Delse%20if%28%22%2A%22%3D%3Db.charAt%28b.length-1%29%29%7Bif%28b%3Db.substr%280%2Cb.length-1%29%2C0%3D%3Dg.indexOf%28b%29%29return%20k%3D%0A%210%2C%211%7Delse%20if%28%22%23%22%3D%3Db%29%7Bif%28%22%22%3D%3Dg%29return%20k%3D%210%2C%211%7Delse%20if%28%22CFP%22%3D%3Db.toUpperCase%28%29%29%7Bif%28r%29return%20k%3D%210%2C%211%7Delse%20if%28b%3D%3Dg%29return%20k%3D%210%2C%211%7D%29%3Bswitch%28t%29%7Bcase%20%22B%22%3Ak%26%26%28c%3D%211%29%3Bbreak%3Bcase%20%22W%22%3Ak%7C%7C%28c%3D%211%29%7D%7Dif%28c%26%26%28h%3Da%28this%29.attr%28%22countries%22%29%2C%22undefined%22%21%3Dtypeof%20h%29%29switch%28h%3Dh.split%28%22%2C%22%29%2Ct%3Da%28this%29.attr%28%22country-list%22%29%2Ck%3D%211%2Ca.each%28h%2Cfunction%28w%2Cb%29%7Bvar%20m%3Db.trim%28%29.split%28%22%3A%22%29%3Bif%28null%3D%3Dm%5B1%5D%7C%7C%22%22%3D%3Dn%29m%5B1%5D%3D%22%22%3Bif%28null%3D%3Dm%5B2%5D%7C%7C%22%22%3D%3Dp%29m%5B2%5D%3D%22%22%3Bvar%20x%3Dm.join%28%22%3A%22%29.toUpperCase%28%29%3Bm%3D%28l%2B%22%3A%22%2B%28%22%22%3D%3Dm%5B1%5D%3F%22%22%3An%29%2B%22%3A%22%2B%28%22%22%3D%3Dm%5B2%5D%3F%22%22%3Ap%29%29.toUpperCase%28%29%3Bif%28x%3D%3D%0Am%29return%20k%3D%210%2C%211%7D%29%2Ct%29%7Bcase%20%22B%22%3Ak%26%26%28c%3D%211%29%3Bbreak%3Bcase%20%22W%22%3Ak%7C%7C%28c%3D%211%29%7Da%28this%29.css%28%7Bvisibility%3A%22%22%2Cposition%3A%22%22%2Cwidth%3A%22%22%2Cheight%3A%22%22%2C%22z-index%22%3A%22%22%7D%29%3Bh%3Da%28this%29.prev%28%22.ai-debug-bar%22%29%3Bh.find%28%22.ai-debug-name.ai-ip-country%22%29.text%28q%29%3Bh.find%28%22.ai-debug-name.ai-ip-status%22%29.text%28c%3Fai_front.visible%3Aai_front.hidden%29%3Bc%3F%28d.css%28%7Bvisibility%3A%22%22%7D%29%2Cd.hasClass%28%22ai-remove-position%22%29%26%26d.css%28%7Bposition%3A%22%22%7D%29%2C%22undefined%22%21%3Dtypeof%20a%28this%29.data%28%22code%22%29%26%26%28h%3Db64d%28a%28this%29.data%28%22code%22%29%29%2C0%21%3Da%28this%29.closest%28%22head%22%29.length%3F%28a%28this%29.after%28h%29%2C%0Aa%28this%29.remove%28%29%29%3Aa%28this%29.append%28h%29%2Ca%28this%29.attr%28%22data-code%22%2C%22%22%29%2Cai_process_element%28this%29%29%29%3A%28a%28this%29.hide%28%29%2Cd.length%26%26%28d.removeAttr%28%22data-ai%22%29.removeClass%28%22ai-track%22%29%2Cd.find%28%22.ai-debug-block%22%29.length%3F%28d.css%28%7Bvisibility%3A%22%22%7D%29.removeClass%28%22ai-close%22%29%2Cd.hasClass%28%22ai-remove-position%22%29%26%26d.css%28%7Bposition%3A%22%22%7D%29%2C%22undefined%22%21%3Dtypeof%20a%28this%29.data%28%22code%22%29%26%26%28d.removeClass%28%22ai-list-block%22%29%2Cd.removeClass%28%22ai-list-block-filter%22%29%2Cd.prev%28%29.hasClass%28%22ai-debug-info%22%29%26%26d.prev%28%29.remove%28%29%29%29%3A-1%3D%3Dd.attr%28%22style%22%29.indexOf%28%22height%3A%22%29%26%26%0Ad.hide%28%29%29%29%3Bd.removeClass%28%22ai-list-block-ip%22%29%7D%29%7D%7Dai_process_ip_addresses%3Dfunction%28e%29%7Be%3Dnull%3D%3De%3Fa%28%22div.ai-ip-data%2C%20meta.ai-ip-data%22%29%3Ae.filter%28%22.ai-ip-data%22%29%3Bif%28e.length%29if%28%22undefined%22%21%3Dtypeof%20ai_ip_data%29v%28e%29%3Belse%20if%28%22undefined%22%3D%3Dtypeof%20ai_ip_data_requested%29%7Bai_ip_data_requested%3D%210%3Bvar%20c%3D%22%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dai_ajax%26ip-data%3Dip-address-country-city%22%2Cf%3Du%28%22ai-debug-ip-address%22%29%3Bnull%21%3Df%26%26%28c%2B%3D%22%26ai-debug-ip-address%3D%22%2Bf%29%3Bf%3Du%28%22ai-debug-country%22%29%3Bnull%21%3Df%26%26%28c%2B%3D%22%26ai-debug-country%3D%22%2Bf%29%3Ba.ajax%28%7Burl%3Ac%2C%0Atype%3A%22post%22%2Cdata%3A%7Bai_check%3A%229bfc3d7aee%22%2Cai_version%3A%28new%20Date%29.getTime%28%29%2B%22-%22%2BMath.round%281E5%2AMath.random%28%29%29%7D%2Casync%3A%210%7D%29.done%28function%28g%29%7Bai_ip_data%3Dg%3Bif%28%22%22%3D%3Dg%29%7Bvar%20l%3D%22Ajax%20request%20returned%20empty%20data%2C%20geo-targeting%20disabled%22%3Bconsole.error%28l%29%3B%22undefined%22%21%3Dtypeof%20ai_js_errors%26%26ai_js_errors.push%28%5Bl%2Cc%2C0%5D%29%7Delse%20try%7BJSON.parse%28g%29%7Dcatch%28n%29%7Bl%3D%22Ajax%20call%20returned%20invalid%20data%2C%20geo-targeting%20disabled%22%2Cconsole.error%28l%2Cg%29%2C%22undefined%22%21%3Dtypeof%20ai_js_errors%26%26ai_js_errors.push%28%5Bl%2Cc%2C0%5D%29%7De%3Da%28%22div.ai-ip-data%2C%20meta.ai-ip-data%22%29%3B%0Ae.length%26%26v%28e%29%7D%29.fail%28function%28g%2Cl%2Cn%29%7Ba%28%22div.ai-ip-data%22%29.each%28function%28%29%7Ba%28this%29.css%28%7Bdisplay%3A%22none%22%2Cvisibility%3A%22%22%2Cposition%3A%22%22%2Cwidth%3A%22%22%2Cheight%3A%22%22%2C%22z-index%22%3A%22%22%7D%29.removeClass%28%22ai-ip-data%22%29.hide%28%29%7D%29%7D%29%7D%7D%3Ba%28document%29.ready%28function%28e%29%7BsetTimeout%28function%28%29%7Bai_process_ip_addresses%28%29%7D%2C5%29%7D%29%7D%29%3B%0Afunction%20ai_process_element%28a%29%7BsetTimeout%28function%28%29%7B%22function%22%3D%3Dtypeof%20ai_process_rotations_in_element%26%26ai_process_rotations_in_element%28a%29%3B%22function%22%3D%3Dtypeof%20ai_process_lists%26%26ai_process_lists%28jQuery%28%22.ai-list-data%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_ip_addresses%26%26ai_process_ip_addresses%28jQuery%28%22.ai-ip-data%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_process_filter_hooks%26%26ai_process_filter_hooks%28jQuery%28%22.ai-filter-check%22%2Ca%29%29%3B%22function%22%3D%3Dtypeof%20ai_adb_process_blocks%26%26ai_adb_process_blocks%28a%29%3B%22function%22%3D%3Dtypeof%20ai_process_impressions%26%26%0A1%3D%3Dai_tracking_finished%26%26ai_process_impressions%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_click_trackers%26%261%3D%3Dai_tracking_finished%26%26ai_install_click_trackers%28%29%3B%22function%22%3D%3Dtypeof%20ai_install_close_buttons%26%26ai_install_close_buttons%28document%29%7D%2C5%29%7D%3B%0A%28function%28e%2Cy%29%7B%22function%22%3D%3D%3Dtypeof%20define%26%26define.amd%3Fdefine%28%5B%22jquery%22%5D%2Cfunction%28l%29%7Breturn%20y%28l%29%7D%29%3A%22object%22%3D%3D%3Dtypeof%20module%26%26module.exports%3Fmodule.exports%3Dy%28require%28%22jquery%22%29%29%3Ay%28e.jQuery%29%7D%29%28this%2Cfunction%28e%29%7Bfunction%20y%28l%2Cm%29%7Breturn%28new%20RegExp%28%22%5E%22%2Bm.split%28%22%2A%22%29.map%28function%28n%29%7Breturn%20n.replace%28%2F%28%5B.%2A%2B%3F%5E%3D%21%3A%24%7B%7D%28%29%7C%5C%5B%5C%5D%5C%2F%5C%5C%5D%29%2Fg%2C%22%5C%5C%241%22%29%7D%29.join%28%22.%2A%22%29%2B%22%24%22%29%29.test%28l%29%7D%28function%28l%29%7Bl.fn.iframeTracker%3Dfunction%28m%29%7B%22function%22%3D%3Dtypeof%20m%26%26%28m%3D%7BblurCallback%3Am%7D%29%3Bvar%20n%3Dthis.get%28%29%3Bif%28null%3D%3D%3Dm%7C%7C%211%3D%3D%3Dm%29l.iframeTracker.untrack%28n%29%3B%0Aelse%20if%28%22object%22%3D%3Dtypeof%20m%29l.iframeTracker.track%28n%2Cm%29%3Belse%20throw%20Error%28%22Wrong%20handler%20type%20%28must%20be%20an%20object%2C%20or%20null%7Cfalse%20to%20untrack%29%22%29%3Breturn%20this%7D%3Bl.iframeTracker%3D%7BfocusRetriever%3Anull%2CfocusRetrieved%3A%211%2ChandlersList%3A%5B%5D%2CisIE8AndOlder%3A%211%2Cinit%3Afunction%28%29%7Btry%7B%210%3D%3D%3Dl.browser.msie%26%269%3El.browser.version%26%26%28this.isIE8AndOlder%3D%210%29%7Dcatch%28n%29%7Btry%7B9%3Enavigator.userAgent.match%28RegExp%28%22%28msie%29%20%28%5B%5C%5Cw.%5D%2B%29%22%2C%22i%22%29%29%5B2%5D%26%26%28this.isIE8AndOlder%3D%210%29%7Dcatch%28v%29%7B%7D%7Dl%28window%29.focus%28%29%3Bl%28window%29.blur%28function%28n%29%7Bl.iframeTracker.windowLoseFocus%28n%29%7D%29%3B%0Al%28%22body%22%29.append%28%27%3Cdiv%20style%3D%22position%3Afixed%3B%20top%3A0%3B%20left%3A0%3B%20overflow%3Ahidden%3B%22%3E%3Cinput%20style%3D%22position%3Aabsolute%3B%20left%3A-300px%3B%22%20type%3D%22text%22%20value%3D%22%22%20id%3D%22focus_retriever%22%20readonly%3D%22true%22%20%2F%3E%3C%2Fdiv%3E%27%29%3Bthis.focusRetriever%3Dl%28%22%23focus_retriever%22%29%3Bthis.focusRetrieved%3D%211%3Bvar%20m%3Dthis%3Bl%28document%29.mousemove%28function%28n%29%7Bif%28document.activeElement%26%26%22IFRAME%22%3D%3D%3Ddocument.activeElement.tagName%29%7Bvar%20v%3D%210%3Bif%28document.activeElement.hasAttribute%28%22id%22%29%26%26%22undefined%22%21%3D%3Dtypeof%20ai_ignore_iframe_ids%26%26ai_ignore_iframe_ids.constructor%3D%3D%3D%0AArray%29%7Bvar%20z%3Ddocument.activeElement.id%3Bai_ignore_iframe_ids.forEach%28function%28C%29%7By%28z%2CC%29%26%26%28v%3D%211%29%7D%29%7Dif%28v%26%26document.activeElement.hasAttribute%28%22class%22%29%26%26%22undefined%22%21%3D%3Dtypeof%20ai_ignore_iframe_classes%26%26ai_ignore_iframe_classes.constructor%3D%3D%3DArray%29%7Bvar%20A%3Ddocument.activeElement.className%3Bai_ignore_iframe_classes.forEach%28function%28C%29%7By%28A%2CC%29%26%26%28v%3D%211%29%7D%29%7Dv%26%26%28l.iframeTracker.focusRetriever.focus%28%29%2Cl.iframeTracker.focusRetrieved%3D%210%29%7Dif%28document.activeElement%26%26%22A%22%3D%3Ddocument.activeElement.tagName%29for%28var%20F%20in%20m.handlersList%29try%7Bm.handlersList%5BF%5D.focusCallback%28document.activeElement%29%7Dcatch%28C%29%7B%7D%7D%29%3B%0Aif%28this.isIE8AndOlder%29%7Bthis.focusRetriever.blur%28function%28n%29%7Bn.stopPropagation%28%29%3Bn.preventDefault%28%29%3Bl.iframeTracker.windowLoseFocus%28n%29%7D%29%3Bl%28%22body%22%29.click%28function%28n%29%7Bl%28window%29.focus%28%29%7D%29%3Bl%28%22form%22%29.click%28function%28n%29%7Bn.stopPropagation%28%29%7D%29%3Btry%7Bl%28%22body%22%29.on%28%22click%22%2C%22form%22%2Cfunction%28n%29%7Bn.stopPropagation%28%29%7D%29%7Dcatch%28n%29%7Bconsole.log%28%22%5BiframeTracker%5D%20Please%20update%20jQuery%20to%201.7%20or%20newer.%20%28exception%3A%20%22%2Bn.message%2B%22%29%22%29%7D%7D%7D%2Ctrack%3Afunction%28m%2Cn%29%7Bn.target%3Dm%3Bl.iframeTracker.handlersList.push%28n%29%3Bl%28m%29.bind%28%22mouseover%22%2C%7Bhandler%3An%7D%2C%0Al.iframeTracker.mouseoverListener%29.bind%28%22mouseout%22%2C%7Bhandler%3An%7D%2Cl.iframeTracker.mouseoutListener%29%7D%2Cuntrack%3Afunction%28m%29%7Bif%28%22function%22%21%3Dtypeof%20Array.prototype.filter%29console.log%28%22Your%20browser%20doesn%27t%20support%20Array%20filter%2C%20untrack%20disabled%22%29%3Belse%7Bl%28m%29.each%28function%28A%29%7Bl%28this%29.unbind%28%22mouseover%22%2Cl.iframeTracker.mouseoverListener%29.unbind%28%22mouseout%22%2Cl.iframeTracker.mouseoutListener%29%7D%29%3Bvar%20n%3Dfunction%28A%29%7Breturn%20null%3D%3D%3DA%3F%211%3A%210%7D%2Cv%3Bfor%28v%20in%20this.handlersList%29%7Bfor%28var%20z%20in%20this.handlersList%5Bv%5D.target%29-1%21%3D%3Dl.inArray%28this.handlersList%5Bv%5D.target%5Bz%5D%2C%0Am%29%26%26%28this.handlersList%5Bv%5D.target%5Bz%5D%3Dnull%29%3Bthis.handlersList%5Bv%5D.target%3Dthis.handlersList%5Bv%5D.target.filter%28n%29%3B0%3D%3D%3Dthis.handlersList%5Bv%5D.target.length%26%26%28this.handlersList%5Bv%5D%3Dnull%29%7Dthis.handlersList%3Dthis.handlersList.filter%28n%29%7D%7D%2CmouseoverListener%3Afunction%28m%29%7Bm.data.handler.over%3D%210%3Btry%7Bm.data.handler.overCallback%28this%2Cm%29%7Dcatch%28n%29%7B%7D%7D%2CmouseoutListener%3Afunction%28m%29%7Bm.data.handler.over%3D%211%3Bl.iframeTracker.focusRetriever.focus%28%29%3Btry%7Bm.data.handler.outCallback%28this%2Cm%29%7Dcatch%28n%29%7B%7D%7D%2CwindowLoseFocus%3Afunction%28m%29%7Bfor%28var%20n%20in%20this.handlersList%29if%28%210%3D%3D%3D%0Athis.handlersList%5Bn%5D.over%29try%7Bthis.handlersList%5Bn%5D.blurCallback%28m%29%7Dcatch%28v%29%7B%7D%7D%7D%3Bl%28document%29.ready%28function%28%29%7Bl.iframeTracker.init%28%29%7D%29%7D%29%28e%29%7D%29%3Bai_tracking_finished%3D%211%3B%0AjQuery%28document%29.ready%28function%28e%29%7Bfunction%20y%28b%2Ch%2Cg%2Ca%2Cc%2Cp%2Cf%2Cd%29%7Bb%3Db.replace%28%22%5BEVENT%5D%22%2Ch%29%3Bb%3Db.replace%28%22%5BBLOCK_NUMBER%5D%22%2Cg%29%3Bb%3Db.replace%28%22%5BBLOCK_NAME%5D%22%2Ca%29%3Bb%3Db.replace%28%22%5BBLOCK_COUNTER%5D%22%2Cc%29%3Bb%3Db.replace%28%22%5BVERSION_NUMBER%5D%22%2Cp%29%3Bb%3Db.replace%28%22%5BVERSION_NAME%5D%22%2Cf%29%3Bb%3Db.replace%28%22%5BBLOCK_VERSION_NUMBER%5D%22%2Cg%2B%280%3D%3Dp%3F%22%22%3A%22%20-%20%22%2Bp%29%29%3Bb%3Db.replace%28%22%5BBLOCK_VERSION_NAME%5D%22%2Ca%2B%28%22%22%3D%3Df%3F%22%22%3A%22%20-%20%22%2Bf%29%29%3Breturn%20b%3Db.replace%28%22%5B%5D%22%2C%22%22%29%7Dfunction%20l%28b%2Ch%2Cg%2Ca%2Cc%2Cp%2Cf%29%7Bvar%20d%3Dy%28%22Ad%20Inserter%20Pro%22%2Cb%2Ch%2Cg%2Ca%2Cc%2Cp%29%2Cq%3Dy%28%22%5BEVENT%5D%22%2Cb%2C%0Ah%2Cg%2Ca%2Cc%2Cp%29%2Ck%3Dy%28%22%5BBLOCK_NUMBER%5D%20-%20%5BBLOCK_VERSION_NAME%5D%22%2Cb%2Ch%2Cg%2Ca%2Cc%2Cp%29%3Bif%28%22function%22%21%3Dtypeof%20ai_external_tracking_event%7C%7C0%21%3Dai_external_tracking_event%28%7Bevent%3Ab%2Cblock%3Ah%2Cblock_name%3Ag%2Cblock_counter%3Aa%2Cversion%3Ac%2Cversion_name%3Ap%7D%2Cd%2Cq%2Ck%2Cf%29%29%22function%22%3D%3Dtypeof%20window.ga%3F%28b%3D%22send%22%2C%22string%22%3D%3Dtypeof%20ai_ga_tracker_name%3Fb%3Dai_ga_tracker_name%2B%22.%22%2Bb%3A%28h%3Dga.getAll%28%29%2C0%21%3Dh.length%26%26%28h%3Dh%5B0%5D.get%28%22name%22%29%2C%22t0%22%21%3Dh%26%26%28b%3Dh%2B%22.%22%2Bb%29%29%29%2Cga%28b%2C%22event%22%2C%7BeventCategory%3Ad%2CeventAction%3Aq%2CeventLabel%3Ak%2CnonInteraction%3Af%7D%29%29%3A%22function%22%3D%3Dtypeof%20window.gtag%3Fgtag%28%22event%22%2C%22impression%22%2C%0A%7Bevent_category%3Ad%2Cevent_action%3Aq%2Cevent_label%3Ak%2Cnon_interaction%3Af%7D%29%3A%22function%22%3D%3Dtypeof%20window.__gaTracker%3F__gaTracker%28%22send%22%2C%22event%22%2C%7BeventCategory%3Ad%2CeventAction%3Aq%2CeventLabel%3Ak%2CnonInteraction%3Af%7D%29%3A%22object%22%3D%3Dtypeof%20_gaq%26%26_gaq.push%28%5B%22_trackEvent%22%2Cd%2Cq%2Ck%2Cvoid%200%2Cf%5D%29%2C%22object%22%3D%3Dtypeof%20_paq%26%26_paq.push%28%5B%22trackEvent%22%2Cd%2Cq%2Ck%5D%29%7Dfunction%20m%28b%2Ch%29%7Bvar%20g%3Db%5B0%5D%2Ca%3Db%5B1%5D%3Bif%28Number.isInteger%28a%29%29if%28%22undefined%22%3D%3Dtypeof%20ai_check_data%26%26%22undefined%22%3D%3Dtypeof%20ai_check_data_timeout%29ai_check_data_timeout%3D%210%2CsetTimeout%28function%28%29%7Bm%28b%2C%0Ah%29%7D%2C2500%29%3Belse%7Bai_cookie%3Dai_load_cookie%28%29%3Bfor%28var%20c%20in%20ai_cookie%29if%28parseInt%28g%29%3D%3DparseInt%28c%29%29for%28var%20p%20in%20ai_cookie%5Bc%5D%29if%28%22c%22%3D%3Dp%29%7Bvar%20f%3Dai_cookie%5Bc%5D%5Bp%5D%3Bif%280%3Cf%29if%28ai_set_cookie%28c%2C%22c%22%2Cf-1%29%2C1%3D%3Df%29%7Bf%3De%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.data%28%22ai-cfp-time%22%29%3Bvar%20d%3Dnew%20Date%3Bd%3DMath.round%28d.getTime%28%29%2F1E3%29%3Bvar%20q%3Dd%2B604800%3Bai_set_cookie%28c%2C%22c%22%2C-q%29%3BsetTimeout%28function%28%29%7Be%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C50%29%7Delse%20ai_set_cookie%28c%2C%22c%22%2Cf-1%29%7Delse%20if%28%22cpt%22%3D%3Dp%29if%28f%3Dai_cookie%5Bc%5D%5Bp%5D%2C0%3Cf%29%7Bif%28ai_set_cookie%28c%2C%0A%22cpt%22%2Cf-1%29%2C1%3D%3Df%29%7Bf%3De%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.data%28%22ai-cfp-time%22%29%3Bd%3Dnew%20Date%3Bd%3DMath.round%28d.getTime%28%29%2F1E3%29%3Bq%3Dai_cookie%5Bc%5D.ct%3Bai_set_cookie%28c%2C%22x%22%2Cq%29%3Bvar%20k%3De%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.closest%28%22div%5Bdata-ai%5D%22%29%3BsetTimeout%28function%28%29%7Bk.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C75%29%3B%22undefined%22%21%3Dtypeof%20f%26%26%28q%3Dd%2B86400%2Af%2Cai_set_cookie%28g%2C%22x%22%2Cq%29%2Ce%28%22span.ai-cfp%22%29.each%28function%28r%29%7Br%3De%28this%29.data%28%22ai-block%22%29%3Bvar%20u%3De%28this%29%3BsetTimeout%28function%28%29%7Bu.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C50%29%3Bai_set_cookie%28r%2C%22x%22%2Cq%29%7D%29%29%7D%7Delse%20ai_check_data.hasOwnProperty%28c%29%26%26%0Aai_check_data%5Bc%5D.hasOwnProperty%28%22cpt%22%29%26%26ai_check_data%5Bc%5D.hasOwnProperty%28%22ct%22%29%3Fai_cookie.hasOwnProperty%28c%29%26%26ai_cookie%5Bc%5D.hasOwnProperty%28%22ct%22%29%26%26%28d%3Dnew%20Date%2Cf%3Dai_cookie%5Bc%5D.ct-Math.round%28d.getTime%28%29%2F1E3%29%2C0%3E%3Df%26%26%28d%3DMath.round%28d.getTime%28%29%2F1E3%29%2Cai_set_cookie%28c%2C%22cpt%22%2Cai_check_data%5Bc%5D.cpt-1%29%2Cai_set_cookie%28c%2C%22ct%22%2CMath.round%28d%2B86400%2Aai_check_data%5Bc%5D.ct%29%29%29%29%3A%28ai_cookie.hasOwnProperty%28c%29%26%26ai_cookie%5Bc%5D.hasOwnProperty%28%22cpt%22%29%26%26ai_set_cookie%28c%2C%22cpt%22%2C%22%22%29%2Cai_cookie.hasOwnProperty%28c%29%26%26ai_cookie%5Bc%5D.hasOwnProperty%28%22ct%22%29%26%26%0Aai_set_cookie%28c%2C%22ct%22%2C%22%22%29%29%3Bai_cookie.hasOwnProperty%28%22G%22%29%26%26ai_cookie.G.hasOwnProperty%28%22cpt%22%29%26%26%28f%3Dai_cookie.G.cpt%2C0%3Cf%3F%28ai_set_cookie%28%22G%22%2C%22cpt%22%2Cf-1%29%2C1%3D%3Df%26%26%28f%3De%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.data%28%22ai-cfp-time%22%29%2Cd%3Dnew%20Date%2Cd%3DMath.round%28d.getTime%28%29%2F1E3%29%2Cq%3Dai_cookie.G.ct%2Cai_set_cookie%28g%2C%22x%22%2Cq%29%2Ck%3De%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.closest%28%22div%5Bdata-ai%5D%22%29%2CsetTimeout%28function%28%29%7Bk.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C75%29%2C%22undefined%22%21%3Dtypeof%20f%26%26%28q%3Dd%2B86400%2Af%2Cai_set_cookie%28g%2C%22x%22%2Cq%29%2Ce%28%22span.ai-cfp%22%29.each%28function%28r%29%7Br%3De%28this%29.data%28%22ai-block%22%29%3B%0Avar%20u%3De%28this%29%3BsetTimeout%28function%28%29%7Bu.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C50%29%3Bai_set_cookie%28r%2C%22x%22%2Cq%29%7D%29%29%29%29%3Aai_check_data.hasOwnProperty%28%22G%22%29%26%26ai_check_data.G.hasOwnProperty%28%22cpt%22%29%26%26ai_check_data.G.hasOwnProperty%28%22ct%22%29%3Fai_cookie.hasOwnProperty%28%22G%22%29%26%26ai_cookie.G.hasOwnProperty%28%22ct%22%29%26%26%28d%3Dnew%20Date%2Cf%3Dai_cookie.G.ct-Math.round%28d.getTime%28%29%2F1E3%29%2C0%3E%3Df%26%26%28d%3DMath.round%28d.getTime%28%29%2F1E3%29%2Cai_set_cookie%28%22G%22%2C%22cpt%22%2Cai_check_data.G.cpt-1%29%2Cai_set_cookie%28%22G%22%2C%22ct%22%2CMath.round%28d%2B86400%2Aai_check_data.G.ct%29%29%29%29%3A%28ai_cookie.hasOwnProperty%28%22G%22%29%26%26%0Aai_cookie.G.hasOwnProperty%28%22cpt%22%29%26%26ai_set_cookie%28%22G%22%2C%22cpt%22%2C%22%22%29%2Cai_cookie.hasOwnProperty%28%22G%22%29%26%26ai_cookie.G.hasOwnProperty%28%22ct%22%29%26%26ai_set_cookie%28%22G%22%2C%22ct%22%2C%22%22%29%29%29%3Bz%26%26%22undefined%22%3D%3D%3Dtypeof%20ai_internal_tracking_no_clicks%26%26e.ajax%28%7Burl%3AE%2Ctype%3A%22post%22%2Cdata%3A%7Baction%3A%22ai_ajax%22%2Cai_check%3A%229bfc3d7aee%22%2Cclick%3Ag%2Cversion%3Aa%2Ctype%3Ah%7D%2Casync%3A%210%7D%29.done%28function%28r%29%7Br%3Dr.trim%28%29%3B%22%22%21%3Dr%26%26%28r%3DJSON.parse%28r%29%2C%22undefined%22%21%3Dtypeof%20r%5B%22%23%22%5D%26%26r%5B%22%23%22%5D%3D%3Dg%26%26%28ai_cookie%3Dai_load_cookie%28%29%2CsetTimeout%28function%28%29%7Be%28%22span%5Bdata-ai-block%3D%22%2Bg%2B%22%5D%22%29.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C%0A50%29%2Cr%3DMath.round%28%28new%20Date%29.getTime%28%29%2F1E3%29%2B43200%2Cai_cookie.hasOwnProperty%28g%29%26%26ai_cookie%5Bg%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28g%2C%22x%22%2Cr%29%29%29%7D%29%3Bif%28A%26%26%22undefined%22%3D%3D%3Dtypeof%20ai_external_tracking_no_clicks%29%7Bvar%20w%3Db%5B2%5D%2Ct%3Db%5B3%5D%3Bl%28%22click%22%2Cg%2Cw%2Cb%5B4%5D%2Ca%2Ct%2C%211%29%7D%22function%22%3D%3Dtypeof%20ai_click_action%26%26ai_click_action%28g%2Cw%2Ca%2Ct%29%7D%7Dfunction%20n%28%29%7Bai_check_data%3D%7B%7D%3Bif%28%22undefined%22%3D%3Dtypeof%20ai_iframe%29%7Bai_cookie%3Dai_load_cookie%28%29%3Be%28%22.ai-check-block%22%29.each%28function%28%29%7Bvar%20a%3De%28this%29.data%28%22ai-block%22%29%2Cc%3De%28this%29.data%28%22ai-delay-pv%22%29%2Cp%3De%28this%29.data%28%22ai-every-pv%22%29%2C%0Af%3De%28this%29.data%28%22ai-hash%22%29%2Cd%3De%28this%29.data%28%22ai-max-imp%22%29%2Cq%3De%28this%29.data%28%22ai-limit-imp-per-time%22%29%2Ck%3De%28this%29.data%28%22ai-limit-imp-time%22%29%2Cw%3De%28this%29.data%28%22ai-max-clicks%22%29%2Ct%3De%28this%29.data%28%22ai-limit-clicks-per-time%22%29%2Cr%3De%28this%29.data%28%22ai-limit-clicks-time%22%29%2Cu%3De%28this%29.data%28%22ai-global-limit-clicks-per-time%22%29%2Cx%3De%28this%29.data%28%22ai-global-limit-clicks-time%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20c%26%260%3Cc%29%7Bai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%3Bai_check_data%5Ba%5D.d%3Dc%3Bvar%20B%3D%22%22%3Bai_cookie.hasOwnProperty%28a%29%26%26ai_cookie%5Ba%5D.hasOwnProperty%28%22d%22%29%26%26%0A%28B%3Dai_cookie%5Ba%5D.d%29%3B%22%22%3D%3D%3DB%26%26ai_set_cookie%28a%2C%22d%22%2Cc-1%29%7D%22undefined%22%21%3Dtypeof%20p%26%262%3C%3Dp%26%26%28ai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%2C%22undefined%22%21%3D%3Dtypeof%20ai_delay_showing_pageviews%7C%7Cai_cookie.hasOwnProperty%28a%29%26%26ai_cookie%5Ba%5D.hasOwnProperty%28%22d%22%29%7C%7C%28ai_cookie.hasOwnProperty%28a%29%7C%7C%28ai_cookie%5Ba%5D%3D%7B%7D%29%2Cai_cookie%5Ba%5D.d%3D0%29%2Cai_check_data%5Ba%5D.e%3Dp%29%3Bif%28%22undefined%22%21%3Dtypeof%20d%26%260%3Cd%29%7Bif%28ai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%2Cai_check_data%5Ba%5D.i%3Dd%2Cai_check_data%5Ba%5D.h%3Df%2Cp%3Dc%3D%22%22%2Cai_cookie.hasOwnProperty%28a%29%26%26%0A%28ai_cookie%5Ba%5D.hasOwnProperty%28%22i%22%29%26%26%28p%3Dai_cookie%5Ba%5D.i%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22h%22%29%26%26%28c%3Dai_cookie%5Ba%5D.h%29%29%2C%22%22%3D%3D%3Dp%7C%7Cc%21%3Df%29ai_set_cookie%28a%2C%22i%22%2Cd%29%2Cai_set_cookie%28a%2C%22h%22%2Cf%29%7Delse%20ai_cookie.hasOwnProperty%28a%29%26%26ai_cookie%5Ba%5D.hasOwnProperty%28%22i%22%29%26%26%28ai_set_cookie%28a%2C%22i%22%2C%22%22%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22c%22%29%7C%7Cai_cookie%5Ba%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28a%2C%22h%22%2C%22%22%29%29%3Bif%28%22undefined%22%21%3Dtypeof%20q%26%260%3Cq%26%26%22undefined%22%21%3Dtypeof%20k%26%260%3Ck%29%7Bai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%3Bai_check_data%5Ba%5D.ipt%3Dq%3Bai_check_data%5Ba%5D.it%3D%0Ak%3Bd%3Dc%3D%22%22%3Bai_cookie.hasOwnProperty%28a%29%26%26%28ai_cookie%5Ba%5D.hasOwnProperty%28%22ipt%22%29%26%26%28c%3Dai_cookie%5Ba%5D.ipt%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22it%22%29%26%26%28d%3Dai_cookie%5Ba%5D.it%29%29%3Bif%28%22%22%3D%3D%3Dc%7C%7C%22%22%3D%3D%3Dd%29ai_set_cookie%28a%2C%22ipt%22%2Cq%29%2Cc%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Cai_set_cookie%28a%2C%22it%22%2CMath.round%28c%2B86400%2Ak%29%29%3B0%3Cd%26%26%28c%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Cd%3C%3Dc%26%26%28ai_set_cookie%28a%2C%22ipt%22%2Cq%29%2Cai_set_cookie%28a%2C%22it%22%2CMath.round%28c%2B86400%2Ak%29%29%29%29%7Delse%20ai_cookie.hasOwnProperty%28a%29%26%26%28ai_cookie%5Ba%5D.hasOwnProperty%28%22ipt%22%29%26%26ai_set_cookie%28a%2C%22ipt%22%2C%22%22%29%2C%0Aai_cookie%5Ba%5D.hasOwnProperty%28%22it%22%29%26%26ai_set_cookie%28a%2C%22it%22%2C%22%22%29%29%3Bif%28%22undefined%22%21%3Dtypeof%20w%26%260%3Cw%29%7Bif%28ai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%2Cai_check_data%5Ba%5D.c%3Dw%2Cai_check_data%5Ba%5D.h%3Df%2Cq%3Dc%3D%22%22%2Cai_cookie.hasOwnProperty%28a%29%26%26%28ai_cookie%5Ba%5D.hasOwnProperty%28%22c%22%29%26%26%28q%3Dai_cookie%5Ba%5D.c%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22h%22%29%26%26%28c%3Dai_cookie%5Ba%5D.h%29%29%2C%22%22%3D%3D%3Dq%7C%7Cc%21%3Df%29ai_set_cookie%28a%2C%22c%22%2Cw%29%2Cai_set_cookie%28a%2C%22h%22%2Cf%29%7Delse%20ai_cookie.hasOwnProperty%28a%29%26%26ai_cookie%5Ba%5D.hasOwnProperty%28%22c%22%29%26%26%28ai_set_cookie%28a%2C%22c%22%2C%22%22%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22i%22%29%7C%7C%0Aai_cookie%5Ba%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28a%2C%22h%22%2C%22%22%29%29%3Bif%28%22undefined%22%21%3Dtypeof%20t%26%260%3Ct%26%26%22undefined%22%21%3Dtypeof%20r%26%260%3Cr%29%7Bai_check_data.hasOwnProperty%28a%29%7C%7C%28ai_check_data%5Ba%5D%3D%7B%7D%29%3Bai_check_data%5Ba%5D.cpt%3Dt%3Bai_check_data%5Ba%5D.ct%3Dr%3Bf%3Dw%3D%22%22%3Bai_cookie.hasOwnProperty%28a%29%26%26%28ai_cookie%5Ba%5D.hasOwnProperty%28%22cpt%22%29%26%26%28w%3Dai_cookie%5Ba%5D.cpt%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22ct%22%29%26%26%28f%3Dai_cookie%5Ba%5D.ct%29%29%3Bif%28%22%22%3D%3D%3Dw%7C%7C%22%22%3D%3D%3Df%29ai_set_cookie%28a%2C%22cpt%22%2Ct%29%2Cc%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Cai_set_cookie%28a%2C%22ct%22%2CMath.round%28c%2B86400%2Ar%29%29%3B0%3Cf%26%26%0A%28c%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Cf%3C%3Dc%26%26%28ai_set_cookie%28a%2C%22cpt%22%2Ct%29%2Cai_set_cookie%28a%2C%22ct%22%2CMath.round%28c%2B86400%2Ar%29%29%29%29%7Delse%20ai_cookie.hasOwnProperty%28a%29%26%26%28ai_cookie%5Ba%5D.hasOwnProperty%28%22cpt%22%29%26%26ai_set_cookie%28a%2C%22cpt%22%2C%22%22%29%2Cai_cookie%5Ba%5D.hasOwnProperty%28%22ct%22%29%26%26ai_set_cookie%28a%2C%22ct%22%2C%22%22%29%29%3Bif%28%22undefined%22%21%3Dtypeof%20u%26%260%3Cu%26%26%22undefined%22%21%3Dtypeof%20x%26%260%3Cx%29%7Bai_check_data.hasOwnProperty%28%22G%22%29%7C%7C%28ai_check_data.G%3D%7B%7D%29%3Bai_check_data.G.cpt%3Du%3Bai_check_data.G.ct%3Dx%3Ba%3Dt%3D%22%22%3Bai_cookie.hasOwnProperty%28%22G%22%29%26%26%28ai_cookie.G.hasOwnProperty%28%22cpt%22%29%26%26%0A%28t%3Dai_cookie.G.cpt%29%2Cai_cookie.G.hasOwnProperty%28%22ct%22%29%26%26%28a%3Dai_cookie.G.ct%29%29%3Bif%28%22%22%3D%3D%3Dt%7C%7C%22%22%3D%3D%3Da%29ai_set_cookie%28%22G%22%2C%22cpt%22%2Cu%29%2Cc%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Cai_set_cookie%28%22G%22%2C%22ct%22%2CMath.round%28c%2B86400%2Ax%29%29%3B0%3Ca%26%26%28c%3Dnew%20Date%2Cc%3DMath.round%28c.getTime%28%29%2F1E3%29%2Ca%3C%3Dc%26%26%28ai_set_cookie%28%22G%22%2C%22cpt%22%2Cu%29%2Cai_set_cookie%28%22G%22%2C%22ct%22%2CMath.round%28c%2B86400%2Ax%29%29%29%29%7Delse%20ai_cookie.hasOwnProperty%28%22G%22%29%26%26%28ai_cookie.G.hasOwnProperty%28%22cpt%22%29%26%26ai_set_cookie%28%22G%22%2C%22cpt%22%2C%22%22%29%2Cai_cookie.G.hasOwnProperty%28%22ct%22%29%26%26ai_set_cookie%28%22G%22%2C%22ct%22%2C%22%22%29%29%7D%29%3Be%28%22.ai-check-block%22%29.removeClass%28%22ai-check-block%22%29%3B%0Afor%28var%20b%20in%20ai_cookie%29for%28var%20h%20in%20ai_cookie%5Bb%5D%29if%28%22d%22%3D%3Dh%29%7Bvar%20g%3Dai_cookie%5Bb%5D%5Bh%5D%3B0%3Cg%3Fai_set_cookie%28b%2C%22d%22%2Cg-1%29%3Aai_check_data.hasOwnProperty%28b%29%26%26ai_check_data%5Bb%5D.hasOwnProperty%28%22e%22%29%3Fai_set_cookie%28b%2C%22d%22%2Cai_check_data%5Bb%5D.e-1%29%3Aai_check_data.hasOwnProperty%28b%29%26%26ai_check_data%5Bb%5D.hasOwnProperty%28%22d%22%29%7C%7Cai_set_cookie%28b%2C%22d%22%2C%22%22%29%7D%7D%7Dfunction%20v%28%29%7BArray.prototype.forEach.call%28document.querySelectorAll%28%22%5Bdata-ai%5D%22%29%2Cfunction%28p%29%7Bfor%28var%20f%3D%22%22%2Cd%3D1%3B9%3E%3Dd%3Bd%2B%2B%29if%28p.hasAttribute%28%22data-ai-%22%2Bd%29%29f%3Dp.getAttribute%28%22data-ai-%22%2Bd%29%3B%0Aelse%20break%3B%22%22%21%3Df%26%26p.setAttribute%28%22data-ai%22%2Cf%29%7D%29%3Bif%28F%29%7Bvar%20b%3Ddocument.documentElement.clientWidth%2Ch%3Dwindow.innerWidth%2Cg%3Db%3Ch%3Fh%3Ab%2Ca%3D0%3Be.each%28G%2Cfunction%28p%2Cf%29%7Bif%28g%3E%3Df%29return%20a%3DH%5Bp%5D%2C%211%7D%29%3Bb%3DjQuery%28b64d%28%22Ym9keQ%3D%3D%22%29%29.attr%28b64d%20%28%27ZGF0YS1kYXRhLW1hc2s%3D%27%29%29%3Bif%28%22string%22%3D%3D%3Dtypeof%20b%29var%20c%3Db%3D%3Db64d%28%22bWFzaw%3D%3D%22%29%3B%22string%22%3D%3D%3Dtypeof%20b%26%26%22boolean%22%3D%3D%3Dtypeof%20c%26%26c%26%26%28A%26%26l%28%22ad%20blocking%22%2C0%2CI%5Ba-1%5D%2C0%2C0%2C%22%22%2C%210%29%2Ca%7C%3D128%29%3BD%3D%5B0%2Ca%5D%7Dn%28%29%3Bai_process_impressions%28%29%3B0%21%3DD.length%26%26z%26%26e.ajax%28%7Burl%3AE%2Ctype%3A%22post%22%2Cdata%3A%7Baction%3A%22ai_ajax%22%2Cai_check%3A%229bfc3d7aee%22%2Cviews%3A%5B0%5D%2C%0Aversions%3A%5Ba%5D%7D%2Casync%3A%210%7D%29.done%28function%28p%29%7B%7D%29%3Bai_tracking_finished%3D%210%7Dvar%20z%3D1%2CA%3D0%2CF%3D0%2CC%3D1%2CG%3D%5B980%2C768%2C0%5D%2CH%3D%5B1%2C2%2C3%5D%2CI%3DJSON.parse%28b64d%28%22WyJEZXNrdG9wIiwiVGFibGV0IiwiUGhvbmUiXQ%3D%3D%22%29%29%2CE%3D%22%2Fwp-admin%2Fadmin-ajax.php%22%3B0%26%26%28E%2B%3D%22%3Fai-debug-tracking%3D1%22%29%3BNumber.isInteger%3DNumber.isInteger%7C%7Cfunction%28b%29%7Breturn%22number%22%3D%3D%3Dtypeof%20b%26%26isFinite%28b%29%26%26Math.floor%28b%29%3D%3D%3Db%7D%3Bai_install_standard_click_trackers%3Dfunction%28b%29%7B%22undefined%22%3D%3D%0Atypeof%20b%26%26%28b%3De%28%22body%22%29%29%3Bb%3De%28%22div.ai-track%5Bdata-ai%5D%3Avisible%22%2Cb%29%3Bvar%20h%3De%28%29%3Bb.each%28function%28%29%7B0%3D%3De%28this%29.find%28%22div.ai-lazy%2C%20div.ai-manual%2C%20div.ai-list-manual%2C%20div.ai-manual-auto%2C%20div.ai-delayed%22%29.length%26%26%28h%3Dh.add%28e%28this%29%29%29%7D%29%3Bb%3Dh%3Bb.removeClass%28%22ai-track%22%29%3Bb%3Db.find%28%22a%22%29%3B0%21%3Db.length%26%26%28C%3Fb.click%28function%28%29%7Bfor%28var%20g%3De%28this%29.closest%28%22div%5Bdata-ai%5D%22%29%3B%22undefined%22%21%3Dtypeof%20g.attr%28%22data-ai%22%29%3B%29%7Bvar%20a%3DJSON.parse%28b64d%28g.attr%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20a%26%26a.constructor%3D%3D%3DArray%26%26Number.isInteger%28a%5B1%5D%29%26%26%21g.hasClass%28%22clicked%22%29%26%26%0A%28g.addClass%28%22clicked%22%29%2Cm%28a%2C%22a.click%22%29%29%3Bg%3Dg.parent%28%29.closest%28%22div%5Bdata-ai%5D%22%29%7D%7D%29%3Ab.click%28function%28%29%7Bfor%28var%20g%3De%28this%29.closest%28%22div%5Bdata-ai%5D%22%29%3B%22undefined%22%21%3Dtypeof%20g.attr%28%22data-ai%22%29%3B%29%7Bvar%20a%3DJSON.parse%28b64d%28g.attr%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20a%26%26a.constructor%3D%3D%3DArray%26%26Number.isInteger%28a%5B1%5D%29%26%26%28m%28a%2C%22a.click%22%29%2Cclicked%3D%210%29%3Bg%3Dg.parent%28%29.closest%28%22div%5Bdata-ai%5D%22%29%7D%7D%29%29%7D%3Bai_install_click_trackers%3Dfunction%28b%29%7B%22undefined%22%3D%3Dtypeof%20b%26%26%28b%3De%28%22body%22%29%29%3Bif%28C%29%7Bvar%20h%3De%28%22div.ai-track%5Bdata-ai%5D%3Avisible%2C%20div.ai-rotate%5Bdata-info%5D%3Avisible%20div.ai-track%5Bdata-ai%5D%22%2C%0Ab%29%3B%22undefined%22%21%3Dtypeof%20e%28b%29.attr%28%22data-ai%22%29%26%26e%28b%29.hasClass%28%22ai-track%22%29%26%26e%28b%29.is%28%22%3Avisible%22%29%26%26%28h%3Dh.add%28b%29%29%3Bvar%20g%3De%28%29%3Bh.each%28function%28%29%7B0%3D%3De%28this%29.find%28%22div.ai-lazy%2C%20div.ai-manual%2C%20div.ai-list-manual%2C%20div.ai-manual-auto%2C%20div.ai-delayed%22%29.length%26%26%28g%3Dg.add%28e%28this%29%29%29%7D%29%3Bh%3Dg%3Bh.removeClass%28%22ai-track%22%29%3B0%21%3Dh.length%26%26h.iframeTracker%28%7BblurCallback%3Afunction%28%29%7Bif%28null%21%3Dthis.ai_data%26%26null%21%3Dwrapper%26%26%21wrapper.hasClass%28%22clicked%22%29%29%7Bwrapper.addClass%28%22clicked%22%29%3Bm%28this.ai_data%2C%22blurCallback%22%29%3Bfor%28var%20a%3Dwrapper.find%28%22div%5Bdata-ai%5D%3Avisible%22%29%3B%22undefined%22%21%3D%0Atypeof%20a.attr%28%22data-ai%22%29%3B%29%7Bvar%20c%3DJSON.parse%28b64d%28a.attr%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20c%26%26c.constructor%3D%3D%3DArray%26%26Number.isInteger%28c%5B1%5D%29%26%26m%28c%2C%22blurCallback%20INNER%22%29%3Ba%3Da.find%28%22div%5Bdata-ai%5D%3Avisible%22%29%7D%7D%7D%2CoverCallback%3Afunction%28a%29%7Ba%3De%28a%29.closest%28%22div%5Bdata-ai%5D%22%29%3Bif%28%22undefined%22%21%3Dtypeof%20a.attr%28%22data-ai%22%29%29%7Bvar%20c%3DJSON.parse%28b64d%28a.attr%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20c%26%26c.constructor%3D%3D%3DArray%26%26Number.isInteger%28c%5B1%5D%29%3F%28wrapper%3Da%2Cthis.ai_data%3Dc%29%3A%28null%21%3Dwrapper%26%26wrapper.removeClass%28%22clicked%22%29%2Cthis.ai_data%3Dwrapper%3D%0Anull%29%7D%7D%2CoutCallback%3Afunction%28a%29%7Bnull%21%3Dwrapper%26%26wrapper.removeClass%28%22clicked%22%29%3Bthis.ai_data%3Dwrapper%3Dnull%7D%2CfocusCallback%3Afunction%28a%29%7Bif%28null%21%3Dthis.ai_data%26%26null%21%3Dwrapper%26%26%21wrapper.hasClass%28%22clicked%22%29%29for%28wrapper.addClass%28%22clicked%22%29%2Cm%28this.ai_data%2C%22focusCallback%22%29%2Ca%3Dwrapper.find%28%22div%5Bdata-ai%5D%3Avisible%22%29%3B%22undefined%22%21%3Dtypeof%20a.attr%28%22data-ai%22%29%3B%29%7Bvar%20c%3DJSON.parse%28b64d%28a.attr%28%22data-ai%22%29%29%29%3B%22undefined%22%21%3D%3Dtypeof%20c%26%26c.constructor%3D%3D%3DArray%26%26Number.isInteger%28c%5B1%5D%29%26%26m%28c%2C%22focusCallback%20INNER%22%29%3Ba%3Da.find%28%22div%5Bdata-ai%5D%3Avisible%22%29%7D%7D%2C%0Awrapper%3Anull%2Cai_data%3Anull%2Cblock%3Anull%2Cversion%3Anull%7D%29%7Dai_install_standard_click_trackers%28b%29%7D%3Bvar%20D%3D%5B%5D%3Bai_process_impressions%3Dfunction%28b%29%7B%22undefined%22%3D%3Dtypeof%20b%26%26%28b%3De%28%22body%22%29%29%3Bvar%20h%3D%5B%5D%2Cg%3D%5B%5D%2Ca%3D%5B%5D%2Cc%3D%5B%5D%2Cp%3D%5B%5D%3B0%21%3DD.length%26%26%28h.push%28D%5B0%5D%29%2Cg.push%28D%5B1%5D%29%2Ca.push%28%22Pageviews%22%29%2Cp.push%280%29%2Cc.push%28%22%22%29%29%3Bvar%20f%3De%28%22div.ai-track%5Bdata-ai%5D%3Avisible%2C%20div.ai-rotate%5Bdata-info%5D%3Avisible%20div.ai-track%5Bdata-ai%5D%22%2Cb%29%3B%22undefined%22%21%3Dtypeof%20e%28b%29.attr%28%22data-ai%22%29%26%26e%28b%29.hasClass%28%22ai-track%22%29%26%26e%28b%29.is%28%22%3Avisible%22%29%26%26%28f%3Df.add%28b%29%29%3B0%21%3Df.length%26%26e%28f%29.each%28function%28%29%7Bif%28%22undefined%22%21%3D%0Atypeof%20e%28this%29.attr%28%22data-ai%22%29%29%7Bvar%20k%3DJSON.parse%28b64d%28e%28this%29.attr%28%22data-ai%22%29%29%29%3Bif%28%22undefined%22%21%3D%3Dtypeof%20k%26%26k.constructor%3D%3D%3DArray%29%7Bvar%20w%3D0%2Ct%3De%28this%29.find%28%22div.ai-rotate%5Bdata-info%5D%22%29%3B1%3D%3Dt.length%26%26%28w%3DJSON.parse%28b64d%28t.data%28%22info%22%29%29%29%5B1%5D%29%3Bif%28Number.isInteger%28k%5B0%5D%29%26%260%21%3Dk%5B0%5D%26%26Number.isInteger%28k%5B1%5D%29%29%7Bt%3D0%3Bvar%20r%3De%28this%29.hasClass%28%22ai-no-tracking%22%29%2Cu%3DjQuery%28b64d%28%22Ym9keQ%3D%3D%22%29%29.attr%28b64d%20%28%27ZGF0YS1kYXRhLW1hc2s%3D%27%29%29%3Bif%28%22string%22%3D%3D%3Dtypeof%20u%29var%20x%3Du%3D%3Db64d%28%22bWFzaw%3D%3D%22%29%3Bif%28%22string%22%3D%3D%3Dtypeof%20u%26%26%22boolean%22%3D%3D%3Dtypeof%20x%29%7Bvar%20B%3De%28this%29.outerHeight%28%29%3B%0Au%3De%28this%29.find%28%22.ai-attributes%22%29%3Bu.length%26%26u.each%28function%28%29%7BB%3E%3De%28this%29.outerHeight%28%29%26%26%28B-%3De%28this%29.outerHeight%28%29%29%7D%29%3Bu%3De%28this%29.find%28%22.ai-code%22%29%3Bu.length%26%26%28B%3D0%2Cu.each%28function%28%29%7BB%2B%3De%28this%29.outerHeight%28%29%7D%29%29%3Bx%26%260%3D%3D%3DB%26%26%28t%3D128%29%7D0%21%3De%28this%29.find%28%22div.ai-lazy%2C%20div.ai-manual%2C%20div.ai-list-manual%2C%20div.ai-manual-auto%2C%20div.ai-delayed%22%29.length%26%26%28r%3D%210%29%3Bif%28%21r%29if%280%3D%3Dw%29h.push%28k%5B0%5D%29%2Cg.push%28k%5B1%5D%7Ct%29%2Ca.push%28k%5B2%5D%29%2Cc.push%28k%5B3%5D%29%2Cp.push%28k%5B4%5D%29%3Belse%20for%28x%3D1%3Bx%3C%3Dw%3Bx%2B%2B%29h.push%28k%5B0%5D%29%2Cg.push%28x%7Ct%29%2Ca.push%28k%5B2%5D%29%2Cc.push%28k%5B3%5D%29%2Cp.push%28k%5B4%5D%29%7D%7D%7D%7D%29%3B%0Aai_cookie%3Dai_load_cookie%28%29%3Bfor%28var%20d%20in%20ai_cookie%29if%28h.includes%28parseInt%28d%29%29%29for%28var%20q%20in%20ai_cookie%5Bd%5D%29%22i%22%3D%3Dq%3F%28b%3Dai_cookie%5Bd%5D%5Bq%5D%2C0%3Cb%26%26%281%3D%3Db%3F%28b%3Dnew%20Date%2Cb%3DMath.round%28b.getTime%28%29%2F1E3%29%2B604800%2Cai_set_cookie%28d%2C%22i%22%2C-b%29%29%3Aai_set_cookie%28d%2C%22i%22%2Cb-1%29%29%29%3A%22ipt%22%3D%3Dq%26%26%28b%3Dai_cookie%5Bd%5D%5Bq%5D%2C0%3Cb%3Fai_set_cookie%28d%2C%22ipt%22%2Cb-1%29%3Aai_check_data.hasOwnProperty%28d%29%26%26ai_check_data%5Bd%5D.hasOwnProperty%28%22ipt%22%29%26%26ai_check_data%5Bd%5D.hasOwnProperty%28%22it%22%29%3Fai_cookie.hasOwnProperty%28d%29%26%26ai_cookie%5Bd%5D.hasOwnProperty%28%22it%22%29%26%26%28b%3Dnew%20Date%2C0%3E%3Dai_cookie%5Bd%5D.it-%0AMath.round%28b.getTime%28%29%2F1E3%29%26%26%28b%3DMath.round%28b.getTime%28%29%2F1E3%29%2Cai_set_cookie%28d%2C%22ipt%22%2Cai_check_data%5Bd%5D.ipt%29%2Cai_set_cookie%28d%2C%22it%22%2CMath.round%28b%2B86400%2Aai_check_data%5Bd%5D.it%29%29%29%29%3A%28ai_cookie.hasOwnProperty%28d%29%26%26ai_cookie%5Bd%5D.hasOwnProperty%28%22ipt%22%29%26%26ai_set_cookie%28d%2C%22ipt%22%2C%22%22%29%2Cai_cookie.hasOwnProperty%28d%29%26%26ai_cookie%5Bd%5D.hasOwnProperty%28%22it%22%29%26%26ai_set_cookie%28d%2C%22it%22%2C%22%22%29%29%29%3Bif%28h.length%26%26%28z%26%26%22undefined%22%3D%3D%3Dtypeof%20ai_internal_tracking_no_impressions%26%26%28D%3D%5B%5D%2Ce.ajax%28%7Burl%3AE%2Ctype%3A%22post%22%2Cdata%3A%7Baction%3A%22ai_ajax%22%2Cai_check%3A%229bfc3d7aee%22%2C%0Aviews%3Ah%2Cversions%3Ag%7D%2Casync%3A%210%7D%29.done%28function%28k%29%7Bk%3Dk.trim%28%29%3Bif%28%22%22%21%3Dk%26%26%28k%3DJSON.parse%28k%29%2C%22undefined%22%21%3Dtypeof%20k%5B%22%23%22%5D%29%29%7Bai_cookie%3Dai_load_cookie%28%29%3Bvar%20w%3DMath.round%28%28new%20Date%29.getTime%28%29%2F1E3%29%2B43200%2Ct%3D%5B%5D%2Cr%3Bfor%28r%20in%20k%5B%22%23%22%5D%29ai_cookie.hasOwnProperty%28k%5B%22%23%22%5D%5Br%5D%29%26%26ai_cookie%5Bk%5B%22%23%22%5D%5Br%5D%5D.hasOwnProperty%28%22x%22%29%7C%7Cai_set_cookie%28k%5B%22%23%22%5D%5Br%5D%2C%22x%22%2Cw%29%3BsetTimeout%28function%28%29%7Bfor%28index%3D0%3Bindex%3Ct.length%3B%2B%2Bindex%29e%28%22span%5Bdata-ai-block%3D%22%2Bt%5Bindex%5D%2B%22%5D%22%29.closest%28%22div%5Bdata-ai%5D%22%29.remove%28%29%7D%2C50%29%7D%7D%29%29%2CA%26%26%22undefined%22%3D%3D%3Dtypeof%20ai_external_tracking_no_impressions%29%29for%28d%3D%0A0%3Bd%3Ch.length%3Bd%2B%2B%290%21%3Dh%5Bd%5D%26%26l%28%22impression%22%2Ch%5Bd%5D%2Ca%5Bd%5D%2Cp%5Bd%5D%2Cg%5Bd%5D%2Cc%5Bd%5D%2C%210%29%7D%3BjQuery%28window%29.on%28%22load%22%2Cfunction%28%29%7B%22undefined%22%3D%3Dtypeof%20ai_delay_tracking%26%26%28ai_delay_tracking%3D0%29%3BsetTimeout%28v%2Cai_delay_tracking%2B1400%29%3BsetTimeout%28ai_install_click_trackers%2Cai_delay_tracking%2B1500%29%7D%29%7D%29%3B%0Aai_run_142431422714%20%3D%20function%28%29%7B%0Aai_document_write%3Ddocument.write%3Bdocument.write%3Dfunction%28a%29%7B%22interactive%22%3D%3Ddocument.readyState%3F%28console.error%28%22document.write%20called%20after%20page%20load%3A%20%22%2Ca%29%2C%22undefined%22%21%3Dtypeof%20ai_js_errors%26%26ai_js_errors.push%28%5B%22document.write%20called%20after%20page%20load%22%2Ca%2C0%5D%29%29%3Aai_document_write.call%28document%2Ca%29%7D%3B%0D%0Aai_check_and_insert_block%20%282%2C%20%27ai-check-2-38316046%27%29%3B%0Aai_check_and_insert_block%20%281%2C%20%27ai-check-1-35121929%27%29%3B%0Aai_check_and_insert_block%20%283%2C%20%27ai-check-3-75688688%27%29%3B%0A%7D%3B%0Aif%20%28document.readyState%20%3D%3D%3D%20%27complete%27%20%7C%7C%20%28document.readyState%20%21%3D%3D%20%27loading%27%20%26%26%20%21document.documentElement.doScroll%29%29%20ai_run_142431422714%20%28%29%3B%20else%20document.addEventListener%20%28%27DOMContentLoaded%27%2C%20ai_run_142431422714%29%3B%0Aai_js_code%20%3D%20true%3B%0A%7D%0D%0Afunction%20ai_wait_for_jquery%28%29%7Bfunction%20b%28f%2Cc%29%7Bvar%20a%3Ddocument.createElement%28%22script%22%29%3Ba.src%3Df%3Bvar%20d%3Ddocument.getElementsByTagName%28%22head%22%29%5B0%5D%2Ce%3D%211%3Ba.onload%3Da.onreadystatechange%3Dfunction%28%29%7Be%7C%7Cthis.readyState%26%26%22loaded%22%21%3Dthis.readyState%26%26%22complete%22%21%3Dthis.readyState%7C%7C%28e%3D%210%2Cc%26%26c%28%29%2Ca.onload%3Da.onreadystatechange%3Dnull%2Cd.removeChild%28a%29%29%7D%3Bd.appendChild%28a%29%7Dwindow.jQuery%26%26window.jQuery.fn%3Fai_run_scripts%28%29%3A%28ai_jquery_waiting_counter%2B%2B%2C4%3D%3Dai_jquery_waiting_counter%26%26b%28%22https%3A%2F%2Ftechpp.com%2Fwp-includes%2Fjs%2Fjquery%2Fjquery.min.js%3Fver%3D5.8.2%22%2Cfunction%28%29%7Bb%28%22https%3A%2F%2Ftechpp.com%2Fwp-includes%2Fjs%2Fjquery%2Fjquery-migrate.min.js%3Fver%3D5.8.2%22%2C%0D%0Anull%29%7D%29%2C30%3Eai_jquery_waiting_counter%26%26setTimeout%28function%28%29%7Bai_wait_for_jquery%28%29%7D%2C50%29%29%7Dai_jquery_waiting_counter%3D0%3Bai_wait_for_jquery%28%29%3B%0D%0A%0A" type="text/javascript" defer></script>
<!-- /WP_FOOTER --> 
<script>(function(){const dpi=window.devicePixelRatio>1?2:1;const images=document.querySelectorAll("img[data-origin-src]");images.forEach(function(image){const image_width=image.offsetWidth*dpi;const render_width=Math.ceil(image_width/100)*100;const origin_src=image.getAttribute("data-origin-src");image.src=`${origin_src}?width=${render_width}`})})();(function(){const events=["mouseover","keydown","touchstart","touchmove","wheel"];const elements=document.querySelectorAll("[data-lazy-method='interaction']");if(!elements.length)return;function load_elements(){clearTimeout(timeout);events.forEach(function(event){window.removeEventListener(event,load_elements,{passive:true})});elements.forEach(function(element){element.getAttribute("data-lazy-attributes").split(",").forEach(function(attribute){const value=element.getAttribute("data-lazy-".concat(attribute));element.setAttribute(attribute,value)})})}const timeout=setTimeout(load_elements,1e4);events.forEach(function(event){window.addEventListener(event,load_elements,{passive:true})})})();(function(){const observer=new IntersectionObserver(function(elements){elements.forEach(function(element){if(element.isIntersecting){observer.unobserve(element.target);element.target.getAttribute("data-lazy-attributes").split(",").forEach(function(attribute){const value=element.target.getAttribute("data-lazy-".concat(attribute));element.target.setAttribute(attribute,value)})}})},{rootMargin:"300px"});document.querySelectorAll("[data-lazy-method='viewport']").forEach(function(element){observer.observe(element)})})();</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'6bd53b659a6957eb',m:'1rhg1V_zFITlH.3IL5b4SYpkd9c5r1Aqicfu1VykKdI-1639461837-0-AZimWrcSgaGB17HSpe68jlLoelfy2y4ECZuE0WlE/d/h9rxV6KbkfcDb4LJHz9udq2mt/ggT1FsHDKwWQHaCGsF9Jpopz9aodJRYAUjztZmwdoF7sEerIap1rgAbcCSPNKeox/Q42pdIG8rtostz277t8QCJ45vutvI2vX8XWoqVSfzcZRiHN2OCgUg0lJftKA==',s:[0xc383b2d2ef,0xa28995b57d],u:'/cdn-cgi/challenge-platform/h/b'}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v64f9daad31f64f81be21cbef6184a5e31634941392597" integrity="sha512-gV/bogrUTVP2N3IzTDKzgP0Js1gg4fbwtYB6ftgLbKQu/V8yH2+lrKCfKHelh4SO3DPzKj4/glTO+tNJGDnb0A==" data-cf-beacon='{"rayId":"6bd53b659a6957eb","version":"2021.12.0","r":1,"token":"af843218bdbf43e2bdfc446d65f061ff","si":100}' crossorigin="anonymous"></script>
</body>
</html>